]> git.pld-linux.org Git - packages/abseil-cpp.git/blob - abseil-cpp.spec
- updated to 20220623.1 (new sonames)
[packages/abseil-cpp.git] / abseil-cpp.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static libraries
4 #
5 Summary:        Abseil - C++ common libraries
6 Summary(pl.UTF-8):      Abseil - wspólne biblioteki C++
7 Name:           abseil-cpp
8 Version:        20220623.1
9 Release:        1
10 License:        Apache v2.0
11 Group:          Libraries
12 #Source0Download: https://github.com/abseil/abseil-cpp/releases
13 Source0:        https://github.com/abseil/abseil-cpp/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  2aea7c1171c4c280f755de170295afd6
15 URL:            https://abseil.io/
16 BuildRequires:  cmake >= 3.8
17 BuildRequires:  libstdc++-devel >= 6:7
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 # refers to _ZN4absl12lts_2021110213cord_internal17cordz_next_sampleE non-function symb ol from libabsl_condz_functions
21 %define         skip_post_check_so      libabsl_cord.so.*
22
23 %description
24 Abseil is an open-source collection of C++ library code designed to
25 augment the C++ standard library. The Abseil library code is collected
26 from Google's own C++ code base, has been extensively tested and used
27 in production.
28
29 %description -l pl.UTF-8
30 Abseil to zbiór bibliotek C++ o otwartych źródłach, zaprojektowancych
31 jako uzupełnienie biblioteki standardowej C++. Kod bibliotek został
32 zebrany z własnego kodu C++ Google'a, obszernie przetestowany i jest
33 używany produkcyjnie.
34
35 %package devel
36 Summary:        Header files for Abseil libraries
37 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Abseil
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       libstdc++-devel >= 6:7
41
42 %description devel
43 Header files for Abseil libraries.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe bibliotek Abseil.
47
48 %package static
49 Summary:        Static Abseil libraries
50 Summary(pl.UTF-8):      Statyczne biblioteki Abseil
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static Abseil libraries.
56
57 %description static -l pl.UTF-8
58 Statyczne biblioteki Abseil.
59
60 %prep
61 %setup -q
62
63 %build
64 %if %{with static_libs}
65 install -d build-static
66 cd build-static
67 %cmake .. \
68         -DABSL_PROPAGATE_CXX_STD=ON \
69         -DBUILD_SHARED_LIBS=OFF \
70         -DCMAKE_CXX_STANDARD=17
71
72 %{__make}
73 cd ..
74 %endif
75
76 install -d build
77 cd build
78 %cmake .. \
79         -DABSL_PROPAGATE_CXX_STD=ON \
80         -DCMAKE_CXX_STANDARD=17
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %if %{with static_libs}
88 %{__make} -C build-static install \
89         DESTDIR=$RPM_BUILD_ROOT
90 %endif
91
92 %{__make} -C build install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc AUTHORS FAQ.md README.md
104 %attr(755,root,root) %{_libdir}/libabsl_*.so.*.*.*
105
106 %files devel
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/libabsl_*.so
109 %{_includedir}/absl
110 %{_libdir}/cmake/absl
111 %{_pkgconfigdir}/absl_*.pc
112
113 %if %{with static_libs}
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/libabsl_*.a
117 %endif
This page took 0.067448 seconds and 4 git commands to generate.