]> git.pld-linux.org Git - packages/abseil-cpp.git/blob - abseil-cpp.spec
9f695c70d6947672d8bf8908d0b7c0fe42e78885
[packages/abseil-cpp.git] / abseil-cpp.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static libraries
4 #
5 Summary:        Abseil - C++ common libraries
6 Summary(pl.UTF-8):      Abseil - wspólne biblioteki C++
7 Name:           abseil-cpp
8 Version:        20210324.2
9 Release:        1
10 License:        Apache v2.0
11 Group:          Libraries
12 #Source0Download: https://github.com/abseil/abseil-cpp/releases
13 Source0:        https://github.com/abseil/abseil-cpp/archive/refs/tags/%{version}.tar.gz
14 # Source0-md5:  e0b585398b89ee92a10d8c68ef7eed48
15 URL:            https://abseil.io/
16 BuildRequires:  cmake >= 3.5
17 BuildRequires:  libstdc++-devel >= 6:4.7
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Abseil is an open-source collection of C++ library code designed to
22 augment the C++ standard library. The Abseil library code is collected
23 from Google's own C++ code base, has been extensively tested and used
24 in production.
25
26 %description -l pl.UTF-8
27 Abseil to zbiór bibliotek C++ o otwartych źródłach, zaprojektowancych
28 jako uzupełnienie biblioteki standardowej C++. Kod bibliotek został
29 zebrany z własnego kodu C++ Google'a, obszernie przetestowany i jest
30 używany produkcyjnie.
31
32 %package devel
33 Summary:        Header files for Abseil libraries
34 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Abseil
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       libstdc++-devel >= 6:4.7
38
39 %description devel
40 Header files for Abseil libraries.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe bibliotek Abseil.
44
45 %package static
46 Summary:        Static Abseil libraries
47 Summary(pl.UTF-8):      Statyczne biblioteki Abseil
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static Abseil libraries.
53
54 %description static -l pl.UTF-8
55 Statyczne biblioteki Abseil.
56
57 %prep
58 %setup -q
59
60 %build
61 %if %{with static_libs}
62 install -d build-static
63 cd build-static
64 %cmake .. \
65         -DBUILD_SHARED_LIBS=OFF
66
67 %{__make}
68 cd ..
69 %endif
70
71 install -d build
72 cd build
73 %cmake ..
74
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %if %{with static_libs}
81 %{__make} -C build-static install \
82         DESTDIR=$RPM_BUILD_ROOT
83 %endif
84
85 %{__make} -C build install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc AUTHORS FAQ.md README.md
97 %attr(755,root,root) %{_libdir}/libabsl_*.so.*.*.*
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/libabsl_*.so
102 %{_includedir}/absl
103 %{_libdir}/cmake/absl
104 %{_pkgconfigdir}/absl_*.pc
105
106 %if %{with static_libs}
107 %files static
108 %defattr(644,root,root,755)
109 %{_libdir}/libabsl_*.a
110 %endif
This page took 0.098414 seconds and 3 git commands to generate.