]> git.pld-linux.org Git - packages/abrt.git/commitdiff
- updated to 2.14.4 auto/th/abrt-2.14.4-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 17 Oct 2020 06:44:10 +0000 (08:44 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 17 Oct 2020 06:44:10 +0000 (08:44 +0200)
- updated rpm5 patch

abrt-rpm5.patch
abrt.spec

index 889d11414f2886c6bca1abf65dc0a332605fa693..573d1e8bc4bea2525b1438d8ff208425ea3459fa 100644 (file)
@@ -8,9 +8,9 @@
      $(GLIB_CFLAGS) \
      $(LIBREPORT_CFLAGS) \
      -D_GNU_SOURCE \
---- abrt-2.8.2/src/daemon/rpm.c.orig   2016-07-08 09:49:44.000000000 +0200
-+++ abrt-2.8.2/src/daemon/rpm.c        2016-08-03 20:51:03.649708165 +0200
-@@ -22,10 +22,10 @@
+--- abrt-2.14.4/src/daemon/rpm.c.orig  2020-08-17 16:37:07.000000000 +0200
++++ abrt-2.14.4/src/daemon/rpm.c       2020-10-17 08:24:59.359365923 +0200
+@@ -20,10 +20,10 @@
  #include "rpm.h"
  
  #ifdef HAVE_LIBRPM
  #endif
  
  /**
-@@ -62,7 +62,6 @@ void rpm_init()
- void rpm_destroy()
+@@ -72,7 +72,6 @@ void rpm_destroy()
  {
+ #ifdef HAVE_LIBRPM
      /* Mirroring the order of deinit calls in rpm-4.11.1/lib/poptALL.c::rpmcliFini() */
 -    rpmFreeCrypto();
      rpmFreeMacros(NULL);
      rpmFreeRpmrc();
-@@ -102,7 +102,7 @@
+ #endif
+@@ -92,7 +91,7 @@ void rpm_load_gpgkey(const char* filenam
      }
  
      uint8_t keyID[8];
--#if 0
-+#if 1
-     if (pgpPubkeyFingerprint(pkt, pklen, keyID) == 0)
- #else
-     if (pgpPubkeyKeyID(pkt, pklen, keyID) == 0)
-@@ -119,13 +118,20 @@ char *rpm_get_fingerprint(const char *pk
+-    if (pgpPubkeyKeyID(pkt, pklen, keyID) == 0)
++    if (pgpPubkeyFingerprint(pkt, pklen, keyID) == 0)
+     {
+         char *fingerprint = pgpHexStr(keyID, sizeof(keyID));
+         if (fingerprint != NULL)
+@@ -125,13 +124,20 @@ char *rpm_get_fingerprint(const char *pk
      const char *errmsg = NULL;
  
      rpmts ts = rpmtsCreate();
 +              NULL,
 +              &errmsg);
 +
-     if (!pgpsig && errmsg)
+     if (!pgpsig)
      {
-         log_notice("cannot get siggpg:pgpsig. reason: %s", errmsg);
-@@ -138,8 +144,8 @@ char *rpm_get_fingerprint(const char *pk
+         log_notice("cannot get siggpg:pgpsig. reason: %s",
+@@ -144,8 +150,8 @@ char *rpm_get_fingerprint(const char *pk
+         fingerprint = g_strdup(pgpsig_tmp + sizeof(" Key ID ") - 1);
  
  error:
-     free(pgpsig);
 -    rpmdbFreeIterator(iter);
 -    rpmtsFree(ts);
 +    iter = rpmmiFree(iter);
 +    ts = rpmtsFree(ts);
      return fingerprint;
- }
-@@ -156,8 +162,8 @@ bool CheckHash(const char* pPackage, con
+ #else
+     return NULL;
+@@ -165,8 +171,8 @@ bool CheckHash(const char* pPackage, con
  {
      bool ret = true;
      rpmts ts = rpmtsCreate();
@@ -88,7 +88,7 @@
      if (header == NULL)
          goto error;
  
-@@ -177,14 +183,14 @@ bool CheckHash(const char* pPackage, con
+@@ -186,14 +192,14 @@ bool CheckHash(const char* pPackage, con
      }
      rpmfiFree(fi);
  error:
          const char *filename, const char *rootdir_or_NULL)
  {
      const char *queryname = filename;
-@@ -191,11 +197,7 @@ static int rpm_query_file(rpmts *ts, rpm
+@@ -201,11 +207,7 @@ static int rpm_query_file(rpmts *ts, rpm
      *ts = rpmtsCreate();
      if (rootdir_or_NULL)
      {
  
          unsigned len = strlen(rootdir_or_NULL);
          /* remove 'chroot' prefix */
-@@ -204,12 +206,12 @@ static int rpm_query_file(rpmts *ts, rpm
+@@ -214,12 +216,12 @@ static int rpm_query_file(rpmts *ts, rpm
      }
  
      *iter = rpmtsInitIterator(*ts, RPMTAG_BASENAMES, queryname, 0);
  
          return rpm_query_file(ts, iter, header, filename, NULL);
      }
-@@ -222,8 +224,8 @@ char* rpm_get_component(const char *file
+@@ -234,8 +236,8 @@ char* rpm_get_component(const char *file
      char *ret = NULL;
-     char *srpm = NULL;
+     g_autofree char *srpm = NULL;
      rpmts ts;
 -    rpmdbMatchIterator iter;
 -    Header header;
  
      if (rpm_query_file(&ts, &iter, &header, filename, rootdir_or_NULL) < 0)
          return NULL;
-@@ -232,7 +234,7 @@ char* rpm_get_component(const char *file
+@@ -244,7 +246,7 @@ char* rpm_get_component(const char *file
          goto error;
  
      const char *errmsg = NULL;
      if (!srpm && errmsg)
      {
          error_msg("cannot get srpm. reason: %s", errmsg);
-@@ -243,8 +245,8 @@ char* rpm_get_component(const char *file
-     free(srpm);
+@@ -254,8 +256,8 @@ char* rpm_get_component(const char *file
+     ret = get_package_name_from_NVR_or_NULL(srpm);
  
   error:
 -    rpmdbFreeIterator(iter);
 +    iter = rpmmiFree(iter);
 +    ts = rpmtsFree(ts);
      return ret;
- }
-@@ -252,7 +254,7 @@ char* rpm_get_component(const char *file
-     static inline int pkg_add_##name(Header header, struct pkg_envra *p) \
+ #else
+     return NULL;
+@@ -267,7 +269,7 @@ char* rpm_get_component(const char *file
+     static inline int pkg_add_##name(Header header, struct pkg_nevra *p) \
      {                                                                   \
          const char *errmsg = NULL;                                      \
 -        p->p_##name = headerFormat(header, "%{"#name"}", &errmsg);      \
          if (p->p_##name || !errmsg)                                     \
              return 0;                                                   \
                                                                          \
-@@ -272,8 +274,8 @@ pkg_add_id(vendor);
- struct pkg_envra *rpm_get_package_nvr(const char *filename, const char *rootdir_or_NULL)
+@@ -289,8 +291,8 @@ struct pkg_nevra *rpm_get_package_nvr(co
  {
+ #ifdef HAVE_LIBRPM
      rpmts ts;
 -    rpmdbMatchIterator iter;
 -    Header header;
 +    rpmmi iter = NULL;
 +    Header header = NULL;
  
-     struct pkg_envra *p = NULL;
-@@ -320,15 +322,15 @@ struct pkg_envra *rpm_get_package_nvr(co
+     struct pkg_nevra *p = NULL;
  
-     p->p_nvr = xasprintf("%s-%s-%s", p->p_name, p->p_version, p->p_release);
+@@ -341,15 +343,15 @@ struct pkg_nevra *rpm_get_package_nvr(co
+     else
+         p->p_nvr = g_strdup_printf("%s:%s-%s-%s", p->p_name, p->p_epoch, p->p_version, p->p_release);
  
 -    rpmdbFreeIterator(iter);
 -    rpmtsFree(ts);
      return p;
  
   error:
-     free_pkg_envra(p);
+     free_pkg_nevra(p);
  
 -    rpmdbFreeIterator(iter);
 -    rpmtsFree(ts);
 +    iter = rpmmiFree(iter);
 +    ts = rpmtsFree(ts);
      return NULL;
- }
+ #else
+     return NULL;
 --- abrt-2.0.15/src/plugins/bodhi.c~   2012-10-05 08:30:34.000000000 +0200
 +++ abrt-2.0.15/src/plugins/bodhi.c    2012-10-15 15:54:12.298943477 +0200
 @@ -331,24 +331,23 @@
index b5ed59945945b1dfa37a18230ec7794882097414..44b8ce7d9bdeb01fa1bda4fc33497a42029dad8b 100644 (file)
--- a/abrt.spec
+++ b/abrt.spec
@@ -9,13 +9,13 @@
 Summary:       Automatic bug detection and reporting tool
 Summary(pl.UTF-8):     Narzędzie do automatycznego wykrywania i zgłaszania błędów
 Name:          abrt
-Version:       2.14.2
+Version:       2.14.4
 Release:       1
 License:       GPL v2+
 Group:         Applications/System
 #Source0Download: https://github.com/abrt/abrt/releases
 Source0:       https://github.com/abrt/abrt/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 5f085a2096e41a8d96e085f1fe823a9b
+# Source0-md5: c7583c001464cb2ec0067afb08cdc6cb
 Source1:       %{name}.init
 Patch0:                %{name}-rpm5.patch
 Patch1:                %{name}-rpm45.patch
@@ -34,7 +34,6 @@ BuildRequires:        gsettings-desktop-schemas-devel >= 3.15.1
 BuildRequires: gtk+3-devel >= 3.0
 BuildRequires: intltool >= 0.35.0
 BuildRequires: json-c-devel
-BuildRequires: libcap-devel
 BuildRequires: libgomp-devel
 BuildRequires: libnotify-devel >= 0.7.0
 BuildRequires: libreport-devel >= %{libreport_ver}
@@ -52,7 +51,7 @@ BuildRequires:        python3-modules >= 1:3.6
 %{?with_tests:BuildRequires:   python3-pytest}
 BuildRequires: rpm-devel >= 4.5-28
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.721
+BuildRequires: rpmbuild(macros) >= 1.752
 BuildRequires: satyr-devel >= 0.21
 BuildRequires: sphinx-pdg-3
 BuildRequires: systemd-devel >= 1:209
@@ -98,9 +97,7 @@ Group:                Applications/Shells
 Requires:      %{name} = %{version}-%{release}
 Requires:      bash-completion
 Requires:      python3-argcomplete
-%if "%{_rpmversion}" >= "4.6"
-BuildArch:     noarch
-%endif
+%{?noarchpackage}
 
 %description -n bash-completion-abrt
 Bash completion for abrt command.
This page took 0.145031 seconds and 4 git commands to generate.