]> git.pld-linux.org Git - packages/aMule.git/commitdiff
- added cryptopp patch (fix for cryptopp 6+, from Gentoo); release 6 auto/th/aMule-2.3.2-6
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 31 Dec 2018 10:16:00 +0000 (11:16 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 31 Dec 2018 10:16:00 +0000 (11:16 +0100)
aMule-cryptopp.patch [new file with mode: 0644]
aMule.spec

diff --git a/aMule-cryptopp.patch b/aMule-cryptopp.patch
new file mode 100644 (file)
index 0000000..29cefb7
--- /dev/null
@@ -0,0 +1,11 @@
+--- aMule-2.3.2/src/ClientCreditsList.cpp.orig 2016-09-16 09:55:06.000000000 +0200
++++ aMule-2.3.2/src/ClientCreditsList.cpp      2018-12-31 11:04:38.491753618 +0100
+@@ -312,7 +312,7 @@
+               // calculate and store public key
+               CryptoPP::RSASSA_PKCS1v15_SHA_Verifier pubkey(*static_cast<CryptoPP::RSASSA_PKCS1v15_SHA_Signer *>(m_pSignkey));
+               CryptoPP::ArraySink asink(m_abyMyPublicKey, 80);
+-              pubkey.DEREncode(asink);
++              pubkey.GetMaterial().Save(asink);
+               m_nMyPublicKeyLen = asink.TotalPutLength();
+               asink.MessageEnd();
+       } catch (const CryptoPP::Exception& e) {
index cf24d775f4fcda983bf03e79a892985b70663d26..c9105a98bce0b002444981ee8c125e450df9bdec 100644 (file)
@@ -5,7 +5,7 @@ Summary:        Unix port of eMule client
 Summary(pl.UTF-8):     Uniksowy port klienta eMule
 Name:          aMule
 Version:       2.3.2
-Release:       5
+Release:       6
 License:       GPL v2+
 Group:         X11/Applications
 Source0:       http://downloads.sourceforge.net/amule/%{name}-%{version}.tar.bz2
@@ -13,6 +13,7 @@ Source0:      http://downloads.sourceforge.net/amule/%{name}-%{version}.tar.bz2
 Patch0:                %{name}-desktop.patch
 Patch1:                %{name}-cas-datadir.patch
 Patch2:                %{name}-ac.patch
+Patch3:                %{name}-cryptopp.patch
 URL:           http://www.amule.org/
 BuildRequires: GeoIP-devel
 BuildRequires: autoconf >= 2.59
@@ -94,6 +95,7 @@ NarzÄ™dzie do generownia statystyk aMule.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__aclocal} -I m4
This page took 0.07884 seconds and 4 git commands to generate.