]> git.pld-linux.org Git - packages/aMule.git/blame_incremental - aMule.spec
- release 13
[packages/aMule.git] / aMule.spec
... / ...
CommitLineData
1Summary: Unix port of eMule client
2Summary(pl.UTF-8): Uniksowy port klienta eMule
3Name: aMule
4Version: 2.2.6
5Release: 13
6License: GPL
7Group: X11/Applications
8Source0: http://download.berlios.de/amule/%{name}-%{version}.tar.bz2
9# Source0-md5: 530d9b48187e36f78fc21bb19e94326d
10Patch0: %{name}-desktop.patch
11Patch1: %{name}-cas-datadir.patch
12Patch2: %{name}-ac.patch
13Patch3: %{name}-build.patch
14URL: http://www.amule.org/
15BuildRequires: GeoIP-devel
16BuildRequires: autoconf
17BuildRequires: automake >= 1:1.7.3
18BuildRequires: binutils-devel
19BuildRequires: bison
20BuildRequires: cryptopp-devel >= 5.1
21BuildRequires: curl-devel >= 7.9.7
22BuildRequires: expat-devel
23BuildRequires: gd-devel
24BuildRequires: gettext-autopoint
25BuildRequires: gettext-devel >= 0.11.5
26BuildRequires: gtk+2-devel >= 2:2.2.0
27BuildRequires: libpng-devel
28BuildRequires: libstdc++-devel
29BuildRequires: pkgconfig
30BuildRequires: wxGTK2-unicode-devel
31BuildRequires: xorg-lib-libXpm-devel
32Requires: wget
33Obsoletes: lmule
34Obsoletes: xmule
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38aMule is a Linux port of eMule client.
39
40%description -l pl.UTF-8
41aMule to linuksowy port klienta eMule.
42
43%package plugin-xchat
44Summary: Xchat plugin
45Summary(pl.UTF-8): Wtyczka dla xchat
46Group: X11/Applications
47Requires: %{name} = %{version}-%{release}
48Provides: %{name}-plugin-xchat
49
50%description plugin-xchat
51Plugin for Xchat IRC client.
52
53%description plugin-xchat -l pl.UTF-8
54Wtczka dla klienta IRC xchat.
55
56%package alc
57Summary: Ed2k link creator for aMule
58Summary(pl.UTF-8): Kreator linków ed2k dla aMule
59Group: X11/Applications
60Requires: %{name} = %{version}-%{release}
61Provides: alc
62
63%description alc
64Tool for creating ed2k links.
65
66%description alc -l pl.UTF-8
67Narzędzie do tworzenia linków ed2k.
68
69%package cas
70Summary: aMule online stats
71Summary(pl.UTF-8): Statystyki online aMule
72Group: X11/Applications
73Requires: %{name} = %{version}-%{release}
74Provides: cas
75
76%description cas
77Tool for generating aMule online stats.
78
79%description cas -l pl.UTF-8
80Narzędzie do generownia statystyk aMule.
81
82%prep
83%setup -q
84%patch0 -p1
85%patch1 -p1
86%patch2 -p1
87%patch3 -p1
88
89%build
90%{__aclocal} -I m4
91%{__autoconf}
92%{__autoheader}
93%{__automake}
94%configure \
95 --with-wx-config=wx-gtk2-unicode-config \
96 --%{?debug:en}%{!?debug:dis}able-debug \
97 --%{?debug:dis}%{!?debug:en}able-optimize \
98 --enable-amule-daemon \
99 --enable-amule-gui \
100 --enable-amulecmd \
101 --enable-webserver \
102 --enable-cas \
103 --enable-wxcas \
104 --enable-alc \
105 --enable-alcc \
106 --enable-geoip
107
108######################################################################################
109# UGLY UGLY BAD BAD BAD !!!!!
110# This should be fixable in another way
111sed -i -e 's#echo "$$d$$p">/dev/null;#echo "$$d$$p";#' src/skins/Makefile
112sed -i -e 's#echo "$$d$$p">/dev/null;#echo "$$d$$p";#' src/webserver/litoral/Makefile
113sed -i -e 's#echo "$$d$$p">/dev/null;#echo "$$d$$p";#' src/webserver/chicane/Makefile
114sed -i -e 's#echo "$$d$$p">/dev/null;#echo "$$d$$p";#' src/webserver/default/Makefile
115sed -i -e 's#echo "$$d$$p">/dev/null;#echo "$$d$$p";#' src/webserver/php-default/Makefile
116sed -i -e 's#echo "$$d$$p">/dev/null;#echo "$$d$$p";#' src/utils/cas/Makefile
117sed -i -e 's#echo "$$d$$p">/dev/null;#echo "$$d$$p";#' src/utils/aLinkCreator/Makefile
118sed -i -e 's#echo "$$d$$p">/dev/null;#echo "$$d$$p";#' src/utils/xas/Makefile
119sed -i -e 's#echo "$$d$$p">/dev/null;#echo "$$d$$p";#' src/utils/wxCas/Makefile
120######################################################################################
121%{__make}
122
123%install
124rm -rf $RPM_BUILD_ROOT
125
126%{__make} install \
127 DESTDIR=$RPM_BUILD_ROOT
128
129install src/utils/xas/xas.pl $RPM_BUILD_ROOT%{_libdir}/xchat/plugins
130install {amule.desktop,amulegui.desktop,src/utils/aLinkCreator/alc.desktop,src/utils/wxCas/wxcas.desktop} $RPM_BUILD_ROOT%{_desktopdir}
131install {amule.xpm,amulegui.xpm,src/utils/aLinkCreator/alc.xpm,src/utils/wxCas/wxcas.xpm} $RPM_BUILD_ROOT%{_pixmapsdir}
132
133mv -f $RPM_BUILD_ROOT%{_datadir}/locale/et{_EE,}
134mv -f $RPM_BUILD_ROOT%{_datadir}/locale/ko{_KR,}
135mv -f $RPM_BUILD_ROOT%{_datadir}/locale/pt{_PT,}
136rm -fr $RPM_BUILD_ROOT%{_docdir}/amule
137rm -fr $RPM_BUILD_ROOT%{_mandir}/eu
138%find_lang amule
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%files -f amule.lang
144%defattr(644,root,root,755)
145%doc docs/AUTHORS docs/EC_Protocol.txt docs/README docs/Changelog docs/ED2K-Links.HOWTO docs/TODO docs/amulesig.txt
146%attr(755,root,root) %{_bindir}/autostart-xas
147%attr(755,root,root) %{_bindir}/amule*
148%attr(755,root,root) %{_bindir}/ed2k
149%dir %{_datadir}/amule
150%{_datadir}/amule/webserver
151%{_datadir}/amule/skins
152%{_desktopdir}/amule.desktop
153%{_desktopdir}/amulegui.desktop
154%{_pixmapsdir}/amule.xpm
155%{_pixmapsdir}/amulegui.xpm
156%{_mandir}/man1/amule*
157%{_mandir}/man1/ed2k*
158%{_mandir}/man1/xas*
159%lang(de) %{_mandir}/de/man1/amule*
160%lang(de) %{_mandir}/de/man1/ed2k*
161%lang(de) %{_mandir}/de/man1/xas*
162%lang(es) %{_mandir}/es/man1/amule*
163%lang(es) %{_mandir}/es/man1/ed2k*
164%lang(es) %{_mandir}/es/man1/xas*
165%lang(fr) %{_mandir}/fr/man1/amule*
166%lang(fr) %{_mandir}/fr/man1/ed2k*
167%lang(hu) %{_mandir}/hu/man1/amule*
168%lang(hu) %{_mandir}/hu/man1/ed2k*
169%lang(hu) %{_mandir}/hu/man1/xas*
170%lang(it) %{_mandir}/it/man1/amule*
171%lang(it) %{_mandir}/it/man1/ed2k*
172
173%files plugin-xchat
174%defattr(644,root,root,755)
175%{_libdir}/xchat/plugins/xas.pl
176
177%files alc
178%defattr(644,root,root,755)
179%attr(755,root,root) %{_bindir}/alc*
180%{_desktopdir}/alc.desktop
181%{_pixmapsdir}/alc.xpm
182%{_mandir}/man1/alc*
183%lang(de) %{_mandir}/de/man1/alc*
184%lang(es) %{_mandir}/es/man1/alc*
185%lang(fr) %{_mandir}/fr/man1/alc*
186%lang(hu) %{_mandir}/hu/man1/alc*
187
188%files cas
189%defattr(644,root,root,755)
190%attr(755,root,root) %{_bindir}/*cas
191%{_datadir}/amule/cas
192%{_desktopdir}/*cas.desktop
193%{_pixmapsdir}/wxcas.xpm
194%{_mandir}/man1/*cas*
195%lang(de) %{_mandir}/de/man1/*cas*
196%lang(es) %{_mandir}/es/man1/*cas*
197%lang(hu) %{_mandir}/hu/man1/*cas*
This page took 0.317033 seconds and 4 git commands to generate.