]> git.pld-linux.org Git - packages/Zope-iHotfix.git/blob - Zope-iHotfix.spec
- removed obsoletes patch
[packages/Zope-iHotfix.git] / Zope-iHotfix.spec
1
2 %include        /usr/lib/rpm/macros.python
3 %define         zope_subname    iHotfix
4 Summary:        Dynamically applying several patches to Zope
5 Summary(pl):    Dodatek aplikuj±cy wiele poprawek dla Zope
6 Name:           Zope-%{zope_subname}
7 Version:        0.4.0
8 Release:        1
9 License:        GPL
10 Group:          Development/Tools
11 Source0:        http://dl.sourceforge.net/lleu/%{zope_subname}-%{version}.tgz
12 # Source0-md5:  773ba7f4202c9230019622fbb67dbd1d
13 URL:            http://sourceforge.net/projects/lleu/
14 BuildRequires:  python >= 2.2
15 Requires(post,postun):  /usr/sbin/installzopeproduct
16 %pyrequires_eq  python-modules
17 Requires:       Zope >= 2.6
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 It dynamically applies several patches to Zope.
23
24 %description -l pl
25 Dodatek aplikuj±cy wiele poprawek dla Zope.
26
27 %prep
28 %setup -q -n %{zope_subname}
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
33
34 # should tests be included or not?
35 cp -af *.py $RPM_BUILD_ROOT%{_datadir}/%{name}
36
37 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
38 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
39
40 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %post
46 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
47 if [ -f /var/lock/subsys/zope ]; then
48         /etc/rc.d/init.d/zope restart >&2
49 fi
50
51 %postun
52 if [ "$1" = "0" ]; then
53         /usr/sbin/installzopeproduct -d %{zope_subname}
54         if [ -f /var/lock/subsys/zope ]; then
55                 /etc/rc.d/init.d/zope restart >&2
56         fi
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %doc TODO.txt
62 %{_datadir}/%{name}
This page took 0.340568 seconds and 3 git commands to generate.