]> git.pld-linux.org Git - packages/Zope-archetypes.git/blob - Zope-archetypes.spec
- removed TODO/warning message; done
[packages/Zope-archetypes.git] / Zope-archetypes.spec
1
2 %define         zope_subname    archetypes
3 Summary:        Framework designed to facilitate the building of applications for Plone and CMF. 
4 Summary(pl):    ¦rodowsko u³atwiaj±ce budowanie aplikacji dla Plone i CMF.
5 Name:           Zope-%{zope_subname}
6 Version:        1.2.0
7 Release:        4
8 License:        GPL
9 Group:          Development/Tools
10 Source0:        http://dl.sourceforge.net/%{zope_subname}/%{zope_subname}-%{version}.tgz
11 # Source0-md5:  b25fdf747a286488b17e512205f4f1ac
12 URL:            http://dreamcatcher.homeunix.org/
13 %pyrequires_eq  python-modules
14 Requires:       Zope
15 Requires:       Zope-CMFPlone
16 Requires:       Zope-CMF
17 Requires:       Zope-PortalTransforms
18 Requires(post,postun):  /usr/sbin/installzopeproduct
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21 Conflicts:      CMF
22 Conflicts:      Plone
23
24 %description
25 Archetypes (formerly known as CMFTypes) is a framework designed 
26 to facilitate the building of applications for Plone and CMF. 
27 Its main purpose is to provide a common method for building 
28 content objects, based on schema definitions. 
29
30 %description -l pl
31 Archetypes (poprzednio znany jako CMFTypes) jest ¶rodowskiem
32 u³atwiaj±cym budowanie aplikacji dla Plone i CMF.
33 G³ównym zadaniem jest dostarczenie podstawowych metod 
34 do zbudowania obiektów typu content opartych na zdefiniowanych
35 schematach. 
36
37 %prep
38 %setup -q -c
39 rm -f %{zope_subname}-%{version}/ArchGenXML/.cvsignore
40 find . -type d -name debian | xargs rm -rf
41
42 %build
43 install -d docs/{ArchExample,ArchGenXML,Archetypes,generator,validation}
44 mv -f %{zope_subname}-%{version}/ArchExample/ChangeLog docs/ArchExample
45 mv -f %{zope_subname}-%{version}/ArchGenXML/README docs/ArchGenXML
46 mv -f %{zope_subname}-%{version}/Archetypes/{AUTHORS,ChangeLog,README.txt,TODO.txt} docs/Archetypes
47 mv -f %{zope_subname}-%{version}/generator/{ChangeLog,README} docs/generator
48 mv -f %{zope_subname}-%{version}/validation/{ChangeLog,README} docs/validation
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
54 cp -af %{zope_subname}-%{version}/{ArchExample,ArchGenXML,Archetypes,generator,validation} $RPM_BUILD_ROOT%{_datadir}/%{name}
55
56 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
57 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
58
59 # rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 for p in ArchExample ArchGenXML Archetypes generator validation; do
66     /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
67 done
68 if [ -f /var/lock/subsys/zope ]; then
69         /etc/rc.d/init.d/zope restart >&2
70 fi
71
72 %postun
73 if [ "$1" = "0" ]; then
74     for p in ArchExample ArchGenXML Archetypes generator validation; do
75         /usr/sbin/installzopeproduct -d $p
76     done
77 fi
78 if [ -f /var/lock/subsys/zope ]; then
79             /etc/rc.d/init.d/zope restart >&2
80 fi
81
82 %files
83 %defattr(644,root,root,755)
84 %doc docs/* 
85 %{_datadir}/%{name}
This page took 0.077599 seconds and 3 git commands to generate.