]> git.pld-linux.org Git - packages/Zope-archetypes.git/blob - Zope-archetypes.spec
- /usr/share doesn't belong here
[packages/Zope-archetypes.git] / Zope-archetypes.spec
1
2 # TODO
3 # - Zope starting but connection refused (on WWW)! archetypes problem?
4 #
5 %define         zope_subname    archetypes
6 Summary:        Framework designed to facilitate the building of applications for Plone and CMF. 
7 Summary(pl):    ¦rodowsko u³atwiaj±ce budowanie aplikacji dla Plone i CMF.
8 Name:           Zope-%{zope_subname}
9 Version:        1.2.0
10 Release:        4
11 License:        GPL
12 Group:          Development/Tools
13 Source0:        http://dl.sourceforge.net/%{zope_subname}/%{zope_subname}-%{version}.tgz
14 # Source0-md5:  b25fdf747a286488b17e512205f4f1ac
15 URL:            http://dreamcatcher.homeunix.org/
16 %pyrequires_eq  python-modules
17 Requires:       Zope
18 Requires:       Zope-CMFPlone
19 Requires:       Zope-CMF
20 Requires:       Zope-PortalTransforms
21 Requires(post,postun):  /usr/sbin/installzopeproduct
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24 Conflicts:      CMF
25 Conflicts:      Plone
26
27 %description
28 Archetypes (formerly known as CMFTypes) is a framework designed 
29 to facilitate the building of applications for Plone and CMF. 
30 Its main purpose is to provide a common method for building 
31 content objects, based on schema definitions. 
32
33 %description -l pl
34 Archetypes (poprzednio znany jako CMFTypes) jest ¶rodowskiem
35 u³atwiaj±cym budowanie aplikacji dla Plone i CMF.
36 G³ównym zadaniem jest dostarczenie podstawowych metod 
37 do zbudowania obiektów typu content opartych na zdefiniowanych
38 schematach. 
39
40 %prep
41 %setup -q -c
42 rm -f %{zope_subname}-%{version}/ArchGenXML/.cvsignore
43 find . -type d -name debian | xargs rm -rf
44
45 %build
46 install -d docs/{ArchExample,ArchGenXML,Archetypes,generator,validation}
47 mv -f %{zope_subname}-%{version}/ArchExample/ChangeLog docs/ArchExample
48 mv -f %{zope_subname}-%{version}/ArchGenXML/README docs/ArchGenXML
49 mv -f %{zope_subname}-%{version}/Archetypes/{AUTHORS,ChangeLog,README.txt,TODO.txt} docs/Archetypes
50 mv -f %{zope_subname}-%{version}/generator/{ChangeLog,README} docs/generator
51 mv -f %{zope_subname}-%{version}/validation/{ChangeLog,README} docs/validation
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
57 cp -af %{zope_subname}-%{version}/{ArchExample,ArchGenXML,Archetypes,generator,validation} $RPM_BUILD_ROOT%{_datadir}/%{name}
58
59 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
60 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
61
62 # rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 for p in ArchExample ArchGenXML Archetypes generator validation; do
69     /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
70 done
71 if [ -f /var/lock/subsys/zope ]; then
72         /etc/rc.d/init.d/zope restart >&2
73 fi
74
75 %postun
76 if [ "$1" = "0" ]; then
77     for p in ArchExample ArchGenXML Archetypes generator validation; do
78         /usr/sbin/installzopeproduct -d $p
79     done
80 fi
81 if [ -f /var/lock/subsys/zope ]; then
82             /etc/rc.d/init.d/zope restart >&2
83 fi
84
85 %files
86 %defattr(644,root,root,755)
87 %doc docs/* 
88 %{_datadir}/%{name}
This page took 0.048752 seconds and 3 git commands to generate.