]> git.pld-linux.org Git - packages/Zope-archetypes.git/blob - Zope-archetypes.spec
- cleanups
[packages/Zope-archetypes.git] / Zope-archetypes.spec
1 %include        /usr/lib/rpm/macros.python
2
3 %define         zope_subname    archetypes
4
5 Summary:        Archetypes - a framework for developing new content types in Plone
6 Summary(pl):    Archetypes - nowe ¶rodowisko pracy dla twórców serwisów Plone
7 Name:           Zope-%{zope_subname}
8 Version:        1.0.1
9 Release:        1
10 License:        GNU
11 Group:          Development/Tools
12 Source0:        http://dl.sourceforge.net/%{zope_subname}/%{zope_subname}-%{version}.tgz
13 # Source0-md5:  53f3ccf5a88ce3a91b50e8a82165c2de
14 URL:            http://dreamcatcher.homeunix.org/
15 %pyrequires_eq  python-modules
16 Requires:       CMF
17 Requires:       Plone
18 Requires:       Zope
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         product_dir     /usr/lib/zope/Products
23
24 %description
25 Archetypes is a framework for developing new content types in
26 Plone. The power of Archetypes is, first, in automatically generating
27 forms; second, in providing a library of stock field types, form
28 widgets, and field validators; third, in easily integrating custom
29 fields, widgets, and validators; and fourth, in automating
30 transformations of rich content.
31
32 %description -l pl
33 Archetypes jest nowym ¶rodowiskiem pracy dla twórców serwisów
34 Plone. Si³± Archetypes s± automatycznie generowane formularze,
35 zarz±dzalne biblioteki pól typów, kontrolek i korektorów pól, a tak¿e
36 ³atwa integracja zaawansowanych mo¿liwo¶ci z w/w typami. Posiada
37 równie¿ bogat± automatykê.
38
39 %prep
40 %setup -q -c %{zope_subname}-%{version}
41
42 %build
43 mkdir docs docs/ArchExample docs/ArchGenXML docs/Archetypes docs/generator docs/validation
44 cd %{zope_subname}-%{version}
45 mv -f *.pdf ../docs/
46 mv -f ArchExample/ChangeLog ../docs/ArchExample
47 mv -f ArchGenXML/README ../docs/ArchGenXML
48 mv -f Archetypes/{/docs/*,AUTHORS,ChangeLog,README.txt,TODO.txt} ../docs/Archetypes
49 rm -rf Archetypes/docs
50 mv -f generator/{ChangeLog,MANIFEST.in,README} ../docs/generator
51 mv -f validation/{ChangeLog,MANIFEST.in,README} ../docs/validation
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{product_dir}
56
57 cd %{zope_subname}-%{version}
58 cp -af * $RPM_BUILD_ROOT%{product_dir}
59
60 %py_comp $RPM_BUILD_ROOT%{product_dir}
61 %py_ocomp $RPM_BUILD_ROOT%{product_dir}
62
63 find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
64 rm -rf $RPM_BUILD_ROOT%{product_dir}/docs
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 if [ -f /var/lock/subsys/zope ]; then
71         /etc/rc.d/init.d/zope restart >&2
72 fi
73
74 %postun
75 if [ -f /var/lock/subsys/zope ]; then
76         /etc/rc.d/init.d/zope restart >&2
77 fi
78
79 %files
80 %defattr(644,root,root,755)
81 %doc docs/*
82 %{product_dir}/ArchExample
83 %{product_dir}/ArchGenXML
84 %{product_dir}/Archetypes
85 %{product_dir}/generator
86 %{product_dir}/validation
This page took 0.117987 seconds and 3 git commands to generate.