]> git.pld-linux.org Git - packages/Zope-ZMySQLDA.git/blob - Zope-ZMySQLDA.spec
- cleanups
[packages/Zope-ZMySQLDA.git] / Zope-ZMySQLDA.spec
1 %define prod_name ZMySQLDA
2 Summary:        Zope MySQL database adapter
3 Summary(pl):    Interfejs bazy danych MySQL do Zope
4 Name:           Zope-%{prod_name}
5 Version:        2.0.8
6 Release:        1
7 License:        ZPL
8 Group:          Development/Languages/Python
9 Source0:        http://www.zope.org/Members/adustman/Products/ZMySQLDA/%{prod_name}-%{version}.tar.gz
10 # Source0-md5:  74332272e53b13c6b19d3185d575699c
11 URL:            http://www.zope.org/Members/adustman/Products/ZMySQLDA/
12 BuildRequires:  python-MySQLdb
13 Requires:       Zope
14 Requires:       python-MySQLdb
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
19 %define python_compile     python -c "import compileall; compileall.compile_dir('.')"
20
21 %define zope_dir           %{_libdir}/zope
22 %define zope_productsdir   %{zope_dir}/Products
23
24 %description
25 Zope MySQL database adapter.
26
27 %description -l pl
28 Interfejs bazy danych MySQL do Zope.
29
30 %prep
31 %setup -q -c
32 mv -f lib/python/Products/%{prod_name}/* .
33 rm -rf lib
34
35 %build
36 %{python_compile}
37 %{python_compile_opt}
38
39 find . -name \*.py | xargs -r rm -f
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
44
45 cp -a . $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
46 rm -f $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}/*.gz
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc *.txt
54 %{zope_productsdir}/%{prod_name}
This page took 0.267649 seconds and 4 git commands to generate.