]> git.pld-linux.org Git - packages/Zope-Formulator.git/blob - Zope-Formulator.spec
- install in %{_datadir}/%{name}
[packages/Zope-Formulator.git] / Zope-Formulator.spec
1 %include        /usr/lib/rpm/macros.python
2
3 %define         zope_subname    Formulator
4
5 Summary:        Zope framework that eases the creation and validation of web forms
6 Summary(pl):    Dodatek do Zope u³atwiaj±cy tworzenie i sprawdzanie poprawno¶ci formularzy WWW
7 Name:           Zope-%{zope_subname}
8 Version:        1.5.0
9 Release:        2
10 License:        BSD-like
11 Group:          Development/Tools
12 Source0:        http://www.zope.org/Members/infrae/Formulator/Formulator-%{version}/%{zope_subname}-%{version}.tgz
13 # Source0-md5:  3a8dbedbc72f9176ca7fe5a54043e8d4
14 URL:            http://www.zope.org/Members/infrae/Formulator/
15 %pyrequires_eq  python-modules
16 Requires:       Zope
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         product_dir     /usr/lib/zope/Products
21
22 %description
23 %{zope_subname} is a tool to help with the creation and validation of web
24 forms. Form fields are stored as objects in Zope, in a special Form folder.
25
26 %description -l pl
27 %{zope_subname} jest narzêdziem pomagaj±cym przy tworzeniu i sprawdzaniu
28 poprawno¶ci formularzy WWW. Pola formularza s± zapisywane jako obiekty
29 w Zope, w specjalnym folderze Form.
30
31 %prep
32 %setup -q -n %{zope_subname}
33
34 %build
35 mkdir docs
36 mv -f {CREDITS.txt,HISTORY.txt,INSTALL.txt,README.txt,TODO.txt} docs
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
41 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
42
43 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
44 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
45
46 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
47 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %post
53 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
54 if [ -f /var/lock/subsys/zope ]; then
55         /etc/rc.d/init.d/zope restart >&2
56 fi
57
58 %postun
59 if [ "$1" = "0" ]; then
60         /usr/sbin/installzopeproduct -d %{zope_subname} 
61         if [ -f /var/lock/subsys/zope ]; then
62                 /etc/rc.d/init.d/zope restart >&2
63         fi
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc docs/*
69 %{_datadir}/%{name}
This page took 0.02919 seconds and 4 git commands to generate.