]> git.pld-linux.org Git - packages/Zope-Formulator.git/blob - Zope-Formulator.spec
- added BR: python
[packages/Zope-Formulator.git] / Zope-Formulator.spec
1
2 %define         zope_subname    Formulator
3 Summary:        Zope framework that eases the creation and validation of web forms
4 Summary(pl):    Dodatek do Zope u³atwiaj±cy tworzenie i sprawdzanie poprawno¶ci formularzy WWW
5 Name:           Zope-%{zope_subname}
6 Version:        1.6.2
7 Release:        2
8 License:        BSD-like
9 Group:          Development/Tools
10 Source0:        http://www.zope.org/Members/infrae/Formulator/Formulator-%{version}/%{zope_subname}-%{version}.tgz
11 # Source0-md5:  c5eb395918349036c7ac400dbbff98e9
12 URL:            http://www.zope.org/Members/infrae/Formulator/
13 BuildRequires:  python
14 %pyrequires_eq  python-modules
15 Requires:       Zope
16 Requires(post,postun):  /usr/sbin/installzopeproduct
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 %{zope_subname} is a tool to help with the creation and validation of web
22 forms. Form fields are stored as objects in Zope, in a special Form folder.
23
24 %description -l pl
25 %{zope_subname} jest narzêdziem pomagaj±cym przy tworzeniu i sprawdzaniu
26 poprawno¶ci formularzy WWW. Pola formularza s± zapisywane jako obiekty
27 w Zope, w specjalnym folderze Form.
28
29 %prep
30 %setup -q -n %{zope_subname}
31
32 %build
33 mkdir docs
34 mv -f {CREDITS.txt,HISTORY.txt,INSTALL.txt,README.txt,TODO.txt} docs
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
39 cp -af {dtml,help,tests,www,*.py,*.html,refresh.txt,version.txt} $RPM_BUILD_ROOT%{_datadir}/%{name}
40
41 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
42 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
43
44 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
45 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post
51 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
52 if [ -f /var/lock/subsys/zope ]; then
53         /etc/rc.d/init.d/zope restart >&2
54 fi
55
56 %postun
57 if [ "$1" = "0" ]; then
58         /usr/sbin/installzopeproduct -d %{zope_subname} 
59         if [ -f /var/lock/subsys/zope ]; then
60                 /etc/rc.d/init.d/zope restart >&2
61         fi
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc docs/*
67 %{_datadir}/%{name}
This page took 0.320877 seconds and 4 git commands to generate.