]> git.pld-linux.org Git - packages/Zope-Formulator.git/blob - Zope-Formulator.spec
- URL fixes and other cosmetics
[packages/Zope-Formulator.git] / Zope-Formulator.spec
1
2 %define prod_name Formulator
3
4 Summary:        Zope framework that eases the creation and validation of web forms
5 Summary(pl):    Dodatek do Zope u³atwiaj±cy tworzenie i sprawdzanie poprawno¶ci formularzy WWW
6 Name:           Zope-%{prod_name}
7 Version:        1.0.1
8 Release:        1
9 License:        BSD-like
10 Group:          Development/Languages/Python
11 Source0:        http://www.zope.org/Members/faassen/Formulator/%{prod_name}-%{version}.tgz
12 # Source0-md5:  ee9d0f3b000f14f66962440fc2e638ae
13 URL:            http://www.zope.org/Members/faassen/Formulator/
14 Requires:       Zope
15 BuildRequires:  python >= 2.1
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
20 %define python_compile     python -c "import compileall; compileall.compile_dir('.')"
21
22 %define zope_dir           %{_libdir}/zope
23 %define zope_productsdir   %{zope_dir}/Products         
24
25 %description
26 %{prod_name} is a tool to help with the creation and validation of web                            
27 forms. Form fields are stored as objects in Zope, in a special Form folder.
28
29 %description -l pl
30 %{prod_name} jest narzêdziem pomagaj±cym przy tworzeniu i sprawdzaniu
31 poprawno¶ci formularzy WW. Pola formularza s± zapisywane jako obiekty
32 w Zope, w specjalnym folderze Form.
33
34 %prep
35 %setup -q -n %{prod_name}
36
37 %build
38 %{python_compile}
39 %{python_compile_opt}
40
41 find . -name \*.py | xargs -r rm -f
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
46
47 cp -a . $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
48 rm -f $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}/*.gz
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc *.txt
56 %{zope_productsdir}/%{prod_name}
This page took 0.076531 seconds and 4 git commands to generate.