]> git.pld-linux.org Git - packages/Zope-Formulator.git/blob - Zope-Formulator.spec
- buildarch: noarch
[packages/Zope-Formulator.git] / Zope-Formulator.spec
1
2 %define prod_name Formulator
3
4 Summary:        Zope framework that eases the creation and validation of web forms. 
5 Name:           Zope-%{prod_name}
6 Version:        1.0.1
7 Release:        1
8 License:        BSD-style
9 Source0:        http://www.zope.org/Members/faassen/%{prod_name}/%{prod_name}-%{version}.tgz
10 URL:            http://www.zope.org/Members/faassen/%{prod_name}
11 Group:          Development/Languages/Python
12 Group(de):      Entwicklung/Sprachen/Python
13 Group(pl):      Programowanie/Jêzyki/Python
14 Requires:       Zope
15 BuildRequires:  python >= 2.1
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
20 %define python_compile     python -c "import compileall; compileall.compile_dir('.')"
21
22 %define zope_dir           %{_libdir}/zope
23 %define zope_productsdir   %{zope_dir}/Products         
24
25 %description
26 %{prod_name} is a tool to help with the creation and validation of web                            
27 forms. Form fields are stored as objects in Zope, in a special Form folder.
28
29 %prep
30 %setup -q -n %{prod_name}
31
32 %build
33 %{python_compile}
34 %{python_compile_opt}
35
36 find . -name \*.py | xargs -r rm -f
37 gzip -9nf *.txt
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
42
43 cp -a . $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
44 rm -f $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}/*.gz
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc *.gz 
52 %{zope_productsdir}/%{prod_name}
This page took 0.036902 seconds and 4 git commands to generate.