]> git.pld-linux.org Git - packages/Zope-Formulator.git/blob - Zope-Formulator.spec
- new from scratch
[packages/Zope-Formulator.git] / Zope-Formulator.spec
1
2 %define prod_name Formulator
3
4 Summary:        Python interface to OpenSSL
5 Name:           Zope-%{prod_name}
6 Version:        1.0.1
7 Release:        1
8 License:        BSD-style
9 Source0:        http://www.zope.org/Members/faassen/%{prod_name}/%{prod_name}-%{version}.tgz
10 URL:            http://www.zope.org/Members/faassen/%{prod_name}
11 Group:          Development/Languages/Python
12 Group(de):      Entwicklung/Sprachen/Python
13 Group(pl):      Programowanie/Jêzyki/Python
14 Requires:       Zope
15 BuildRequires:  python >= 1.5.2
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
19 %define python_compile     python -c "import compileall; compileall.compile_dir('.')"
20
21 %define zope_dir           %{_libdir}/zope
22 %define zope_productsdir   %{zope_dir}/Products         
23
24 %description
25 %{prod_name} is a tool to help with the creation and validation of web                            
26 forms. Form fields are stored as objects in Zope, in a special Form folder.
27
28 %prep
29 %setup -q -n %{prod_name}
30
31 %build
32 %{python_compile}
33 %{python_compile_opt}
34
35 find . -name \*.py | xargs -r rm -f
36 gzip -9nf *.txt
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
41
42 cp -a . $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
43 rm -f $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}/*.gz
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc *.gz 
51 %{zope_productsdir}/%{prod_name}
This page took 0.985994 seconds and 4 git commands to generate.