]> git.pld-linux.org Git - packages/Zope-Formulator.git/blob - Zope-Formulator.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/Zope-Formulator.git] / Zope-Formulator.spec
1
2 %define prod_name Formulator
3
4 Summary:        Zope framework that eases the creation and validation of web forms
5 Summary(pl):    Dodatek do Zope u³atwiaj±cy tworzenie i sprawdzanie poprawno¶ci formularzy WWW
6 Name:           Zope-%{prod_name}
7 Version:        1.0.1
8 Release:        1
9 License:        BSD-style
10 Group:          Development/Languages/Python
11 Source0:        http://www.zope.org/Members/faassen/%{prod_name}/%{prod_name}-%{version}.tgz
12 URL:            http://www.zope.org/Members/faassen/%{prod_name}
13 Requires:       Zope
14 BuildRequires:  python >= 2.1
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
19 %define python_compile     python -c "import compileall; compileall.compile_dir('.')"
20
21 %define zope_dir           %{_libdir}/zope
22 %define zope_productsdir   %{zope_dir}/Products         
23
24 %description
25 %{prod_name} is a tool to help with the creation and validation of web                            
26 forms. Form fields are stored as objects in Zope, in a special Form folder.
27
28 %description -l pl
29 %{prod_name} jest narzêdziem pomagaj±cym przy tworzeniu i sprawdzaniu
30 poprawno¶ci formularzy WW. Pola formularza s± zapisywane jako obiekty
31 w Zope, w specjalnym folderze Form.
32
33 %prep
34 %setup -q -n %{prod_name}
35
36 %build
37 %{python_compile}
38 %{python_compile_opt}
39
40 find . -name \*.py | xargs -r rm -f
41 gzip -9nf *.txt
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
46
47 cp -a . $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
48 rm -f $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}/*.gz
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc *.gz 
56 %{zope_productsdir}/%{prod_name}
This page took 0.052183 seconds and 4 git commands to generate.