]> git.pld-linux.org Git - packages/Zope-Formulator.git/blob - Zope-Formulator.spec
- upgraded to 1.6.1 version
[packages/Zope-Formulator.git] / Zope-Formulator.spec
1 #
2 # Warning: product is req. by Plone but make error when create form on Zope 2.7b4 and python 2.3.3
3 #
4
5 %include        /usr/lib/rpm/macros.python
6 %define         zope_subname    Formulator
7 Summary:        Zope framework that eases the creation and validation of web forms
8 Summary(pl):    Dodatek do Zope u³atwiaj±cy tworzenie i sprawdzanie poprawno¶ci formularzy WWW
9 Name:           Zope-%{zope_subname}
10 Version:        1.6.1
11 Release:        1
12 License:        BSD-like
13 Group:          Development/Tools
14 Source0:        http://www.zope.org/Members/infrae/Formulator/Formulator-%{version}/%{zope_subname}-%{version}.tgz
15 # Source0-md5:  3753d468f24ea36e8ca61a13096c7095
16 URL:            http://www.zope.org/Members/infrae/Formulator/
17 %pyrequires_eq  python-modules
18 Requires:       Zope
19 Requires(post,postun):  /usr/sbin/installzopeproduct
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 %{zope_subname} is a tool to help with the creation and validation of web
25 forms. Form fields are stored as objects in Zope, in a special Form folder.
26
27 %description -l pl
28 %{zope_subname} jest narzêdziem pomagaj±cym przy tworzeniu i sprawdzaniu
29 poprawno¶ci formularzy WWW. Pola formularza s± zapisywane jako obiekty
30 w Zope, w specjalnym folderze Form.
31
32 %prep
33 %setup -q -n %{zope_subname}
34
35 %build
36 mkdir docs
37 mv -f {CREDITS.txt,HISTORY.txt,INSTALL.txt,README.txt,TODO.txt} docs
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
42 cp -af {dtml,help,tests,www,*.py,*.html,version.txt} $RPM_BUILD_ROOT%{_datadir}/%{name}
43
44 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
45 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
46
47 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
48 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
55 if [ -f /var/lock/subsys/zope ]; then
56         /etc/rc.d/init.d/zope restart >&2
57 fi
58
59 %postun
60 if [ "$1" = "0" ]; then
61         /usr/sbin/installzopeproduct -d %{zope_subname} 
62         if [ -f /var/lock/subsys/zope ]; then
63                 /etc/rc.d/init.d/zope restart >&2
64         fi
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc docs/*
70 %{_datadir}/%{name}
This page took 0.030662 seconds and 3 git commands to generate.