]> git.pld-linux.org Git - packages/Zope-ExternalEditor.git/blob - Zope-ExternalEditor.spec
- rewritten to use correct sources. Previous release was one big packaging mistake...
[packages/Zope-ExternalEditor.git] / Zope-ExternalEditor.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         zope_subname    ExternalEditor
3 Summary:        ExternalEditor - a Zope product integrating Zope more seamlessly with client-side tools
4 Summary(pl):    ExternalEditor - dodatek do Zope lepiej intergruj±cy Zope z narzêdziami od strony klienta
5 Name:           Zope-%{zope_subname}
6 Version:        0.7
7 Release:        3
8 License:        ZPL 2.0
9 Group:          Development/Tools
10 Source0:        http://zope.org/Members/Caseman/%{zope_subname}/%{version}/%{zope_subname}-%{version}.tgz
11 # Source0-md5:  1dac15db90bb3c320955c114f2053963
12 URL:            http://sourceforge.net/projects/collective/
13 BuildRequires:  python >= 2.2
14 %pyrequires_eq  python-modules
15 Requires:       Zope
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         product_dir     /usr/lib/zope/Products
20
21 %description
22 ExternalEditor is a Zope product, a new way to integrate Zope more seamlessly
23 with client-side tools. 
24
25 This package is supposed to be installed on Zope server, there is a zopeedit
26 tool for clients.
27
28 %description -l pl
29 ExternalEditor jest dodatkiem do Zope, umo¿liwiaj±cym w nowy, bardziej
30 przezroczysty sposób integrowaæ Zope z narzêdziami od strony klienta.
31
32 Ten pakiet powinien byæ zainstalowany na serwerze Zope. Od strony klienta
33 dostêp do niego zapewnia pakiet zopeedit.
34
35 %prep
36 %setup -q -n %{zope_subname}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
41
42 install -m 644 {*.py,*.gif,*.dtml,README.txt} $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
43
44 %py_comp $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
45 %py_ocomp $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
46
47 rm $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}/*.py
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %post
53 if [ -f /var/lock/subsys/zope ]; then
54         /etc/rc.d/init.d/zope restart >&2
55 fi
56
57 %postun
58 if [ -f /var/lock/subsys/zope ]; then
59         /etc/rc.d/init.d/zope restart >&2
60 fi
61
62 %files
63 %defattr(644,root,root,755)
64 %doc CHANGES.txt INSTALL-UNIX.txt LICENSE.txt README.txt
65 %{product_dir}/%{zope_subname}
This page took 0.07834 seconds and 3 git commands to generate.