]> git.pld-linux.org Git - packages/Zope-CPSSkinsTutorial.git/blob - Zope-CPSSkinsTutorial.spec
- initial release
[packages/Zope-CPSSkinsTutorial.git] / Zope-CPSSkinsTutorial.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         zope_subname    CPSSkinsTutorial
3 Summary:        Tutorial for CPSSkins
4 Summary(pl):    Samouczek dla CPSSkins
5 Name:           Zope-%{zope_subname}
6 Version:        0.2
7 Release:        1
8 License:        GPL
9 Group:          Development/Tools
10 Source0:        http://www.medic.chalmers.se/~jmo/CPS/%{zope_subname}%{version}.tgz
11 # Source0-md5:  3ac2fcee53fcef9f244cb6b06d696a8c
12 URL:            http://www.medic.chalmers.se/~jmo/CPS/
13 Requires(post,postun):  /usr/sbin/installzopeproduct
14 %pyrequires_eq  python-modules
15 Requires:       Zope
16 Requires:       Zope-CPSSkins
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Tutorial for CPSSkins.
22
23 %description -l pl
24 Samouczek dla CPSSkins.
25
26 %prep
27 %setup -q -c
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
32
33 cp -af Products/%{zope_subname}/{Extensions,i18n,skins,*.py,version.txt,refresh.txt} \
34     $RPM_BUILD_ROOT%{_datadir}/%{name}
35
36 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
37 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
38
39 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %post
45 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
46 if [ -f /var/lock/subsys/zope ]; then
47         /etc/rc.d/init.d/zope restart >&2
48 fi
49
50 %postun
51 if [ "$1" = "0" ]; then
52         /usr/sbin/installzopeproduct -d %{zope_subname}
53         if [ -f /var/lock/subsys/zope ]; then
54                 /etc/rc.d/init.d/zope restart >&2
55         fi
56 fi
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Products/%{zope_subname}/{INSTALL.TXT,*.doc}
61 %{_datadir}/%{name}
This page took 0.061175 seconds and 3 git commands to generate.