]> git.pld-linux.org Git - packages/Zope-COREBlog.git/blob - Zope-COREBlog.spec
- spaces -> tabs
[packages/Zope-COREBlog.git] / Zope-COREBlog.spec
1 %define         zope_subname    COREBlog
2 Summary:        Blog / Weblog / Web Nikki system on Zope
3 Summary(pl):    System bloga/webloga oparty na Zope
4 Name:           Zope-%{zope_subname}
5 Version:        1.0
6 Release:        2
7 License:        GPL
8 Group:          Development/Tools
9 Source0:        http://coreblog.org/junk/%{zope_subname}10.tgz
10 # Source0-md5:  1a0c95a7d22d2f3bd5a05ad3b702a256
11 URL:            http://coreblog.org/
12 BuildRequires:  python
13 %pyrequires_eq  python-modules
14 Requires:       Zope >= 2.6.1
15 Requires(post,postun):  /usr/sbin/installzopeproduct
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Blog / Weblog / Web Nikki system on Zope.
21
22 %description -l pl
23 System bloga/webloga oparty na Zope.
24
25 %prep
26 %setup -q -n %{zope_subname}
27 find . -type d -name CVS | xargs rm -rf
28 find . -type f -name .DS_Store | xargs rm -rf
29
30 %build
31 mkdir docs docs/stripogram
32 mv -f changelog.txt docs
33 mv -f stripogram/readme.txt docs/stripogram
34 rm -rf dtml/changelog.txt
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
39
40 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
41
42 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
43 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
44
45 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
46 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
53 if [ -f /var/lock/subsys/zope ]; then
54         /etc/rc.d/init.d/zope restart >&2
55 fi
56
57 %postun
58 if [ "$1" = "0" ]; then
59         /usr/sbin/installzopeproduct -d %{zope_subname}
60         if [ -f /var/lock/subsys/zope ]; then
61                 /etc/rc.d/init.d/zope restart >&2
62         fi
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %doc docs/*
68 %{_datadir}/%{name}
This page took 0.056414 seconds and 3 git commands to generate.