]> git.pld-linux.org Git - packages/Zope-CMFSin.git/blob - Zope-CMFSin.spec
- removed Licenses*
[packages/Zope-CMFSin.git] / Zope-CMFSin.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         zope_subname    CMFSin
3 Summary:        A Zope product that is a simple syndication client for CMF
4 Summary(pl):    Dodatek do Zope bêd±cy prostym klientem "korporacyjnym" dla CMF
5 Name:           Zope-%{zope_subname}
6 Version:        0.6.1
7 Release:        6
8 License:        GPL
9 Group:          Development/Tools
10 Source0:        http://dl.sourceforge.net/collective/%{zope_subname}.tar.gz
11 # Source0-md5:  a50ab5b9c13526a6a52397d556b09e84
12 URL:            http://sourceforge.net/projects/collective/
13 %pyrequires_eq  python-modules
14 Requires:       Zope-CMF
15 Requires:       Zope
16 Requires(post,postun):  /usr/sbin/installzopeproduct
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 Conflicts:      CMF
20
21 %description
22 This is a simple syndication client for CMF. It uses rssparser and
23 shares many things in common with CMFNewsFeed but has a different
24 model for handling channels. It is designed to map _n_ channels or
25 feeds to sets of composite virtual channels which can then be called
26 in in a timely fashion.
27
28 %description -l pl
29 CMFSin jest prostym klientem "korporacyjnym" dla CMF. Umo¿liwia
30 parsowanie rss i posiada wiele mo¿liwosæi jakie daje CMFNewsFeed, lecz
31 ró¿ni siê innym modelem obs³ugi kana³ów. Jest opracowany tak, by
32 odwzorowywaæ _n_ kana³ów lub strumieni na zbiory po³±czonych
33 wirtualnych kana³ów, które mog± byæ wywo³ywane o okre¶lonej porze.
34
35 %prep
36 %setup -q -n %{zope_subname}
37
38 find . -type d -name CVS | xargs rm -rf
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
43
44 cp -af {Extensions,skins,www,*.py,*.cfg,*.gif,version.txt,refresh.txt} $RPM_BUILD_ROOT%{_datadir}/%{name}
45
46 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
47 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
48
49 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
56 if [ -f /var/lock/subsys/zope ]; then
57         /etc/rc.d/init.d/zope restart >&2
58 fi
59
60 %postun
61 if [ "$1" = "0" ]; then
62         /usr/sbin/installzopeproduct -d %{zope_subname}
63         if [ -f /var/lock/subsys/zope ]; then
64                 /etc/rc.d/init.d/zope restart >&2
65         fi
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %doc docs/* README.txt
71 %{_datadir}/%{name}
This page took 0.13546 seconds and 4 git commands to generate.