]> git.pld-linux.org Git - packages/Zope-CMFSin.git/blob - Zope-CMFSin.spec
- initial release
[packages/Zope-CMFSin.git] / Zope-CMFSin.spec
1 %include        /usr/lib/rpm/macros.python
2
3 %define         zope_subname    CMFSin
4
5 Summary:        CMFSin is a Zope product - This is a simple syndication client for CMF
6 Summary(pl):    CMFSin jest dodatkiem do Zope - Prosty klient "korporacyjny" dla CMF
7 Name:           Zope-%{zope_subname}
8 Version:        0.6.1
9 Release:        1
10 License:        GNU
11 Group:          Development/Tools
12 Source0:        http://switch.dl.sourceforge.net/sourceforge/collective/%{zope_subname}.tar.gz
13 # Source0-md5:  a50ab5b9c13526a6a52397d556b09e84
14 URL:            http://sourceforge.net/projects/collective
15 %pyrequires_eq  python-modules
16 Requires:       Zope
17 Requires:       CMF
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         product_dir     /usr/lib/zope/Products
22
23 %description
24 This is a simple syndication client for CMF. It uses rssparser and
25 shares many things in common with CMFNewsFeed but has a different
26 model for handling channels. It is designed to map _n_ channels or
27 feeds to sets of composite virtual channels which can then be called
28 in in a timely fashion.
29
30 %description -l pl
31 CMFSin jest prostym klientem "korporacyjnym" dla CMF. Umo¿liwia
32 parsowanie rss i posiada wiele mo¿liwosæi jakie daje CMFNewsFeed lecz
33 ró¿ni siê innym modelem obs³ugi kana³ów. Jest stworzony dla ob³ugi
34 kana³ów typu _n_ lub wirtualnych kana³ów tworzonych o okre¶lonej
35 porze.
36
37 %prep
38 %setup -q -c %{zope_subname}-%{version}
39
40 %build
41 cd %{zope_subname}
42 rm -fR `find . -type d -name CVS`
43 mv -f README.txt docs/
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{product_dir}
48 cp -af * $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
49
50 rm -rf $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}/debian
51
52 %py_comp $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
53 %py_ocomp $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
54
55 find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
56 rm -rf $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}/docs
57
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post
63 if [ -f /var/lock/subsys/zope ]; then
64         /etc/rc.d/init.d/zope restart >&2
65 fi
66
67 %preun
68
69 %postun
70 if [ -f /var/lock/subsys/zope ]; then
71         /etc/rc.d/init.d/zope restart >&2
72 fi
73
74 %files
75 %defattr(644,root,root,755)
76 %doc %{zope_subname}/docs/*
77 %{product_dir}/%{zope_subname}
This page took 0.041193 seconds and 4 git commands to generate.