]> git.pld-linux.org Git - packages/Zope-CMFPlone.git/blob - Zope-CMFPlone.spec
- fixed PL Summary
[packages/Zope-CMFPlone.git] / Zope-CMFPlone.spec
1
2 %include        /usr/lib/rpm/macros.python
3 %define         zope_subname    CMFPlone
4 Summary:        Free and open source Content Management System based on Zope and CMF
5 Summary(pl):    Darmowy i otwarty system zarz±dzania tre¶ci± oparty na Zope i CMF
6 Name:           Zope-%{zope_subname}
7 Version:        2.0
8 # %%define              sub_ver RC6
9 Release:        7
10 License:        Zope Public License (ZPL), GPL
11 Group:          Networking/Daemons
12 Source0:        http://osdn.dl.sourceforge.net/sourceforge/plone/%{zope_subname}%{version}-final.tar.gz
13 # Source0-md5:  7d9805d07dec4dea30ff62e6c4f8481d
14 URL:            http://www.plone.org/
15 %pyrequires_eq  python-modules
16 Requires:       Zope-archetypes >= 1.2.4
17 Requires:       Zope-PortalTransforms
18 Requires:       Zope-CMF > 1.4.2
19 Requires:       Zope >= 2.6.2
20 Requires:       Zope-BTreeFolder2
21 Requires:       Zope-CMFQuickInstallerTool
22 Requires:       Zope-ExternalEditor
23 Requires:       Zope-Formulator >= 1.6.2
24 Requires:       Zope-GroupUserFolder >= 2.0
25 Requires(post,postun):  /usr/sbin/installzopeproduct
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28 Obsoletes:      Plone
29 Conflicts:      CMF
30
31 %description
32 Plone is a free, open source Content Management System. The focus of
33 Plone is to provide value at every level of an organization. It comes
34 with a workflow engine, pre-configured security and roles, a set of
35 content types and multi-lingual support. There are many developers,
36 writers and testers from all over the world, contributing to Plone
37 everyday. Plone is based on the Content Management Framework.
38
39 %description -l pl
40 Plone jest darmowym systemem zarz±dzania informacj± z otwartym kodem
41 ¼ród³owym. G³ównym celem Plone jest mo¿liwo¶æ dzielenia siê informacj±
42 na ka¿dym poziomie dostêpu. Jest to "silnik" serwisu umo¿liwiaj±cy
43 pracê z wieloma jêzykami, z wstêpn± konfiguracj± uwzglêdniaj±c±
44 zabezpieczenia serwisu. Plone dzia³a w zestawie z CMF, Zope i
45 Pythonem.
46
47 %prep
48 %setup -q -n %{zope_subname}-%{version}-final
49 # remove dirs - additional packages!
50 # ExternalEditor
51 rm -rf {BTreeFolder2,CMFQuickInstallerTool,Formulator,GroupUserFolder,Archetypes,generator,validation}
52 rm -rf {CMFCalendar,CMFCore,CMFDefault,CMFTopic,DCWorkflow,PortalTransforms}
53 find . -type d -name debian | xargs rm -rf
54
55 %build
56 mkdir docs docs/CMFPlone docs/CMFFormController docs/PlacelessTranslationService docs/PloneErrorReporting
57 mv -f CMFPlone/{CREDITS.txt,HISTORY.txt,INSTALL.txt,README.txt,UPGRADE.txt,LICENSE.txt} docs/CMFPlone
58 mv -f CMFPlone/docs/* docs/CMFPlone
59 rm -rf CMFPlone/LICENSE.GPL
60 mv -f CMFFormController/{AUTHORS,ChangeLog,README.txt} docs/CMFFormController
61 rm -rf CMFPlone/docs
62 mv -f PlacelessTranslationService/{COPYING.txt,NEWS.txt} docs/PlacelessTranslationService
63 mv -f PloneErrorReporting/{ChangeLog,README.txt} docs/PloneErrorReporting
64 rm -rf PloneErrorReporting/LICENSE.txt
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
69 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
70
71 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
72 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
73
74 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post
80 for p in CMFPlone CMFActionIcons CMFFormController PlacelessTranslationService PloneErrorReporting; do
81         /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
82 done
83 if [ -f /var/lock/subsys/zope ]; then
84         /etc/rc.d/init.d/zope restart >&2
85 fi
86
87 %postun
88 if [ "$1" = "0" ]; then
89         for p in CMFPlone CMFActionIcons CMFFormController PlacelessTranslationService PloneErrorReporting; do
90                 /usr/sbin/installzopeproduct -d $p
91         done
92         if [ -f /var/lock/subsys/zope ]; then
93                 /etc/rc.d/init.d/zope restart >&2
94         fi
95 fi
96
97 %files
98 %defattr(644,root,root,755)
99 %doc docs/*
100 %{_datadir}/%{name}
This page took 0.10036 seconds and 4 git commands to generate.