]> git.pld-linux.org Git - packages/Zope-CMFPlone.git/blob - Zope-CMFPlone.spec
- fixed buildroot
[packages/Zope-CMFPlone.git] / Zope-CMFPlone.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         zope_subname    Plone
3 Summary:        Free and open source Content Management System based on Zope and CMF
4 Summary:        Darmowy i otwarty system zarz±dzania tre¶ci± oparty na Zope i CMF
5 Name:           Zope-CMF%{zope_subname}
6 Version:        2.0
7 %define         sub_ver beta3
8 Release:        4.%{sub_ver}
9 License:        Zope Public License (ZPL), GPL
10 Group:          Networking/Daemons
11 Source0:        http://dl.sourceforge.net/plone/CMF%{zope_subname}%{version}-%{sub_ver}.tar.gz
12 # Source0-md5:  ae47b12f56eb6e4f86ec7b0650e35552
13 URL:            http://www.plone.org/
14 %pyrequires_eq  python-modules
15 Requires:       Zope-CMF >= 1.4
16 Requires:       Zope >= 2.6.2
17 Requires:       Zope-BTreeFolder2
18 Requires:       Zope-CMFQuickInstallerTool
19 Requires:       Zope-ExternalEditor
20 Requires:       Zope-Formulator
21 Requires:       Zope-GroupUserFolder
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24 Obsoletes:      CMF
25
26 %define         product_dir     /usr/lib/zope/Products
27
28 %description
29 Plone is a free, open source Content Management System. The focus of
30 Plone is to provide value at every level of an organization. It comes
31 with a workflow engine, pre-configured security and roles, a set of
32 content types and multi-lingual support. There are many developers,
33 writers and testers from all over the world, contributing to Plone
34 everyday. Plone is based on the Content Management Framework.
35
36 %description -l pl
37 Plone jest darmowym systemem zarz±dzania informacj± z otwartym kodem
38 ¼ród³owym. G³ównym celem Plone jest mo¿liwo¶æ dzielenia siê informacj±
39 na ka¿dym poziomie dostêpu. Jest to "silnik" serwisu umo¿liwiaj±cy
40 pracê z wieloma jêzykami, z wstêpn± konfiguracj± uwzglêdniaj±c±
41 zabezpieczenia serwisu. Plone dzia³a w zestawie z CMF, Zope i
42 Pythonem.
43
44 %prep
45 %setup -q -n CMF%{zope_subname}-%{version}-%{sub_ver}
46
47 %build
48 # remove dirs - additional packages!
49 rm -rf {BTreeFolder2,CMFQuickInstallerTool,ExternalEditor,GroupUserFolder,Formulator}
50
51 mkdir docs docs/CMFPlone docs/CMFFormController docs/i18n
52 rm -rf `find . type f -name .cvsignore`
53 mv -f CMFPlone/{CREDITS.txt,ChangeLog,HISTORY.txt,INSTALL.txt,README.txt} docs/CMFPlone
54 mv -f CMFPlone/docs/* docs/CMFPlone
55 mv -f CMFPlone/i18n/ChangeLog docs/i18n
56 rm -rf CMFPlone/i18n/{build.bat,msgfmt.exe}
57 mv -f CMFFormController/{AUTHORS,ChangeLog,README.txt} docs/CMFFormController
58 rm -rf CMFPlone/docs
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT%{product_dir}
63 cp -af * $RPM_BUILD_ROOT%{product_dir}
64
65 %py_comp $RPM_BUILD_ROOT%{product_dir}
66 %py_ocomp $RPM_BUILD_ROOT%{product_dir}
67
68 rm -rf $RPM_BUILD_ROOT%{product_dir}/docs
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 if [ -f /var/lock/subsys/zope ]; then
75         /etc/rc.d/init.d/zope restart >&2
76 fi
77 echo "From /manage interface there should be a 'Select Type to Add' and says Plone Site" >&2
78
79 %postun
80 if [ -f /var/lock/subsys/zope ]; then
81         /etc/rc.d/init.d/zope restart >&2
82 fi
83
84 %files
85 %defattr(644,root,root,755)
86 %doc docs/*
87 %{product_dir}/CMFPlone
88 %{product_dir}/CMFActionIcons
89 %{product_dir}/CMFFormController
90 # %%{product_dir}/i18n
This page took 0.068587 seconds and 3 git commands to generate.