]> git.pld-linux.org Git - packages/Zope-CMFPlone.git/blob - Zope-CMFPlone.spec
7334336bc963b6c66f5841ee3168a5fe66c75ce3
[packages/Zope-CMFPlone.git] / Zope-CMFPlone.spec
1 #
2 # Warning: This version (RC1) make errors on Zope (2.7b3) after AddPloneSite
3 # Recommended use stable version of Plone :)
4 #
5 %include        /usr/lib/rpm/macros.python
6 %define         zope_subname    CMFPlone
7 Summary:        Free and open source Content Management System based on Zope and CMF
8 Summary:        Darmowy i otwarty system zarz±dzania tre¶ci± oparty na Zope i CMF
9 Name:           Zope-%{zope_subname}
10 Version:        2.0
11 %define         sub_ver RC1 
12 Release:        5.%{sub_ver}.1
13 License:        Zope Public License (ZPL), GPL
14 Group:          Networking/Daemons
15 Source0:        http://dl.sourceforge.net/plone/%{zope_subname}%{version}-%{sub_ver}.tar.gz
16 # Source0-md5:  cd606b698247526073a6ad3a0ffa5579
17 Patch0:         %{name}-migration.patch
18 URL:            http://www.plone.org/
19 %pyrequires_eq  python-modules
20 Requires:       Zope-CMF >= 1.4
21 Requires:       Zope >= 2.6.2
22 Requires:       Zope-BTreeFolder2
23 Requires:       Zope-CMFQuickInstallerTool
24 Requires:       Zope-ExternalEditor
25 Requires:       Zope-Formulator
26 Requires:       Zope-GroupUserFolder >= 2.0
27 Requires(post,postun):  /usr/sbin/installzopeproduct
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30 Obsoletes:      Plone
31 Conflicts:      CMF
32
33 %description
34 Plone is a free, open source Content Management System. The focus of
35 Plone is to provide value at every level of an organization. It comes
36 with a workflow engine, pre-configured security and roles, a set of
37 content types and multi-lingual support. There are many developers,
38 writers and testers from all over the world, contributing to Plone
39 everyday. Plone is based on the Content Management Framework.
40
41 %description -l pl
42 Plone jest darmowym systemem zarz±dzania informacj± z otwartym kodem
43 ¼ród³owym. G³ównym celem Plone jest mo¿liwo¶æ dzielenia siê informacj±
44 na ka¿dym poziomie dostêpu. Jest to "silnik" serwisu umo¿liwiaj±cy
45 pracê z wieloma jêzykami, z wstêpn± konfiguracj± uwzglêdniaj±c±
46 zabezpieczenia serwisu. Plone dzia³a w zestawie z CMF, Zope i
47 Pythonem.
48
49 %prep
50 %setup -q -n %{zope_subname}-%{version}-%{sub_ver}
51 %patch0 -p1
52
53 %build
54 # remove dirs - additional packages!
55 rm -rf {BTreeFolder2,CMFQuickInstallerTool,ExternalEditor,GroupUserFolder,Formulator}
56
57 mkdir docs docs/CMFPlone docs/CMFFormController docs/i18n
58 rm -rf `find . type f -name .cvsignore`
59 mv -f CMFPlone/{CREDITS.txt,ChangeLog,HISTORY.txt,INSTALL.txt,README.txt} docs/CMFPlone
60 mv -f CMFPlone/docs/* docs/CMFPlone
61 mv -f CMFPlone/i18n/ChangeLog docs/i18n
62 rm -rf CMFPlone/i18n/{build.bat,msgfmt.exe}
63 mv -f CMFFormController/{AUTHORS,ChangeLog,README.txt} docs/CMFFormController
64 rm -rf CMFPlone/docs
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
69 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
70
71 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
72 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
73
74 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post
80 for p in CMFPlone CMFActionIcons CMFFormController; do
81         /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
82 done
83 if [ -f /var/lock/subsys/zope ]; then
84         /etc/rc.d/init.d/zope restart >&2
85 fi
86
87 %postun
88 if [ "$1" = "0" ]; then
89         for p in CMFPlone CMFActionIcons CMFFormController; do
90                 /usr/sbin/installzopeproduct -d $p
91         done
92         if [ -f /var/lock/subsys/zope ]; then
93                 /etc/rc.d/init.d/zope restart >&2
94         fi
95 fi
96
97 %files
98 %defattr(644,root,root,755)
99 %doc docs/*
100 %{_datadir}/%{name}
This page took 0.02905 seconds and 2 git commands to generate.