]> git.pld-linux.org Git - packages/Zope-CMFPlone.git/blob - Zope-CMFPlone.spec
- removed old *.pyo
[packages/Zope-CMFPlone.git] / Zope-CMFPlone.spec
1
2 %include        /usr/lib/rpm/macros.python
3 %define         zope_subname    CMFPlone
4 Summary:        Free and open source Content Management System based on Zope and CMF
5 Summary:        Darmowy i otwarty system zarz±dzania tre¶ci± oparty na Zope i CMF
6 Name:           Zope-%{zope_subname}
7 Version:        2.0
8 %define         sub_ver RC1 
9 Release:        5.%{sub_ver}.2
10 License:        Zope Public License (ZPL), GPL
11 Group:          Networking/Daemons
12 Source0:        http://dl.sourceforge.net/plone/%{zope_subname}%{version}-%{sub_ver}.tar.gz
13 # Source0-md5:  cd606b698247526073a6ad3a0ffa5579
14 Patch0:         %{name}-migration.patch
15 URL:            http://www.plone.org/
16 %pyrequires_eq  python-modules
17 Requires:       Zope-CMF >= 1.4
18 Requires:       Zope >= 2.6.2
19 Requires:       Zope-BTreeFolder2
20 Requires:       Zope-CMFQuickInstallerTool
21 Requires:       Zope-ExternalEditor
22 Requires:       Zope-Formulator
23 Requires:       Zope-GroupUserFolder >= 2.0
24 Requires(post,postun):  /usr/sbin/installzopeproduct
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27 Obsoletes:      Plone
28 Conflicts:      CMF
29
30 %description
31 Plone is a free, open source Content Management System. The focus of
32 Plone is to provide value at every level of an organization. It comes
33 with a workflow engine, pre-configured security and roles, a set of
34 content types and multi-lingual support. There are many developers,
35 writers and testers from all over the world, contributing to Plone
36 everyday. Plone is based on the Content Management Framework.
37
38 %description -l pl
39 Plone jest darmowym systemem zarz±dzania informacj± z otwartym kodem
40 ¼ród³owym. G³ównym celem Plone jest mo¿liwo¶æ dzielenia siê informacj±
41 na ka¿dym poziomie dostêpu. Jest to "silnik" serwisu umo¿liwiaj±cy
42 pracê z wieloma jêzykami, z wstêpn± konfiguracj± uwzglêdniaj±c±
43 zabezpieczenia serwisu. Plone dzia³a w zestawie z CMF, Zope i
44 Pythonem.
45
46 %prep
47 %setup -q -n %{zope_subname}-%{version}-%{sub_ver}
48 %patch0 -p1
49
50 %build
51 # remove dirs - additional packages!
52 rm -rf {BTreeFolder2,CMFQuickInstallerTool,ExternalEditor,GroupUserFolder,Formulator}
53 find . -type f -name "*.pyo" -exec rm -rf {} \;;
54
55 mkdir docs docs/CMFPlone docs/CMFFormController docs/i18n
56 rm -rf `find . type f -name .cvsignore`
57 mv -f CMFPlone/{CREDITS.txt,ChangeLog,HISTORY.txt,INSTALL.txt,README.txt} docs/CMFPlone
58 mv -f CMFPlone/docs/* docs/CMFPlone
59 mv -f CMFPlone/i18n/ChangeLog docs/i18n
60 rm -rf CMFPlone/i18n/{build.bat,msgfmt.exe}
61 mv -f CMFFormController/{AUTHORS,ChangeLog,README.txt} docs/CMFFormController
62 rm -rf CMFPlone/docs
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
67 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
68
69 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
70 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
71
72 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 for p in CMFPlone CMFActionIcons CMFFormController; do
79         /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
80 done
81 if [ -f /var/lock/subsys/zope ]; then
82         /etc/rc.d/init.d/zope restart >&2
83 fi
84
85 %postun
86 if [ "$1" = "0" ]; then
87         for p in CMFPlone CMFActionIcons CMFFormController; do
88                 /usr/sbin/installzopeproduct -d $p
89         done
90         if [ -f /var/lock/subsys/zope ]; then
91                 /etc/rc.d/init.d/zope restart >&2
92         fi
93 fi
94
95 %files
96 %defattr(644,root,root,755)
97 %doc docs/*
98 %{_datadir}/%{name}
This page took 0.064515 seconds and 3 git commands to generate.