]> git.pld-linux.org Git - packages/Zope-CMFForum.git/blob - Zope-CMFForum.spec
- initial release
[packages/Zope-CMFForum.git] / Zope-CMFForum.spec
1 %define         zope_subname    CMFForum
2 Summary:        CMMForum is a Zope product that Anonymous can post by default.
3 Summary(pl):    CMMForum jest dodatkiem do Zope daj±cy mo¿liwo¶æ wys³ania e-maila
4 Name:           Zope-%{zope_subname}
5 Version:        1.0
6 Release:        1
7 License:        GNU
8 Group:          Development/Tools
9 Source0:        http://telia.dl.sourceforge.net/sourceforge/collective/%{zope_subname}-%{version}.tgz
10 # Source0-md5:  dc9ee26b8c78a32238afd2540dcf258c
11
12 URL:            http://sourceforge.net/projects/collective
13 Requires:       python >= 2.2
14 Requires:       python-modules >= 2.2
15 Requires:       python-libs >= 2.2
16 Requires:       Zope
17 Requires:       CMF
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 # define        python_prefix           %(echo `python -c "import sys; print sys.prefix"`)
21 # define        python_version          %(echo `python -c "import sys; print sys.version[:3]"`)
22 # define        python_libdir           %{python_prefix}/lib/python%{python_version}
23 # define        python_sitedir          %{python_libdir}/site-packages
24
25 %define         zope_lib        /usr/lib/zope/Addons
26 %define         product_dir     /usr/lib/zope/Products
27
28 %description
29 CMMForum is a Zope product - Anonymous can post by default but cant
30 add Attachments - Anonumous can set Author and e-mail fields. Logged
31 in user gets 'username' as Author and email from preferences. Security
32 cleanup.
33
34 %description -l pl
35 CMMForum jest dodatkiem do Zope umo¿liwiaj±cy dodanie formy wysy³ania
36 e-mail bez mo¿liwo¶ci wysy³ania za³±czników. Anonymous mo¿e ustawiæ
37 adres e-mail, a je¿eli zaloguje siê jako konkretny u¿ytkownik, wtedy
38 pobierane s± odpowiednie pola z preferencji. Dodatek sprawdzony pod
39 wzglêdem bezpieczeñstwa.
40
41 %prep
42 %setup -q -c %{zope_subname}-%{version}
43
44 %build
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT%{zope_lib}
49 install -d $RPM_BUILD_ROOT%{product_dir}
50 cp -af * $RPM_BUILD_ROOT%{zope_lib}/%{zope_subname}
51 rm -rf $RPM_BUILD_ROOT%{zope_lib}/%{zope_subname}/*.txt
52 ln -s %{zope_lib}/%{zope_subname}/ $RPM_BUILD_ROOT%{product_dir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 if [ -f /var/lock/subsys/zope ]; then
59         /etc/rc.d/init.d/zope restart >&2
60 fi
61
62 %preun
63
64 %postun
65 if [ -f /var/lock/subsys/zope ]; then
66         /etc/rc.d/init.d/zope restart >&2
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc %{zope_subname}/*.txt
72 %{zope_lib}
73 %{product_dir}
This page took 0.06812 seconds and 4 git commands to generate.