]> git.pld-linux.org Git - packages/Zope-CMFForum.git/blob - Zope-CMFForum.spec
- install into new dir (datadir)
[packages/Zope-CMFForum.git] / Zope-CMFForum.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         zope_subname    CMFForum
3 Summary:        A Zope product that Anonymous can post by default
4 Summary(pl):    Dodatek do Zope daj±cy mo¿liwo¶æ wys³ania e-maila
5 Name:           Zope-%{zope_subname}
6 Version:        1.0
7 Release:        6
8 License:        ZPL 2.0
9 Group:          Development/Tools
10 Source0:        http://dl.sourceforge.net/collective/%{zope_subname}-%{version}.tgz
11 # Source0-md5:  dc9ee26b8c78a32238afd2540dcf258c
12 URL:            http://sourceforge.net/projects/collective/
13 %pyrequires_eq  python-modules
14 Requires:       Zope >= 2.5.1
15 Requires:       Zope-CMF >= 1.3
16 Requires(post,postun):  /usr/sbin/installzopeproduct
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 Conflicts:      CMF
20
21 %description
22 CMMForum is a Zope product - Anonymous can post by default but can't
23 add Attachments - Anonymous can set Author and e-mail fields. Logged
24 in user gets 'username' as Author and email from preferences. Security
25 cleanup.
26
27 %description -l pl
28 CMMForum jest dodatkiem do Zope umo¿liwiaj±cym dodanie formy wysy³ania
29 e-mailem bez mo¿liwo¶ci wysy³ania za³±czników. Anonymous mo¿e ustawiæ
30 adres e-mail, a je¿eli zaloguje siê jako konkretny u¿ytkownik, wtedy
31 pobierane s± odpowiednie pola z preferencji. Dodatek sprawdzony pod
32 wzglêdem bezpieczeñstwa.
33
34 %prep
35 %setup -q -n %{zope_subname}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
40
41 cp -af {Extensions,interfaces,skins,*.py,*.gif} $RPM_BUILD_ROOT%{_datadir}/%{name}
42
43 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
44 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
45
46 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
53 if [ -f /var/lock/subsys/zope ]; then
54         /etc/rc.d/init.d/zope restart >&2
55 fi
56
57 %postun
58 if [ "$1" = "0" ]; then
59         /usr/sbin/installzopeproduct -d %{zope_subname}
60         if [ -f /var/lock/subsys/zope ]; then
61                 /etc/rc.d/init.d/zope restart >&2
62         fi
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %doc CHANGES.txt CREDITS.txt HISTORY.txt INSTALL.txt LICENSE.txt README.txt TODO.txt
68 %{_datadir}/%{name}
This page took 0.04624 seconds and 4 git commands to generate.