]> git.pld-linux.org Git - packages/ZendStudio.git/blob - ZendStudio.spec
up to 10.6.0
[packages/ZendStudio.git] / ZendStudio.spec
1 # TODO
2 # - sync -pl
3 # - contains: eclipse, jre - maybe can use system pkgs
4 Summary:        Zend Studio - The Leading PHP IDE
5 Summary(pl.UTF-8):      ZendStudio - narzędzia do zarządzania serwerami WWW opartymi o PHP
6 Name:           ZendStudio
7 Version:        10.6.0
8 Release:        0.1
9 License:        Zend Studio License
10 Group:          Applications
11 Source0:        http://downloads.zend.com/studio-eclipse/%{version}/%{name}-%{version}-linux.gtk.x86.tar.gz
12 # NoSource0-md5:        d618f10c50d5077b1d6c72406d5a57d6
13 NoSource:       0
14 Source1:        http://downloads.zend.com/studio-eclipse/%{version}/%{name}-%{version}-linux.gtk.x86_64.tar.gz
15 # NoSource1-md5:        3ca8d2aa435070d8405b290875dbd610
16 NoSource:       1
17 URL:            http://www.zend.com/products/studio/
18 BuildRequires:  rpm-pythonprov
19 ExclusiveArch:  %{ix86} %{x8664}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _appdir         %{_libdir}/%{name}
23
24 # no Provides for privately packaged libs
25 %define         _noautoprov             libpng12.so.0
26 %define         _noautoreq              %{_noautoprov}
27
28 # don't strip anything. strip crashes, and if it succeeds then ZS crashes
29 %define         _noautostrip    .*%{_appdir}/.*
30
31 # otherwise it builds this package two decades
32 %define         _noautoprovfiles        %{_appdir}/.*
33
34 %description
35 Zend Studio is our professional-grade PHP IDE (Integrated Development
36 Environment). It has been designed to maximize developer productivity
37 by enabling you to develop and maintain code faster, solve application
38 problems quickly and improve team collaboration.
39
40 %description -l pl.UTF-8
41 Ten pakiet zawiera narzędzia do zarządzania serwerami WWW opartymi o
42 PHP. Moduł pozwala na przezroczystą instalację i integrację,
43 jednocześnie upraszczając konfigurowanie PHP i zdalną diagnostykę oraz
44 utrzymywanie bezpieczeństwa.
45
46 %prep
47 %ifarch %{ix86}
48 %setup -qcT -b 0
49 %endif
50 %ifarch %{x8664}
51 %setup -qcT -b 1
52 %endif
53 mv %{name} .unp && mv .unp/* .unp/.eclipseproduct . && rmdir .unp
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT%{_appdir}
58
59 # test if we can hardlink -- %{_builddir} and $RPM_BUILD_ROOT on same partition
60 if cp -al notice.html $RPM_BUILD_ROOT/notice.html; then
61         l=l
62         rm -f $RPM_BUILD_ROOT/notice.html
63 fi
64
65 cp -a$l . $RPM_BUILD_ROOT%{_appdir}
66
67 rm -f $RPM_BUILD_ROOT%{_appdir}/debug*.list
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %dir %{_appdir}
75 %attr(755,root,root) %{_appdir}/ZendStudio
76 %attr(755,root,root) %{_appdir}/libcairo-swt.so
77
78 # use actual file permissions from source tarball. fix this later
79 %defattr(-,root,root,-)
80
81 %{_appdir}/.eclipseproduct
82 %{_appdir}/readme
83 %{_appdir}/epl-v10.html
84 %{_appdir}/notice.html
85
86 %{_appdir}/ZendStudio.ini
87 %{_appdir}/icon.xpm
88 %{_appdir}/configuration
89 %{_appdir}/p2
90
91 %{_appdir}/artifacts.xml
92 %{_appdir}/features
93 %{_appdir}/plugins
This page took 0.08302 seconds and 3 git commands to generate.