]> git.pld-linux.org Git - packages/ZendDebugger.git/blob - ZendDebugger.spec
ffb5892a1c2e369648701d0425fdfba379f03f4d
[packages/ZendDebugger.git] / ZendDebugger.spec
1 # NOTE
2 # - Unusable in PLD Linux as our PHP is compiled with ZTS, while this extension is not
3 # - Can't find what Free Download means (http://www.zend.com/free_download/list)
4 %define         php4_version    4.4
5 %define         php5_version    5.2
6 Summary:        The Zend Debug Server enabling remote debugging of PHP applications
7 Summary(pl.UTF-8):      Zend Debug Server pozwalający na zdalne śledzenie aplikacji PHP
8 Name:           ZendDebugger
9 Version:        5.2.10
10 Release:        0.4
11 License:        Free Download
12 Group:          Development/Languages/PHP
13 Source0:        http://downloads.zend.com/pdt/server-debugger/%{name}-%{version}-linux-glibc21-i386.tar.gz
14 # NoSource0-md5:        d2ee7659c0c8721221696cab5e765936
15 NoSource:       0
16 Source1:        http://downloads.zend.com/pdt/server-debugger/%{name}-%{version}-linux-glibc23-x86_64.tar.gz
17 # NoSource1-md5:        3238904ebd1accd5795a50fb88fc6fff
18 NoSource:       1
19 URL:            http://www.zend.com/store/software/zend_studio
20 BuildRequires:  tar >= 1:1.15.1
21 ExclusiveArch:  %{ix86} %{x8664}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _datadir        %{_prefix}/share/Zend
25 %define         no_install_post_strip           1
26 %define         no_install_post_chrpath         1
27 %define         _php4_extensiondir      %{_libdir}/php4
28 %define         _php5_extensiondir      %{_libdir}/php
29 %define         _php4_sysconfdir        /etc/php4/conf.d
30 %define         _php5_sysconfdir        /etc/php/conf.d
31
32 %description
33 The Zend Debug Server enables remote debugging of PHP applications. It
34 plugs into a PHP server and allows the Zend Development Environment to
35 control the execution of PHP applications on the server.
36
37 The Debug Server is designed be deployed safely on production servers.
38 It does not affect server performance and features access-list based
39 security for protecting the server from unauthorized access.
40
41 %description -l pl.UTF-8
42 Zend Debug Server pozwala na zdalne śledzenie aplikacji PHP. Podłącza
43 się do serwera PHP i pozwala środowisku Zend Development Environment
44 sterować wykonywaniem aplikacji PHP na serwerze.
45
46 Debug server jest zaprojektowany z myślą o bezpiecznym wdrożeniu na
47 serwerach produkcyjnych. Nie wpływa na wydajność serwera i cechuje się
48 bezpieczeństwem opartym na listach dostępu.
49
50 %package -n php4-%{name}
51 Summary:        Zend Debugger for PHP 4.x
52 Summary(pl.UTF-8):      Zend Debugger dla PHP 4.x
53 Group:          Development/Languages/PHP
54 Requires:       php4(thread-safety) = 0
55 Requires:       php4-common < 3:%(awk 'BEGIN{print %{php4_version} + 0.1}')
56 Requires:       php4-common >= 3:%{php4_version}
57 Conflicts:      ZendStudioServer <= 5.2.0
58
59 %description -n php4-%{name}
60 The Zend Debug Server enables remote debugging of PHP applications. It
61 plugs into a PHP server and allows the Zend Development Environment to
62 control the execution of PHP applications on the server.
63
64 The Debug Server is designed be deployed safely on production servers.
65 It does not affect server performance and features access-list based
66 security for protecting the server from unauthorized access.
67
68 %description -n php4-%{name} -l pl.UTF-8
69 Zend Debug Server pozwala na zdalne śledzenie aplikacji PHP. Podłącza
70 się do serwera PHP i pozwala środowisku Zend Development Environment
71 sterować wykonywaniem aplikacji PHP na serwerze.
72
73 Debug server jest zaprojektowany z myślą o bezpiecznym wdrożeniu na
74 serwerach produkcyjnych. Nie wpływa na wydajność serwera i cechuje się
75 bezpieczeństwem opartym na listach dostępu.
76
77 %package -n php-%{name}
78 Summary:        Zend Debugger for PHP 5.x
79 Summary(pl.UTF-8):      Zend Debugger dla PHP 5.x
80 Group:          Development/Languages/PHP
81 Requires:       php-common < 4:%(awk 'BEGIN{print %{php5_version} + 0.1}')
82 Requires:       php-common >= 4:%{php5_version}
83 Requires:       php5(thread-safety) = 0
84 Conflicts:      ZendStudioServer <= 5.2.0
85
86 %description -n php-%{name}
87 The Zend Debug Server enables remote debugging of PHP applications. It
88 plugs into a PHP server and allows the Zend Development Environment to
89 control the execution of PHP applications on the server.
90
91 The Debug Server is designed be deployed safely on production servers.
92 It does not affect server performance and features access-list based
93 security for protecting the server from unauthorized access.
94
95 %description -n php-%{name} -l pl.UTF-8
96 Zend Debug Server pozwala na zdalne śledzenie aplikacji PHP. Podłącza
97 się do serwera PHP i pozwala środowisku Zend Development Environment
98 sterować wykonywaniem aplikacji PHP na serwerze.
99
100 Debug server jest zaprojektowany z myślą o bezpiecznym wdrożeniu na
101 serwerach produkcyjnych. Nie wpływa na wydajność serwera i cechuje się
102 bezpieczeństwem opartym na listach dostępu.
103
104 %prep
105 %setup -qcT
106 %ifarch %{x8664}
107 tar --strip-components=1 -xzf %{SOURCE1}
108 %else
109 tar --strip-components=1 -xzf %{SOURCE0}
110 %endif
111
112 cat > zend.ini <<EOF
113 [Zend]
114 zend_debugger.allow_hosts=127.0.0.1
115 zend_debugger.expose_remotely=always
116 EOF
117
118 cat <<'EOF' > pack4.ini
119 ; %{name} package settings. Overwritten with each upgrade.
120 ; if you need to add options, edit %{name}.ini instead
121 [Zend]
122 zend_extension=%{_php4_extensiondir}/ZendDebugger.so
123 EOF
124
125 cat <<'EOF' > pack5.ini
126 ; %{name} package settings. Overwritten with each upgrade.
127 ; if you need to add options, edit %{name}.ini instead
128 [Zend]
129 zend_extension=%{_php5_extensiondir}/ZendDebugger.so
130 EOF
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT{%{_php4_extensiondir},%{_php5_extensiondir}}
135 install %(echo %{php4_version} | tr . _)_x_comp/ZendDebugger.so $RPM_BUILD_ROOT%{_php4_extensiondir}
136 install %(echo %{php5_version} | tr . _)_x_comp/ZendDebugger.so $RPM_BUILD_ROOT%{_php5_extensiondir}
137
138 install -d $RPM_BUILD_ROOT{%{_php4_sysconfdir},%{_php5_sysconfdir}}
139 install zend.ini $RPM_BUILD_ROOT%{_php4_sysconfdir}/%{name}.ini
140 install zend.ini $RPM_BUILD_ROOT%{_php5_sysconfdir}/%{name}.ini
141 install pack4.ini $RPM_BUILD_ROOT%{_php4_sysconfdir}/%{name}_pack.ini
142 install pack5.ini $RPM_BUILD_ROOT%{_php5_sysconfdir}/%{name}_pack.ini
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %preun -n php4-%{name}
148 if [ "$1" = "0" ]; then
149         %php4_webserver_restart
150 fi
151
152 %post -n php4-%{name}
153 %php4_webserver_restart
154
155 %preun -n php-%{name}
156 if [ "$1" = "0" ]; then
157         %php_webserver_restart
158 fi
159
160 %post -n php-%{name}
161 %php_webserver_restart
162
163 %files -n php4-%{name}
164 %defattr(644,root,root,755)
165 %config(noreplace) %verify(not md5 mtime size) %{_php4_sysconfdir}/%{name}.ini
166 %config %verify(not md5 mtime size) %{_php4_sysconfdir}/%{name}_pack.ini
167 %attr(755,root,root) %{_php4_extensiondir}/ZendDebugger.so
168
169 %files -n php-%{name}
170 %defattr(644,root,root,755)
171 %config(noreplace) %verify(not md5 mtime size) %{_php5_sysconfdir}/%{name}.ini
172 %config %verify(not md5 mtime size) %{_php5_sysconfdir}/%{name}_pack.ini
173 %attr(755,root,root) %{_php5_extensiondir}/ZendDebugger.so
This page took 0.080389 seconds and 2 git commands to generate.