]> git.pld-linux.org Git - packages/ZThread.git/commitdiff
- more fixes in c++ patch
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 4 Nov 2013 19:39:37 +0000 (20:39 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 4 Nov 2013 19:39:37 +0000 (20:39 +0100)
ZThread-c++.patch
ZThread.spec

index 3dcf4a82d0e23507619c6d042f29905cff885f03..d67167b8159c1506ef3a3cda51f80e6b0417fd1e 100644 (file)
      for(;;) {
 --- ZThread-2.3.2/include/zthread/Guard.h.orig 2005-03-13 03:10:09.000000000 +0100
 +++ ZThread-2.3.2/include/zthread/Guard.h      2008-09-10 18:14:58.176983956 +0200
+@@ -428,7 +428,7 @@
+   template <class U, class V>
+   Guard(Guard<U, V>& g) : LockHolder<LockType>(g) {
+-    LockingPolicy::shareScope(*this, extract(g));
++    LockingPolicy::shareScope(*this, this->extract(g));
+     
+   }
+@@ -458,7 +458,7 @@
+   template <class U, class V>
+   Guard(Guard<U, V>& g, LockType& lock) : LockHolder<LockType>(lock) {
+-    LockingPolicy::transferScope(*this, extract(g));
++    LockingPolicy::transferScope(*this, this->extract(g));
+   }
 @@ -491,7 +491,7 @@ Guard<LockType, LockingPolicy>::~Guard()
      
    try {
index 9696325adf2446841a9ec3eb328b5549c4fe4fec..91fad1de90227ba113ab96fa1b2ec86ccf08f867 100644 (file)
@@ -5,7 +5,7 @@ Version:        2.3.2
 Release:       1
 License:       MIT
 Group:         Libraries
-Source0:       http://dl.sourceforge.net/zthread/%{name}-%{version}.tar.gz
+Source0:       http://downloads.sourceforge.net/zthread/%{name}-%{version}.tar.gz
 # Source0-md5: f2782d19b8ed6f1ff2ab8824dd4ba48e
 Patch0:                %{name}-c++.patch
 Patch1:                %{name}-destdir.patch
This page took 0.441105 seconds and 4 git commands to generate.