]> git.pld-linux.org Git - packages/Yap.git/blob - Yap.spec
a1587db0be479c300ccd1e4679d722ed16cc9d6e
[packages/Yap.git] / Yap.spec
1 Summary:        Prolog Compiler
2 Summary(pl):    Kompilator Prologu
3 Name:           Yap
4 Version:        4.5.5
5 Release:        1
6 License:        Artistic
7 Group:          Development/Languages
8 Source0:        http://dl.sourceforge.net/yap/%{name}-%{version}.tar.gz
9 # Source0-md5:  661e289f4bdac0e6cfc7e59d4421c2a8
10 Patch0:         %{name}-acdirs.patch
11 Patch1:         %{name}-port.patch
12 Patch2:         %{name}-nolibs.patch
13 Patch3:         %{name}-info.patch
14 URL:            http://www.ncc.up.pt/~vsc/Yap/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  gmp-devel
18 BuildRequires:  indent
19 BuildRequires:  readline-devel
20 BuildRequires:  texinfo
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # follow configure
24 %define         specflags_ia32  -DBP_FREE
25
26 %description
27 A high-performance Prolog compiler developed at LIACC, Universidade do
28 Porto. The Prolog engine is based in the WAM (Warren Abstract
29 Machine), with several optimizations for better performance. YAP
30 follows the Edinburgh tradition, and is largely compatible with the
31 ISO-Prolog standard and with Quintus and SICStus Prolog.
32
33 %description -l pl
34 Wydajny kompilator Prologu stworzony w LIACC, Universidade do
35 Porto. Silnik Prologu bazuje na WAM (Warren Abstract Machine), z
36 ró¿nymi optymalizacjami dla lepszej wydajno¶ci. Zgodnie z tradycj±
37 Edinburgh jest on wysoce kompatybilny ze standardem ISO-Prolog oraz
38 z Prologiem Quintus i SICStus.
39
40 %package static
41 Summary:        Static library for YAP Prolog
42 Summary(pl):    Statyczna biblioteka dla kompilatora Prologu YAP
43 Group:          Development/Languages
44 Requires:       %{name} = %{version}-%{release}
45
46 %description static
47 Static library for YAP prolog.
48
49 %description static -l pl
50 Statyczna biblioteka dla kompilatora prologu YAP.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55 %patch1 -p1
56 %patch2 -p1
57 %patch3 -p1
58
59 %build
60 cp -f /usr/share/automake/config.sub .
61 %{__aclocal}
62 %{__autoconf}
63 CFLAGS="%{rpmcflags}%{!?debug: -fomit-frame-pointer} -Wall"
64 %configure \
65         C_INTERF_FLAGS="%{rpmcflags} -Wall" \
66         C_PARSER_FLAGS="%{rpmcflags} -Wall" \
67         --enable-coroutining \
68         %{?debug:--enable-debug-yap} \
69         --enable-depth-limit \
70         --enable-low-level-tracer
71
72 %{__make}
73
74 %{__make} -C docs info
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{%{_infodir},%{_examplesdir}/%{name}-%{version},%{_libdir}/%{name}}
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 install docs/*info* $RPM_BUILD_ROOT%{_infodir}
84
85 for d in chr clpqr; do
86         mv -f $RPM_BUILD_ROOT%{_datadir}/Yap/$d/examples \
87                 $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$d
88 done
89
90 %post
91 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
92 /sbin/ldconfig
93
94 %postun
95 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
96 /sbin/ldconfig
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(644,root,root,755)
103 %doc README* changes4.3.html docs/yap.tex
104 %attr(755,root,root) %{_bindir}/yap
105 %dir %{_libdir}/%{name}
106 %attr(755,root,root) %{_libdir}/%{name}/*.so
107 %attr(755,root,root) %{_libdir}/%{name}/startup
108 %{_datadir}/%{name}
109 %{_includedir}/%{name}
110 %{_infodir}/*info*
111 %{_examplesdir}/%{name}-%{version}
112
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/libYap.a
This page took 0.111388 seconds and 2 git commands to generate.