]> git.pld-linux.org Git - packages/Xnee.git/blame - Xnee.spec
- invoke fix-info-dir via /sbin/postshell where possible to avoid extra /bin/sh dep
[packages/Xnee.git] / Xnee.spec
CommitLineData
39241bfa 1# TODO:
8445abf7
JB
2# - package libxnee if needed for anything (it's noinst now)
3# - generate docs - (some files are missing)
4#
5# Conditional build:
6%bcond_with doc # documentation (broken, missing files)
7%bcond_without gnome # GNOME panel applet
8#
32202ea1 9Summary: Suite of programs that can record and replay user actions under X11
8af58442 10Summary(pl.UTF-8): Zestaw programów do nagrywania i odtwarzania akcji użytkownika pod X11
39241bfa 11Name: Xnee
7c2500e2 12Version: 3.01
39241bfa 13Release: 0.1
8445abf7 14License: GPL v3+
32202ea1
JB
15Group: X11/Applications
16Source0: ftp://ftp.gnu.org/gnu/xnee/%{name}-%{version}.tar.gz
7c2500e2 17# Source0-md5: a6e1e797170317a7454723a7cd7b3c58
32202ea1 18Patch0: %{name}-info.patch
39241bfa 19URL: http://www.gnu.org/software/xnee/www/index.html
8445abf7
JB
20BuildRequires: gtk+2-devel >= 1:2.0.0
21BuildRequires: pkgconfig >= 1:0.9.0
22BuildRequires: texinfo
7c2500e2
MWP
23BuildRequires: xorg-proto-recordproto-devel
24BuildRequires: xorg-lib-libXtst-devel
8445abf7
JB
25%if %{with gnome}
26BuildRequires: GConf2-devel >= 2.0
27BuildRequires: gnome-panel-devel >= 2.0
28%endif
29%if %{with doc}
30BuildRequires: ImageMagick
31BuildRequires: ImageMagick-coder-jpeg
32BuildRequires: ImageMagick-coder-png
33BuildRequires: dia
34BuildRequires: ghostscript
35BuildRequires: tetex-dvips
36BuildRequires: tetex-format-plain
37BuildRequires: tetex-tex-misc
38BuildRequires: texinfo-texi2dvi
39%endif
39241bfa 40Provides: xnee
8445abf7 41Obsoletes: xnee
32202ea1
JB
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45Xnee is a suite of programs that can record, replay and distribute
46user actions under the X11 environment. Think of it as a robot that
47can imitate the job you just did. Xnee can be used to: automate tests,
48demonstrate programs, distribute actions, record and replay "macros",
49retype a file etc.
50
2f4dc8a5
JR
51%description -l pl.UTF-8
52Xnee to zestaw programów do nagrywania, odtwarzania i powielania akcji
53użytkownika w środowisku X11. Można je określić jako maszynę
54powtarzającą pracę wykonaną przez nas. Xnee można użyć do:
55automatyzowania testów, demonstrowania programów, powielania akcji (na
32202ea1 56wielu komputerach), nagrywania i odtwarzania "makr", przepisywania
2f4dc8a5 57plików itp.
32202ea1 58
8445abf7
JB
59%package gtk
60Summary: gnee - GTK+ based graphical frontent to GNU Xnee
61Summary(pl.UTF-8): gnee - oparty na GTK+ graficzny interfejs do GNU Xnee
62Group: X11/Applications
63Requires: %{name} = %{version}-%{release}
64
65%description gtk
66gnee is the graphical frontend to GNU Xnee, based on GTK+ toolkit.
67
68%description gtk -l pl.UTF-8
69gnee to graficzny interfejs do GNU Xnee, oparty na GTK+.
70
71%package gnome
72Summary: pnee - GNOME panel applet for GNU Xnee
73Summary(pl.UTF-8): pnee - aplet panelu GNOME dla GNU Xnee
74Group: X11/Applications
75Requires: %{name} = %{version}-%{release}
76
77%description gnome
78pnee is the GNOME panel applet for GNU Xnee.
79
80%description gnome -l pl.UTF-8
81pnee to aplet panelu GNOME dla GNU Xnee.
82
32202ea1
JB
83%prep
84%setup -q
8445abf7 85%patch0 -p1
32202ea1
JB
86
87%build
39241bfa 88%configure \
8445abf7
JB
89 --disable-doc \
90 %{!?with_gnome:--disable-gnome-applet} \
91 --enable-xosd
39241bfa 92
32202ea1 93%{__make} \
8445abf7 94 CNEE_INFO="cnee.info"
32202ea1
JB
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99%{__make} install \
8445abf7 100 DESTDIR=$RPM_BUILD_ROOT \
17ddc481
JB
101 CNEE_INFO="cnee.info" \
102 PANEL_APPLET_DIR=$RPM_BUILD_ROOT%{_bindir} \
103 PANEL_SERVER_DIR=$RPM_BUILD_ROOT%{_libdir}/bonobo/servers
32202ea1
JB
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
8998578e
ER
108%post -p /sbin/postshell
109-/usr/sbin/fix-info-dir -c %{_infodir}
32202ea1 110
8998578e
ER
111%postun -p /sbin/postshell
112-/usr/sbin/fix-info-dir -c %{_infodir}
32202ea1
JB
113
114%files
115%defattr(644,root,root,755)
8445abf7 116%doc AUTHORS BUGS ChangeLog FAQ NEWS README TODO
39241bfa 117%attr(755,root,root) %{_bindir}/cnee
8445abf7
JB
118%dir %{_datadir}/xnee
119%{_datadir}/xnee/*.sh
120%{_datadir}/xnee/*.xns
121%dir %{_datadir}/xnee/pixmaps
122%{_datadir}/xnee/pixmaps/xnee.png
123%{_datadir}/xnee/pixmaps/xnee.xpm
124%{_mandir}/man1/cnee.1*
125%{_mandir}/man1/xnee.1*
126%{_infodir}/cnee.info*
127
128%files gtk
129%defattr(644,root,root,755)
130%doc gnee/AUTHORS
39241bfa 131%attr(755,root,root) %{_bindir}/gnee
8445abf7
JB
132%{_mandir}/man1/gnee.1*
133
134%if %{with gnome}
135%files gnome
136%defattr(644,root,root,755)
17ddc481 137%attr(755,root,root) %{_bindir}/pnee
8445abf7
JB
138%{_libdir}/bonobo/servers/pnee.server
139%{_datadir}/xnee/pixmaps/pnee-*.png
140%{_mandir}/man1/pnee.1*
141%endif
This page took 0.075983 seconds and 4 git commands to generate.