]> git.pld-linux.org Git - packages/XmHTML.git/blob - XmHTML.spec
- massive attack: no need for 755 for *.la
[packages/XmHTML.git] / XmHTML.spec
1 Summary:        Motif HTML widget
2 Summary(pl):    Widget do HTML oparty o Motif
3 Name:           XmHTML
4 Version:        1.1.7
5 Release:        2
6 License:        LGPL
7 Group:          X11/Libraries
8 Source0:        http://www.xs4all.nl/~ripley/XmHTML/dist/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-am.patch
10 Patch1:         %{name}-macro.patch
11 URL:            http://www.xs4all.nl/~ripley/XmHTML/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  lesstif-devel
15 BuildRequires:  libjpeg-devel
16 BuildRequires:  libpng-devel
17 BuildRequires:  libtool
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _prefix         /usr/X11R6
21 %define         _mandir         %{_prefix}/man
22
23 %description
24 XmHTML provides a widget capable of displaying HTML 3.2 conforming
25 text.
26
27 %description -l pl
28 XmHTML zawiera widget wy¶wietlaj±cy HTML w wersji 3.2.
29
30 %package devel
31 Summary:        Development package of XmHTML
32 Summary(pl):    Pliki nag³ówkowe XmHTML
33 Group:          X11/Development/Libraries
34 Requires:       %{name} = %{version}
35 Requires:       lesstif-devel
36
37 %description devel
38 Headers needed to compile XmHTML programs.
39
40 %description devel -l pl
41 Pliki nag³ówkowe potrzebne do kompilowania programów korzystaj±cych z
42 XmHTML.
43
44 %package static
45 Summary:        Static version of XmHTML library
46 Summary(pl):    Statyczna biblioteka XmHTML
47 Group:          X11/Development/Libraries
48 Requires:       %{name}-devel = %{version}
49
50 %description static
51 Static version of XmHTML library.
52
53 %description static -l pl
54 Statyczna wersja biblioteki XmHTML.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59 %patch1 -p1
60
61 %build
62 # Argh! automake stuff outdated, imake stuff outdated even more,
63 # makefiles not outdated but don't support shared libraries :/
64 # Use automake with some patches/workarounds/etc
65 (cd lib
66 mv -f common/*.c .
67 mv -f Motif/*.c .
68 )
69
70 rm -f missing
71 %{__libtoolize}
72 %{__aclocal}
73 %{__autoconf}
74 %{__automake}
75 CFLAGS="%{rpmcflags} \
76         -I`pwd`/include/XmHTML -I`pwd`/include/common \
77         %{!?debug:-DNDEBUG -Dproduction} -DVERSION=1107"
78 %configure PNGINC="`pkg-config --cflags libpng12 2>/dev/null`"
79
80 cd lib
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT%{_includedir}/XmHTML
86
87 %{__make} install -C lib DESTDIR=$RPM_BUILD_ROOT
88
89 install include/XmHTML/{Balloon,HTML,HTMLStrings,XCC,XmHTML}.h \
90         include/common/LZWStream.h \
91         $RPM_BUILD_ROOT%{_includedir}/XmHTML
92
93 rm -f html/man/man.{map,tmpl}
94
95 %clean 
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc APPS BUG-REPORTING CHANGES DEBUGGING FEEDBACK FIXES
104 %doc README THANKS TODO docs/{QUOTES,README.*,REASONS,progressive.txt}
105 %attr(755,root,root) %{_libdir}/lib*.so.*.*
106
107 %files devel
108 %defattr(644,root,root,755)
109 %doc html/*
110 %attr(755,root,root) %{_libdir}/lib*.so
111 %{_libdir}/lib*.la
112 %{_includedir}/XmHTML
113
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/lib*.a
This page took 0.029924 seconds and 3 git commands to generate.