]> git.pld-linux.org Git - packages/XaoS.git/blob - XaoS.spec
- massive change ( validate errors warrings from desktop-file-validate)
[packages/XaoS.git] / XaoS.spec
1 #
2 # Conditional build:
3 %bcond_without  aalib   # without aalib output support
4 %bcond_without  ggi     # without ggi output support
5 %bcond_without  ncurses # without ncurses output support
6 %bcond_without  svga    # without svga output support
7 #
8 Summary:        A fast, portable real-time interactive fractal zoomer
9 Summary(pl.UTF-8):      Szybki, przenośny i interaktywny eksplorator fraktali
10 Name:           XaoS
11 Version:        3.2.3
12 Release:        1
13 License:        GPL
14 Group:          X11/Applications
15 Source0:        http://dl.sourceforge.net/xaos/%{name}-%{version}.tar.gz
16 # Source0-md5:  f1d9a9f3d2097906754b8824ba925e64
17 Source1:        %{name}.desktop
18 Source2:        %{name}.png
19 Patch0:         %{name}-nosuid.patch
20 Patch1:         %{name}-ggi-fix.patch
21 Patch2:         %{name}-svga-fix.patch
22 Patch3:         %{name}-info.patch
23 URL:            http://xaos.theory.org/
24 %{?with_aalib:BuildRequires:            aalib-devel}
25 BuildRequires:  autoconf >= 2.59-9
26 BuildRequires:  automake
27 BuildRequires:  gettext-devel
28 %{?with_ggi:BuildRequires:              libggi-devel}
29 BuildRequires:  libpng-devel
30 %{?with_ncurses:BuildRequires:  ncurses-devel}
31 %{?with_svga:BuildRequires:     svgalib-devel}
32 BuildRequires:  texinfo
33 BuildRequires:  xorg-lib-libXext-devel
34 BuildRequires:  xorg-lib-libXxf86dga-devel
35 BuildRequires:  xorg-lib-libXxf86vm-devel
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 XaoS is a fast portable real-time interactive fractal zoomer. It
40 supports outputs such as X11, aalib, ncurses and SVGAlib. It displays
41 the Mandelbrot set (among other escape time fractals) and allows you
42 zoom smoothly into the fractal. Various coloring modes are provided
43 for both the points inside and outside the selected set. In addition,
44 switching between Julia and Mandelbrot fractal types is provided. The
45 first version was a poorly written Mandelbrot view by Thomas later
46 modified by Jan to support high frame-rate zooming. Other additions
47 were later made including autopilot (for those of you without drivers
48 licenses), palette changing, PNG saving, and fractal inversion.
49
50 %description -l pl.UTF-8
51 XaoS jest szybkim, przenośnym i interaktywnym eksploratorem fraktali.
52 Efekty jego działania można oglądać z użyciem drajwerów X11, aalib,
53 ncurses oraz SVGAlib. XaoS wyświetla zbiór Mandelbrota (i nie tylko) i
54 pozwala na płynne powiększanie/pomniejszanie widocznego zakresu.
55 Dostępne są różne rodzaje kolorowania dla punktów w wybranym zbiorze,
56 jak i poza nim. Dodatkowo, możliwe jest przełączanie między fraktalem
57 Mandelbrota, a odpowiadającym mu fraktalem Julii (i w drugą stronę).
58 Pierwsza wersja (Tomasa) była kiepsko napisanym wyświetlaczem zbioru
59 Mandelbrota. Została zmodyfikowana przez Jana aby umożliwiać szybkie
60 powiększanie. Inne zmiany, zrobione później to autopilot, zmiana
61 palety, zapisywanie PNG i inwersja fraktali.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66 %patch1 -p1
67 %patch2 -p1
68 %patch3 -p1
69
70 # workaround for gettext 0.15 compatibility
71 touch src/i18n/POTFILES.in
72
73 %build
74 cp -f /usr/share/automake/config.* .
75 %{__aclocal}
76 %{__autoconf}
77 %configure \
78         --with-x \
79         --with-x11-driver=yes \
80         %{!?with_aalib:--with-aa-driver=no} \
81         %{!?with_ggi:--with-ggi-driver=no} \
82         %{!?with_ncurses:--with-curses-driver=no} \
83         %{!?with_svga:--with-svga-driver=no}
84
85 %{__make}
86
87 cd doc
88 makeinfo --no-split xaos.texinfo
89 makeinfo --no-split xaosdev.texinfo
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
99 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
100
101 %find_lang xaos
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post
107 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
108
109 %postun
110 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
111
112 %files -f xaos.lang
113 %defattr(644,root,root,755)
114 %doc RELEASE_NOTES TODO doc/{AUTHORS,PROBLEMS,README{,.bugs,.ggi},SPONSORS,built-in_formulas.txt}
115 %attr(755,root,root) %{_bindir}/xaos
116 %dir %{_datadir}/XaoS
117 %dir %{_datadir}/XaoS/catalogs
118 %lang(cs) %{_datadir}/XaoS/catalogs/cesky.cat
119 %lang(de) %{_datadir}/XaoS/catalogs/deutsch.cat
120 %{_datadir}/XaoS/catalogs/english.cat
121 %lang(es) %{_datadir}/XaoS/catalogs/espanhol.cat
122 %lang(fr) %{_datadir}/XaoS/catalogs/francais.cat
123 %lang(hu) %{_datadir}/XaoS/catalogs/magyar.cat
124 %{_datadir}/XaoS/examples
125 %{_datadir}/XaoS/help
126 %{_datadir}/XaoS/tutorial
127 %{_mandir}/man6/*
128 %{_infodir}/*.info*
129 %{_pixmapsdir}/XaoS.png
130 %{_desktopdir}/XaoS.desktop
This page took 0.053879 seconds and 3 git commands to generate.