]> git.pld-linux.org Git - packages/XaoS.git/blob - XaoS.spec
- updated gettext BR
[packages/XaoS.git] / XaoS.spec
1 # TODO: enable GTK+ UI when it becomes stable
2 #
3 # Conditional build:
4 %bcond_without  aalib   # without aalib output support
5 %bcond_without  ggi     # without ggi output support
6 %bcond_without  ncurses # without ncurses output support
7 %bcond_without  svga    # without svga output support
8 #
9 Summary:        A fast, portable real-time interactive fractal zoomer
10 Summary(pl.UTF-8):      Szybki, przenośny i interaktywny eksplorator fraktali
11 Name:           XaoS
12 Version:        3.4
13 Release:        1
14 License:        GPL v2+
15 Group:          X11/Applications
16 Source0:        http://dl.sourceforge.net/xaos/%{name}-%{version}.tar.gz
17 # Source0-md5:  366fd8151e9642a0d9afce889912e388
18 Source1:        %{name}.desktop
19 Source2:        %{name}.png
20 Patch0:         %{name}-nosuid.patch
21 Patch1:         %{name}-ggi-fix.patch
22 Patch2:         %{name}-svga-fix.patch
23 Patch3:         %{name}-info.patch
24 URL:            http://xaos.theory.org/
25 %{?with_aalib:BuildRequires:            aalib-devel}
26 BuildRequires:  autoconf >= 2.59-9
27 BuildRequires:  automake
28 BuildRequires:  gettext-tools
29 %{?with_ggi:BuildRequires:              libggi-devel}
30 BuildRequires:  libpng-devel
31 %{?with_ncurses:BuildRequires:  ncurses-devel}
32 %{?with_svga:BuildRequires:     svgalib-devel}
33 BuildRequires:  texinfo
34 BuildRequires:  xorg-lib-libXext-devel
35 BuildRequires:  xorg-lib-libXxf86dga-devel
36 BuildRequires:  xorg-lib-libXxf86vm-devel
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 XaoS is a fast portable real-time interactive fractal zoomer. It
41 supports outputs such as X11, aalib, ncurses and SVGAlib. It displays
42 the Mandelbrot set (among other escape time fractals) and allows you
43 zoom smoothly into the fractal. Various coloring modes are provided
44 for both the points inside and outside the selected set. In addition,
45 switching between Julia and Mandelbrot fractal types is provided. The
46 first version was a poorly written Mandelbrot view by Thomas later
47 modified by Jan to support high frame-rate zooming. Other additions
48 were later made including autopilot (for those of you without drivers
49 licenses), palette changing, PNG saving, and fractal inversion.
50
51 %description -l pl.UTF-8
52 XaoS jest szybkim, przenośnym i interaktywnym eksploratorem fraktali.
53 Efekty jego działania można oglądać z użyciem drajwerów X11, aalib,
54 ncurses oraz SVGAlib. XaoS wyświetla zbiór Mandelbrota (i nie tylko) i
55 pozwala na płynne powiększanie/pomniejszanie widocznego zakresu.
56 Dostępne są różne rodzaje kolorowania dla punktów w wybranym zbiorze,
57 jak i poza nim. Dodatkowo, możliwe jest przełączanie między fraktalem
58 Mandelbrota, a odpowiadającym mu fraktalem Julii (i w drugą stronę).
59 Pierwsza wersja (Tomasa) była kiepsko napisanym wyświetlaczem zbioru
60 Mandelbrota. Została zmodyfikowana przez Jana aby umożliwiać szybkie
61 powiększanie. Inne zmiany, zrobione później to autopilot, zmiana
62 palety, zapisywanie PNG i inwersja fraktali.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67 %patch1 -p1
68 %patch2 -p1
69 %patch3 -p1
70
71 # workaround for gettext 0.15 compatibility
72 touch src/i18n/POTFILES.in
73
74 %build
75 cp -f /usr/share/automake/config.* .
76 %{__aclocal}
77 %{__autoconf}
78 %configure \
79         --with-x \
80         --with-x11-driver=yes \
81         %{!?with_aalib:--with-aa-driver=no} \
82         %{!?with_ggi:--with-ggi-driver=no} \
83         %{!?with_ncurses:--with-curses-driver=no} \
84         %{!?with_svga:--with-svga-driver=no}
85
86 %{__make}
87
88 cd doc
89 makeinfo --no-split xaos.texinfo
90 makeinfo --no-split xaosdev.texinfo
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
100 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
101
102 %find_lang xaos
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/postshell
108 -/usr/sbin/fix-info-dir -c %{_infodir}
109
110 %postun -p /sbin/postshell
111 -/usr/sbin/fix-info-dir -c %{_infodir}
112
113 %files -f xaos.lang
114 %defattr(644,root,root,755)
115 %doc RELEASE_NOTES TODO doc/{AUTHORS,PROBLEMS,README{,.bugs,.ggi},SPONSORS,built-in_formulas.txt}
116 %attr(755,root,root) %{_bindir}/xaos
117 %dir %{_datadir}/XaoS
118 %dir %{_datadir}/XaoS/catalogs
119 %lang(cs) %{_datadir}/XaoS/catalogs/cesky.cat
120 %lang(de) %{_datadir}/XaoS/catalogs/deutsch.cat
121 %{_datadir}/XaoS/catalogs/english.cat
122 %lang(es) %{_datadir}/XaoS/catalogs/espanhol.cat
123 %lang(fr) %{_datadir}/XaoS/catalogs/francais.cat
124 %lang(it) %{_datadir}/XaoS/catalogs/italiano.cat
125 %lang(hu) %{_datadir}/XaoS/catalogs/magyar.cat
126 %lang(ro) %{_datadir}/XaoS/catalogs/romanian.cat
127 %{_datadir}/XaoS/examples
128 %{_datadir}/XaoS/help
129 %{_datadir}/XaoS/tutorial
130 %{_mandir}/man6/xaos.6*
131 %{_infodir}/xaos.info*
132 %{_pixmapsdir}/XaoS.png
133 %{_desktopdir}/XaoS.desktop
This page took 0.414796 seconds and 3 git commands to generate.