]> git.pld-linux.org Git - packages/XaoS.git/blob - XaoS.spec
- categories
[packages/XaoS.git] / XaoS.spec
1 #
2 # Conditional build:
3 #
4 %bcond_without  aalib   # without aalib output support
5 %bcond_without  ggi     # without ggi output support
6 %bcond_without  ncurses # without ncurses output support
7 %bcond_without  svga    # without svga output support
8 #
9 Summary:        A fast, portable real-time interactive fractal zoomer
10 Summary(pl):    Szybki, przeno¶ny i interaktywny explorator fraktali
11 Name:           XaoS
12 Version:        3.1
13 %define pre     pre5
14 Release:        0.%{pre}.3
15 License:        GPL
16 Group:          X11/Applications
17 Source0:        http://dl.sourceforge.net/xaos/%{name}-%{version}%{pre}.tar.gz
18 # Source0-md5:  904691517303d2bedddf33b3d68f97cc
19 Source1:        %{name}.desktop
20 Source2:        %{name}.png
21 Patch0:         %{name}-nosuid.patch
22 Patch1:         %{name}-brokenasm.patch
23 Patch2:         %{name}-ggi-fix.patch
24 Patch3:         %{name}-svga-fix.patch
25 Patch4:         %{name}-info.patch
26 URL:            http://xaos.theory.org/
27 BuildRequires:  XFree86-devel
28 %{?with_aalib:BuildRequires:            aalib-devel}
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 %{?with_ggi:BuildRequires:              libggi-devel}
32 BuildRequires:  libpng-devel
33 %{?with_ncurses:BuildRequires:  ncurses-devel}
34 %{?with_svga:BuildRequires:     svgalib-devel}
35 BuildRequires:  texinfo
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 XaoS is a fast portable real-time interactive fractal zoomer. It
40 supports outputs such as X11, aalib, ncurses and SVGAlib. It displays
41 the Mandelbrot set (among other escape time fractals) and allows you
42 zoom smoothly into the fractal. Various coloring modes are provided
43 for both the points inside and outside the selected set. In addition,
44 switching between Julia and Mandelbrot fractal types is provided. The
45 first version was a poorly written Mandelbrot view by Thomas later
46 modified by Jan to support high frame-rate zooming. Other additions
47 were later made including autopilot (for those of you without drivers
48 licenses), palette changing, PNG saving, and fractal inversion.
49
50 %description -l pl
51 XaoS jest szybkim, przeno¶nym i interaktywnym exploratorem fraktali.
52 Efekty jego dzia³ania mo¿na ogl±daæ z u¿yciem drajwerów X11, aalib,
53 ncurses oraz SVGAlib. XaoS wy¶wietla zbiór Mandelbrota (i nie tylko) i
54 pozwala na p³ynne powiêkszanie/pomniejszanie widocznego zakresu.
55 Dostêpne s± ró¿ne rodzaje kolorowania dla punktów w wybranym zbiorze,
56 jak i poza nim. Dodatkowo, mo¿liwe jest prze³±czanie miêdzy fraktalem
57 Mandelbrota, a odpowiadaj±cym mu fraktalem Julii (i w drug± stronê).
58 Pierwsza wersja (Tomasa) by³a kiepsko napisanym wy¶wietlaczem zbioru
59 Mandelbrota. Zosta³a zmodyfikowana przez Jana aby umo¿liwiaæ szybkie
60 powiêkszanie. Inne zmiany, zrobione pó¼niej to autopilot, zmiana
61 palety, zapisywanie PNG i inwersja fraktali.
62
63 %prep
64 %setup -q -n %{name}-%{version}%{pre}
65 %patch0 -p1
66 %patch1 -p1
67 %patch2 -p1
68 %patch3 -p1
69 %patch4 -p1
70
71 %build
72 cp -f /usr/share/automake/config.* .
73 %{__autoconf}
74 LDFLAGS="%{rpmldflags} -L/usr/X11R6/%{_lib}"
75 %configure \
76         --with-x \
77         --with-x11-driver=yes \
78         %{?with_aalib:  --with-aa-driver=no} \
79         %{?with_ggi:    --with-ggi-driver=no} \
80         %{?with_ncurses:--with-curses-driver=no} \
81         %{?with_svga:   --with-svga-driver=no}
82
83 %{__make}
84
85 cd doc
86 makeinfo --no-split xaos.texinfo
87 makeinfo --no-split xaosdev.texinfo
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT{%{_infodir},%{_desktopdir},%{_pixmapsdir}} \
92         $RPM_BUILD_ROOT%{_datadir}/locale/{hu,es,fr,cs,de}/LC_MESSAGES
93
94 %{__make} install \
95         datadir=$RPM_BUILD_ROOT%{_datadir} \
96         bindir=$RPM_BUILD_ROOT%{_bindir} \
97         mandir=$RPM_BUILD_ROOT%{_mandir} \
98         infodir=$RPM_BUILD_ROOT%{_infodir} \
99         LOCALEDIR=$RPM_BUILD_ROOT%{_datadir}/locale
100
101 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
102 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
103
104 %find_lang xaos
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post
110 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
111
112 %postun
113 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
114
115 %files -f xaos.lang
116 %defattr(644,root,root,755)
117 %doc TODO doc/{ANNOUNCE,AUTHORS,PROBLEMS,README{,.bugs,.ggi},SPONSORS}
118 %attr(755,root,root) %{_bindir}/xaos
119 %dir %{_datadir}/XaoS
120 %dir %{_datadir}/XaoS/catalogs
121 %lang(cs) %{_datadir}/XaoS/catalogs/cesky.cat
122 %lang(de) %{_datadir}/XaoS/catalogs/deutsch.cat
123 %{_datadir}/XaoS/catalogs/english.cat
124 %lang(es) %{_datadir}/XaoS/catalogs/espanhol.cat
125 %lang(fr) %{_datadir}/XaoS/catalogs/francais.cat
126 %lang(hu) %{_datadir}/XaoS/catalogs/magyar.cat
127 %{_datadir}/XaoS/examples
128 %{_datadir}/XaoS/help
129 %{_datadir}/XaoS/tutorial
130 %{_mandir}/man6/*
131 %{_infodir}/*.info*
132 %{_pixmapsdir}/XaoS.png
133 %{_desktopdir}/XaoS.desktop
This page took 0.078255 seconds and 3 git commands to generate.