]> git.pld-linux.org Git - packages/XFree86-glx.git/blob - XFree86-glx.spec
- typos, pl description, some cleanups
[packages/XFree86-glx.git] / XFree86-glx.spec
1 %define mesaversion     3.2.1
2 %define glx_ver latest
3
4 Summary:        OpenGL 1.2 compatible 3D graphics library
5 Summary(pl):    Biblioteka grafiki 3D kompatybilna z OpenGL 1.2
6 Name:           XFree86-glx
7 Version:        4.2.0
8 Release:        0.2
9 License:        LGPL
10 Vendor:         Brian Paul <brian_paul@mesa3d.org>
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.mesa3d.org/pub/sourceforge/mesa3d/MesaLib-%{mesaversion}.tar.bz2
13 Source1:        ftp://ftp.mesa3d.org/pub/sourceforge/mesa3d/MesaDemos-%{mesaversion}.tar.bz2
14 Source2:        http://snow.ashlu.bc.ca/glx/snapshots/utah-glx-src-%{glx_ver}.tar.gz
15 URL:            http://www.mesa3d.org/
16 BuildRequires:  binutils >= 2.9.1.0.19a
17 BuildRequires:  tcl
18 Conflicts:      XFree86 =< 4.1.0
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20 Provides:       OpenGL
21 Obsoletes:      Mesa
22 Obsoletes:      XFree86-OpenGL-core
23 Obsoletes:      XFree86-OpenGL-libs
24
25 %define         _prefix         /usr/X11R6
26 %define         _sysconfdir     /etc/X11
27
28 %description
29 This is an implementation of the Mesa 3D library and GLX with support
30 for hardware acceleration. GLX was developed by SGI as an extension to
31 the X window system to integrate OpenGL rendering functions. This
32 allows the Mesa 3D library to perform its 3D rendering functions
33 within the X server's process, rather than within the X client
34 program. This offers potential performance benefits, because the
35 rendered image does not have to be moved from the X client program to
36 the X server. (Only the commands required to render the image are
37 sent.) It also makes 3-D hardware acceleration much more practical
38 (and fast). This package includes a accelerated hardware drivers for
39 video card based on NVIDIA Riva series and ATI Rage Pro chipsets.
40
41 The Mesa 3D graphics library is a powerful and generic toolset for
42 creating hardware assisted computer graphics. To the extent that Mesa
43 utilizes the OpenGL command syntax or state machine, it is being used
44 with authorization from Silicon Graphics, Inc. However, the author
45 (Brian Paul) makes no claim that Mesa is in any way a compatible
46 replacement for OpenGL or associated with Silicon Graphics, Inc. Those
47 who want a licensed implementation of OpenGL should contact a licensed
48 vendor. However, Mesa is very similar to OpenGL, and you might find
49 Mesa to be a valid alternative to OpenGL.
50
51 This package is based on Mesa %{mesaver} and utah-glx-%{glxver}.
52
53 please see http://utah-glx.sourceforge.net/ for more information.
54
55 %description -l pl
56 To jest implementacja biblioteki Mesa 3D oraz GLX z obs³ug± sprzêtowej
57 akceleracji. GLX zosta³ stworzony przez SGI jako rozszerzenie systemu
58 X Window w celu integracji funkcji renderuj±cych OpenGL. Pozwala to
59 bibliotece Mesa 3D na wykonywanie funkcji renderujacych 3D wewn±trz
60 procesu X serwera zamiast po stronie X klienta. Daje to potencjalne
61 zyski wydajno¶ci, poniewa¿ wyrenderowany obraz nie musi byæ przesy³any
62 z programu X klienta do X serwera (przesy³ane s± tylko polecenia
63 potrzebne do renderowania). Daje to tak¿e mo¿liwo¶æ u¿ycia sprzêtowej
64 akceleracji 3D. Ten pakiet zawiera sterowniki wykorzystuj±ce
65 akceleracjê dla kart graficznych opartych na uk³adach z serii NVIDIA
66 Riva i ATI Rage Pro.
67
68 Biblioteka graficzna Mesa 3D jest potê¿nym i ogólnym zestawem narzêdzi
69 do tworzenia grafiki komputerowej przy wsparciu sprzêtu. Mesa u¿ywa
70 sk³adni poleceñ i maszyny stanów OpenGL za zgod± Silicon Graphics,
71 Inc. Nie jest to jednak licencjonowana implementacja OpenGL.
72
73 Ten pakiet bazuje na Mesie %{mesaver} oraz utah-glx-%{glxver}.
74
75 Wiêcej informacji na stronie http://utah-glx.sourceforge.net/.
76
77 %package        devel
78 Summary:        Development files for Mesa (OpenGL compatible 3D lib)
79 Summary(pl):    Pliki nag³ówkowe dla Mesy (biblioteki 3D zgodnej z OpenGL)
80 Group:          X11/Development/Libraries
81 Requires:       %{name} = %{version}
82 Provides:       OpenGL-devel
83 Obsoletes:      Mesa-devel
84 Obsoletes:      XFree86-OpenGL-devel
85
86 %description devel
87 Mesa is an OpenGL 1.2 compatible 3D graphics library. This package
88 contains the header files needed to compile Mesa programs.
89
90 %description devel -l pl
91 Mesa jest bibliotek± 3D zgodn± z OpenGL 1.2. Ten pakiet zawiera pliki
92 nag³ówkowe potrzebne do kompilowania programów u¿ywaj±cych Mesy.
93
94 %prep
95 %setup -q -n Mesa-%{mesaversion} -b1 -a2
96 [ -d glx-xf4 ] && ln -s glx-xf4 glx;
97
98 perl -p -i -e "s/-O3/%{rpmcflags}/" Make-config
99
100 %build
101 RPM_OPT_FLAGS="%{rpmcflags}"; export RPM_OPT_FLAGS
102 %ifarch i386 i486
103 CFLAGS="%{rpmcflags}" CXXFLAGS="%{rpmcflags}" \
104 ./configure     --prefix=%{_prefix} \
105                 --sysconfdir=%{_sysconfdir} \
106                 --disable-mmx \
107                 --disable-3dnow \
108                 --without-ggi \
109                 --enable-mga=no \
110                 --enable-mach64=no \
111                 --enable-tnt=yes \
112                 --enable-i810=no \
113                 --enable-s3virge=no \
114                 --enable-s3savage=no \
115                 --enable-sis6326=no
116
117 %endif
118 %ifarch i586 i686 k6 athlon
119 CFLAGS="%{rpmcflags}" CXXFLAGS="%{rpmcflags}" \
120 ./configure     --prefix=%{_prefix} \
121                 --sysconfdir=%{_sysconfdir} \
122                 --with-glide=/usr \
123                 --without-ggi \
124                 --enable-mga=no \
125                 --enable-mach64=no \
126                 --enable-tnt=yes \
127                 --enable-i810=no \
128                 --enable-s3virge=no \
129                 --enable-s3savage=no \
130                 --enable-sis6326=no
131 %endif
132 %ifnarch %{ix86}
133 ./configure     --prefix=%{_prefix} \
134                 --sysconfdir=%{_sysconfdir} \
135                 --disable-3dnow \
136                 --without-ggi \
137                 --enable-mga=no \
138                 --enable-mach64=no \
139                 --enable-tnt=yes \
140                 --enable-i810=no \
141                 --enable-s3virge=no \
142                 --enable-s3savage=no \
143                 --enable-sis6326=no
144 %endif
145
146 %{__make}
147
148 %ifarch alpha sparc sparc64 ppc # Skip utah_glx for alpha - (fg) also skip it for
149                                 # sparc - (jb) also added skip for ppc
150         echo 'utah_glx skipped for alpha, powerpc and sparcs'
151 %else
152 cd glx
153 cp -fv ../config.sub ./
154
155 CFLAGS="%{rpmcflags}" \
156         ./autogen.sh    --with-chipset=both \
157                         --with-mesa=../ \
158                         --enable-extra \
159                         --disable-mtrr \
160                         --disable-agp \
161                         --disable-glut \
162                         --disable-GLU \
163                         --prefix=%{_prefix} \
164                         --sysconfdir=%{_sysconfdir} \
165                         --without-x86-asm \
166                         --without-mmx-asm \
167                         --without-3dnow-asm \
168                         --enable-mga=no \
169                         --enable-mach64=no \
170                         --enable-tnt=yes \
171                         --enable-i810=no \
172                         --enable-s3virge=no \
173                         --enable-s3savage=no \
174                         --enable-sis6326=no
175
176 # Arg docs sux ((Dadou) "are not OK", it's better ;)
177 cd docs
178 cat <<EOF > config.cache
179 ac_cv_path_install=${ac_cv_path_install='/usr/bin/install -c'}
180 ac_cv_prog_CP=${ac_cv_prog_CP='cp -f'}
181 ac_cv_prog_LN_S=${ac_cv_prog_LN_S='ln -s'}
182 ac_cv_prog_MKDIR=${ac_cv_prog_MKDIR='mkdir -p'}
183 ac_cv_prog_MV=${ac_cv_prog_MV='mv -f'}
184 ac_cv_prog_RM=${ac_cv_prog_RM='rm -f'}
185 ac_cv_prog_have_dvips=${ac_cv_prog_have_dvips=no}
186 ac_cv_prog_have_jade=${ac_cv_prog_have_jade=no}
187 ac_cv_prog_have_jadetex=${ac_cv_prog_have_jadetex=no}
188 ac_cv_prog_have_lynx=${ac_cv_prog_have_lynx=no}
189 ac_cv_prog_have_ps2pdf=${ac_cv_prog_have_ps2pdf=no}
190 ac_cv_prog_make_make_set=${ac_cv_prog_make_make_set=yes}
191 EOF
192
193 ./configure     --enable-text \
194                 --enable-html \
195                 --enable-ps \
196                 --enable-pdf
197 cd ..
198
199 %{__make}
200 cd ..
201 %endif # Skip glx for Alpha
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205 install -d $RPM_BUILD_ROOT{%{_includedir}/GL,%{_sysconfdir},/usr/bin}
206 install -d $RPM_BUILD_ROOT%{_libdir}/modules
207
208 %{__make} DESTDIR=$RPM_BUILD_ROOT install
209 install include/GL/svgamesa.h $RPM_BUILD_ROOT%{_includedir}/GL
210 install glx/servGL/libglx.so $RPM_BUILD_ROOT%{_libdir}/modules
211
212 %ifarch alpha sparc sparc64 ppc
213 echo 'Skipping utah_glx'
214 %else
215 cat > $RPM_BUILD_ROOT/usr/bin/glx <<EOF
216 #!/bin/sh
217 LD_PRELOAD=%{_prefix}/lib/libGL.so.1.0 "\$@"
218 EOF
219
220 ## glx
221 cd glx
222 %{__make} DESTDIR=$RPM_BUILD_ROOT sysconfdir=%{_sysconfdir} install
223 cd ..
224 %endif # glx
225
226 cd $RPM_BUILD_ROOT/%{_prefix}/lib/
227 ln -sf libGL.so.1 libGL.so
228 ln -sf libGLU.so.1 libGLU.so
229 ln -sf libGLU.so.1 libGLU.so.3
230 ln -sf libglut.so.3 libglut.so
231
232 # (gc) add Mesa symlinks for compatibility
233 ln -sf libGL.so libMesaGL.so
234 ln -sf libGL.so.1 libMesaGL.so.1
235 ln -sf libGL.so.1.0 libMesaGL.so.1.0
236 ln -sf libGLU.so libMesaGLU.so
237 ln -sf libGLU.so.1 libMesaGLU.so.1
238
239 %clean
240 rm -rf $RPM_BUILD_ROOT
241
242 %post   -p /sbin/ldconfig
243 %postun -p /sbin/ldconfig
244
245 %files
246 %defattr(644,root,root,755)
247 %doc docs/{COPYRIGHT,README*,COPYING,DEVINFO,CONFORM,VERSIONS} glx/docs/README.*
248 %attr(755,root,root) /usr/bin/glx
249 %{_libdir}/*.so.*
250 %config %{_sysconfdir}/mesa.conf
251 %ifarch %{ix86}
252 %{_prefix}/lib/modules/extensions/*.so
253 %config %{_sysconfdir}/glx.conf
254 %endif
255
256 %files devel
257 %defattr(644,root,root,755)
258 %dir %{_includedir}/GL
259 %{_includedir}/GL/gl*.h
260 %{_includedir}/GL/o*.h
261 %{_includedir}/GL/x*.h
262 %ifarch %{ix86}
263 %{_includedir}/GL/svgamesa.h
264 %endif
265 %{_prefix}/lib/lib*.so
266 %{_prefix}/lib/lib*.la
This page took 0.08919 seconds and 3 git commands to generate.