]> git.pld-linux.org Git - packages/Wnn6-SDK.git/commitdiff
- updated to the current state of Xorg auto/th/Wnn6-SDK-1_0-11
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 14 Jul 2011 10:21:46 +0000 (10:21 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    Wnn6-SDK-config.patch -> 1.2
    Wnn6-SDK-malloc.patch -> 1.2
    Wnn6-SDK.spec -> 1.10

Wnn6-SDK-config.patch
Wnn6-SDK-malloc.patch
Wnn6-SDK.spec

index eda8ce4bee143f1b269417ec447c1006d3878f58..d7eaf472cdd80da8df9893e24372dd5416d6019b 100644 (file)
@@ -13,6 +13,39 @@ diff -ruN src.org/contrib/im/Xsi/Wnn/include/config.h src/contrib/im/Xsi/Wnn/inc
 diff -ruN src.org/contrib/im/Xsi/config/X11.tmpl src/contrib/im/Xsi/config/X11.tmpl
 --- src.org/contrib/im/Xsi/config/X11.tmpl     Wed Oct 28 13:36:37 1998
 +++ src/contrib/im/Xsi/config/X11.tmpl Wed Jan 27 11:36:14 1999
+@@ -7,9 +7,9 @@
+ #include "/usr/openwin/lib/config/Project.tmpl"
+ #else /* Sun & SVR4 */
+ #if defined(LinuxArchitecture) || defined(FreeBSDArchitecture) || defined(NetBSDArchitecture) || defined(OpenBSDArchitecture) || defined(BSD386Architecture)
+-#include "/usr/X11R6/lib/X11/config/X11.tmpl"
++#include "/usr/lib64/X11/config/X11.tmpl"
+ #else /* Linux || *BSD */
+-#include "/usr/lib/X11/config/Project.tmpl"
++#include "/usr/lib64/X11/config/Project.tmpl"
+ #endif        /* Linux || *BSD */
+ #endif        /* Sun & SVR4 */
+@@ -60,9 +60,9 @@
+ #define BinDir Concat(ProjectRoot,/bin)
+ #else
+ #if ((defined LINUX) || (defined FREEBSD) || (defined BSDOS) || (defined NETBSD))
+-#define BinDir /usr/X11R6/bin
++#define BinDir /usr/bin
+ #else
+-#define BinDir /usr/bin/X11
++#define BinDir /usr/bin
+ #endif /* LINUX || FREEBSD || BSDOS || NETBSD */
+ #endif /* ProjectRoot */
+ #endif /* BinDir */
+@@ -73,7 +73,7 @@
+ #define BuildIncTop ..                /* relative to $(TOP)/X11 */
+ #endif
+ #ifndef LibDir
+-#define LibDir $(USRLIBDIR)/X11
++#define LibDir $(USRLIBDIR)
+ #endif
+ #ifndef ConfigDir
+ #define ConfigDir $(LIBDIR)/config
 @@ -502,32 +502,36 @@
  #define WnnOwner      wnn
  #endif
@@ -37,13 +70,11 @@ diff -ruN src.org/contrib/im/Xsi/config/X11.tmpl src/contrib/im/Xsi/config/X11.t
  #endif
  
  #ifndef WnnIncDir
--#define WnnIncDir     $(INCROOT)
-+#define WnnIncDir     /usr/include
+ #define WnnIncDir     $(INCROOT)
  #endif
  
  #ifndef WnnLibDir
--#define WnnLibDir     $(USRLIBDIR)
-+#define WnnLibDir     /usr/lib
+ #define WnnLibDir     $(USRLIBDIR)
  #endif
  
         WNNOWNER = WnnOwner
@@ -73,3 +104,29 @@ diff -ruN src.org/contrib/im/Xsi/config/X11.tmpl src/contrib/im/Xsi/config/X11.t
       WNNCONVLIB = $(WNNCONVSRC)/libconvkey.a
  
          CWNNTOP = $(IMTOP)/cWnn
+diff -ur src/contrib/im/Xsi/Makefile.ini src.new/contrib/im/Xsi/Makefile.ini
+--- src/contrib/im/Xsi/Makefile.ini    2011-07-14 11:38:14.915761854 +0200
++++ src.new/contrib/im/Xsi/Makefile.ini        2011-07-14 11:31:20.392761947 +0200
+@@ -15,7 +15,7 @@
+       CURRENT_DIR = ./../contrib/im/Xsi
+ #       CONFIGSRC = /usr/lib/X11/config
+ #       CONFIGSRC = /usr/openwin/lib/X11/config
+-        CONFIGSRC = /usr/X11R6/lib/X11/config
++        CONFIGSRC = /usr/lib64/X11/config
+          IMAKESRC = $(CONFIGSRC)
+          IRULESRC = $(CONFIGSRC)
+           WSFLAGS = 
+--- src/contrib/im/Xsi/config/Project.tmpl~    2000-09-01 11:58:55.000000000 +0200
++++ src/contrib/im/Xsi/config/Project.tmpl     2011-07-14 12:14:57.879151945 +0200
+@@ -7,9 +7,9 @@
+ #include "/usr/openwin/lib/config/Project.tmpl"
+ #else /* Sun & SVR4 */
+ #if defined(LinuxArchitecture) || defined(FreeBSDArchitecture) || defined(NetBSDArchitecture) || defined(OpenBSDArchitecture) || defined(BSD386Architecture)
+-#include "/usr/X11R6/lib/X11/config/Project.tmpl"
++#include "/usr/lib64/X11/config/Project.tmpl"
+ #else /* Linux || *BSD */
+-#include "/usr/lib/X11/config/Project.tmpl"
++#include "/usr/lib64/X11/config/Project.tmpl"
+ #endif        /* Linux || *BSD */
+ #endif        /* Sun & SVR4 */
index 85524b238353209932993770a52739ded8aa2bf7..6835d5c372c4973314d316887b0e68e4e3c5a568 100644 (file)
@@ -1,15 +1,6 @@
 diff -uNr Xsi.orig/Wnn/etc/bdic.c Xsi/Wnn/etc/bdic.c
 --- Xsi.orig/Wnn/etc/bdic.c    Wed Oct 28 13:36:16 1998
 +++ Xsi/Wnn/etc/bdic.c Tue Nov 10 05:17:21 1998
-@@ -179,6 +179,8 @@
- #define max(a, b) ((a < b)? b:a)
- #endif
-+extern  char    *malloc0();
-+
- /*:::DOC_START
-  *
-  *    Function Name: dic_get_compressed_filename
 @@ -1849,7 +1851,7 @@
      hjt.hindo_area = (int)((serial + MAX_HINDO_DATA_AREA - 1) / MAX_HINDO_DATA_AREA);
      if(hjt.hindo_area != 0) {
@@ -841,7 +832,7 @@ diff -uNr Xsi.orig/Wnn/jlib/js.c Xsi/Wnn/jlib/js.c
 diff -uNr Xsi.orig/Wnn/jlib/malloc.c Xsi/Wnn/jlib/malloc.c
 --- Xsi.orig/Wnn/jlib/malloc.c Thu Jan  1 09:00:00 1970
 +++ Xsi/Wnn/jlib/malloc.c      Tue Nov 10 04:58:00 1998
-@@ -0,0 +1,94 @@
+@@ -0,0 +1,86 @@
 +/*
 + * $Id$
 + */
@@ -894,14 +885,6 @@ diff -uNr Xsi.orig/Wnn/jlib/malloc.c Xsi/Wnn/jlib/malloc.c
 + */
 +#include <stdio.h>
 +/* #include "wnn_malloc.h" */
-+#undef        malloc
-+#undef        realloc
-+#undef        free
-+
-+extern char *malloc();
-+extern void free();
-+extern char *realloc();
-+extern char *calloc();
 +
 +char *
 +malloc0(size)
index 99a7564b62dd5c77b4ddc5c38d1e7535f1cd3291..1c508933cbe7995751ee360c520a1f4f8edc05a0 100644 (file)
@@ -57,10 +57,15 @@ Statyczna biblioteka kliencka Wnn6.
 %patch5 -p0
 %patch6 -p0
 
+%{__sed} -i -e 's|/usr/lib64/X11|%{_libdir}/X11|g' \
+       config/X11.tmpl Makefile.ini
+
 %build
 %{__make} World -f Makefile.ini \
+       WNNLIBDIR=%{_libdir} \
        CC="%{__cc}" \
-       CDEBUGFLAGS="%{rpmcflags}"
+       CDEBUGFLAGS="%{rpmcflags} -fPIC" \
+       REQUIREDLIBS="-lcrypt" \
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -78,6 +83,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README
 %attr(755,root,root) %{_libdir}/libwnn6.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libwnn6.so.1
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.206573 seconds and 4 git commands to generate.