]> git.pld-linux.org Git - packages/WebGUI.git/blob - WebGUI.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/WebGUI.git] / WebGUI.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Open source content management system (CMS)
3 Summary(pl.UTF-8):      Wolnodostępny system zarządzania treścią (CMS)
4 Name:           WebGUI
5 Version:        7.3.20
6 Release:        0.1
7 License:        GPL
8 Group:          Development/Languages/Perl
9 Source0:        http://dl.sourceforge.net/pbwebgui/webgui-%{version}-stable.tar.gz
10 # Source0-md5:  daa844679d2a2d9dc55a93afc15022fb
11 URL:            http://www.webgui.org/
12 BuildRequires:  rpm-perlprov >= 3.0.3-16
13 # BRs for autodeps:
14 BuildRequires:  perl-Archive-Tar >= 1.05
15 BuildRequires:  perl-DBI >= 1.40
16 BuildRequires:  perl-Date-Calc
17 BuildRequires:  perl-Digest-MD5 >= 2.20
18 BuildRequires:  perl-HTML-Parser >= 3.36
19 BuildRequires:  perl-libwww
20 Requires:       perl-Compress-Zlib
21 Requires:       perl-DBD-mysql >= 3.0002
22 Requires:       perl-base >= 5.6
23 # these versions are originally included in package - require these or newer
24 Requires:       perl-Convert-ASN1 >= 0.15
25 Requires:       perl-HTML-TagFilter >= 0.07
26 Requires:       perl-HTML-Template >= 2.6
27 Requires:       perl-HTTP-BrowserDetect >= 0.97
28 Requires:       perl-JSON >= 0.991
29 Requires:       perl-POE-Component-Client-HTTP >= 0.77
30 Requires:       perl-POE-Component-IKC >= 0.18
31 Requires:       perl-Parse-PlainConfig >= 1.1
32 # for tests only
33 Requires:       perl-Pod-Coverage >= 0.17
34 Requires:       perl-Tie-CPHash >= 1.001
35 Requires:       perl-Tie-IxHash >= 1.21
36 Requires:       perl-Tree-DAG_Node >= 1.04
37 Requires:       perl-XML-RSSLite >= 0.11
38 Requires:       perl-ldap >= 0.25
39 BuildArch:      noarch
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 # optional
43 %define         _noautoreq      'perl(Authen::Smb)' 'perl(WebGUI::AssetBranch' 'perl(WebGUI::AssetClipboard)' 'perl(WebGUI::AssetExportHtml)' 'perl(WebGUI::AssetLineage)' 'perl(WebGUI::AssetMetaData)' 'perl(WebGUI::AssetPackage)' 'perl(WebGUI::AssetTrash)' 'perl(WebGUI::AssetVersioning)' 'perl(WebGUI)' 'perl(templates)'
44
45 %description
46 WebGUI is a content management platform built to allow average
47 business users to build and maintain complex web sites. It is modular,
48 pluggable, and platform independent. It was designed to allow the
49 people who create the content, to manage it online, rather than
50 content management taking up the time of the busy IT Staff.
51
52 %description -l pl.UTF-8
53 WebGUI to platforma zarządzania treścią stworzona, aby umożliwić
54 średniej wielkości firmom tworzenie i utrzymywanie skomplikowanych
55 serwisów WWW. WebGUI jest systemem modularnym, obsługującym wtyczki i
56 niezależnym od platformy. Został zaprojektowany tak, aby pozwolić
57 ludziom tworzącym serwisy zarządzać nimi z poziomu przeglądarki,
58 zamiast zajmować czas i tak już zajętym informatykom.
59
60 %prep
61 %setup -q -n %{name}
62
63 %{__perl} -pi -e 's|/data/WebGUI|%{_datadir}/WebGUI|' sbin/preload.perl etc/WebGUI.conf*
64 ##%{__perl} -pi -e 's|configFile\s+=\s+\"WebGUI.conf\"|configFile = \"%{_sysconfdir}/WebGUI/WebGUI.conf\"|' www/index.pl
65 %{__perl} -pi -e "s|(\\\$session\{config\}\{webguiRoot\}\s*\.\s*'%{_sysconfdir}/'\s*\.)||g;" \
66         lib/WebGUI/Session.pm
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT{%{_datadir}/%{name}/sql,%{_datadir}/%{name}/lib,%{_sysconfdir}/%{name},%{perl_vendorlib}}
71
72 cp -rf docs/upgrades $RPM_BUILD_ROOT%{_datadir}/%{name}/sql
73 install docs/create.sql $RPM_BUILD_ROOT%{_datadir}/%{name}/sql
74 #gzip -9nf $RPM_BUILD_ROOT%{_datadir}/%{name}/sql{,/upgrades}/*.sql
75
76 install etc/WebGUI.conf.original $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/WebGUI.conf
77 install etc/spectre.conf.original $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/spectre.conf
78 cp -Prf sbin www $RPM_BUILD_ROOT%{_datadir}/%{name}
79 cp -Prf lib/{Spectre,WebGUI} $RPM_BUILD_ROOT%{perl_vendorlib}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc docs/{changelog,credits.txt,gotcha.txt,install.txt,legal.txt}
87 %dir %{_sysconfdir}/%{name}
88 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/WebGUI.conf
89 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/spectre.conf
90 %{_datadir}/%{name}
91 %dir %{perl_vendorlib}/WebGUI
92 %{perl_vendorlib}/WebGUI/*.pm
93 %dir %{perl_vendorlib}/WebGUI/AdSpace
94 %{perl_vendorlib}/WebGUI/AdSpace/*.pm
95 %dir %{perl_vendorlib}/WebGUI/Asset
96 %{perl_vendorlib}/WebGUI/Asset/*.pm
97 %dir %{perl_vendorlib}/WebGUI/Asset/File
98 %{perl_vendorlib}/WebGUI/Asset/File/*.pm
99 %dir %{perl_vendorlib}/WebGUI/Asset/Post
100 %{perl_vendorlib}/WebGUI/Asset/Post/*.pm
101 %dir %{perl_vendorlib}/WebGUI/Asset/Template
102 %{perl_vendorlib}/WebGUI/Asset/Template/*.pm
103 %dir %{perl_vendorlib}/WebGUI/Asset/Wobject
104 %{perl_vendorlib}/WebGUI/Asset/Wobject/*.pm
105 %dir %{perl_vendorlib}/WebGUI/Asset/Wobject/HttpProxy
106 %{perl_vendorlib}/WebGUI/Asset/Wobject/HttpProxy/*.pm
107 %dir %{perl_vendorlib}/WebGUI/Auth
108 %{perl_vendorlib}/WebGUI/Auth/*.pm
109 %dir %{perl_vendorlib}/WebGUI/Cache
110 %{perl_vendorlib}/WebGUI/Cache/*.pm
111 %dir %{perl_vendorlib}/WebGUI/Commerce
112 %{perl_vendorlib}/WebGUI/Commerce/*.pm
113 %dir %{perl_vendorlib}/WebGUI/Commerce/Item
114 %{perl_vendorlib}/WebGUI/Commerce/Item/*.pm
115 %dir %{perl_vendorlib}/WebGUI/Commerce/Payment
116 %{perl_vendorlib}/WebGUI/Commerce/Payment/*.pm
117 %dir %{perl_vendorlib}/WebGUI/Commerce/Shipping
118 %{perl_vendorlib}/WebGUI/Commerce/Shipping/*.pm
119 %dir %{perl_vendorlib}/WebGUI/Form
120 %{perl_vendorlib}/WebGUI/Form/*.pm
121 %dir %{perl_vendorlib}/WebGUI/Help
122 %{perl_vendorlib}/WebGUI/Help/*.pm
123 %dir %{perl_vendorlib}/WebGUI/i18n
124 %{perl_vendorlib}/WebGUI/i18n/*.pm
125 %dir %{perl_vendorlib}/WebGUI/i18n/English
126 %{perl_vendorlib}/WebGUI/i18n/English/*.pm
127 %dir %{perl_vendorlib}/WebGUI/Image
128 %{perl_vendorlib}/WebGUI/Image/*.pm
129 %dir %{perl_vendorlib}/WebGUI/Image/Graph
130 %{perl_vendorlib}/WebGUI/Image/Graph/*.pm
131 %dir %{perl_vendorlib}/WebGUI/Image/Graph/XYGraph
132 %{perl_vendorlib}/WebGUI/Image/Graph/XYGraph/*.pm
133 %dir %{perl_vendorlib}/WebGUI/Inbox
134 %{perl_vendorlib}/WebGUI/Inbox/*.pm
135 %dir %{perl_vendorlib}/WebGUI/Macro
136 %{perl_vendorlib}/WebGUI/Macro/*.pm
137 %dir %{perl_vendorlib}/WebGUI/Mail
138 %{perl_vendorlib}/WebGUI/Mail/*.pm
139 %dir %{perl_vendorlib}/WebGUI/Operation
140 %{perl_vendorlib}/WebGUI/Operation/*.pm
141 %dir %{perl_vendorlib}/WebGUI/Search
142 %{perl_vendorlib}/WebGUI/Search/*.pm
143 %dir %{perl_vendorlib}/WebGUI/Session
144 %{perl_vendorlib}/WebGUI/Session/*.pm
145 %dir %{perl_vendorlib}/WebGUI/SQL
146 %{perl_vendorlib}/WebGUI/SQL/*.pm
147 %dir %{perl_vendorlib}/Spectre
148 %{perl_vendorlib}/Spectre/*.pm
149 %dir %{perl_vendorlib}/WebGUI/Storage
150 %{perl_vendorlib}/WebGUI/Storage/*.pm
151 %dir %{perl_vendorlib}/WebGUI/Workflow
152 %{perl_vendorlib}/WebGUI/Workflow/*.pm
153 %dir %{perl_vendorlib}/WebGUI/Workflow/Activity
154 %{perl_vendorlib}/WebGUI/Workflow/Activity/*.pm
This page took 0.068091 seconds and 3 git commands to generate.