]> git.pld-linux.org Git - packages/WebGUI.git/blob - WebGUI.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/WebGUI.git] / WebGUI.spec
1 Summary:        Open source content management system (CMS)
2 Summary(pl.UTF-8):      Wolnodostępny system zarządzania treścią (CMS)
3 Name:           WebGUI
4 Version:        7.3.20
5 Release:        0.1
6 License:        GPL
7 Group:          Development/Languages/Perl
8 Source0:        http://dl.sourceforge.net/pbwebgui/webgui-%{version}-stable.tar.gz
9 # Source0-md5:  daa844679d2a2d9dc55a93afc15022fb
10 URL:            http://www.webgui.org/
11 BuildRequires:  rpm-perlprov >= 3.0.3-16
12 # BRs for autodeps:
13 BuildRequires:  perl-Archive-Tar >= 1.05
14 BuildRequires:  perl-DBI >= 1.40
15 BuildRequires:  perl-Date-Calc
16 BuildRequires:  perl-Digest-MD5 >= 2.20
17 BuildRequires:  perl-HTML-Parser >= 3.36
18 BuildRequires:  perl-libwww
19 Requires:       perl-Compress-Zlib
20 Requires:       perl-DBD-mysql >= 3.0002
21 Requires:       perl-base >= 5.6
22 # these versions are originally included in package - require these or newer
23 Requires:       perl-Convert-ASN1 >= 0.15
24 Requires:       perl-HTML-TagFilter >= 0.07
25 Requires:       perl-HTML-Template >= 2.6
26 Requires:       perl-HTTP-BrowserDetect >= 0.97
27 Requires:       perl-JSON >= 0.991
28 Requires:       perl-POE-Component-Client-HTTP >= 0.77
29 Requires:       perl-POE-Component-IKC >= 0.18
30 Requires:       perl-Parse-PlainConfig >= 1.1
31 # for tests only
32 Requires:       perl-Pod-Coverage >= 0.17
33 Requires:       perl-Tie-CPHash >= 1.001
34 Requires:       perl-Tie-IxHash >= 1.21
35 Requires:       perl-Tree-DAG_Node >= 1.04
36 Requires:       perl-XML-RSSLite >= 0.11
37 Requires:       perl-ldap >= 0.25
38 BuildArch:      noarch
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 # optional
42 %define         _noautoreq      'perl(Authen::Smb)' 'perl(WebGUI::AssetBranch' 'perl(WebGUI::AssetClipboard)' 'perl(WebGUI::AssetExportHtml)' 'perl(WebGUI::AssetLineage)' 'perl(WebGUI::AssetMetaData)' 'perl(WebGUI::AssetPackage)' 'perl(WebGUI::AssetTrash)' 'perl(WebGUI::AssetVersioning)' 'perl(WebGUI)' 'perl(templates)'
43
44 %description
45 WebGUI is a content management platform built to allow average
46 business users to build and maintain complex web sites. It is modular,
47 pluggable, and platform independent. It was designed to allow the
48 people who create the content, to manage it online, rather than
49 content management taking up the time of the busy IT Staff.
50
51 %description -l pl.UTF-8
52 WebGUI to platforma zarządzania treścią stworzona, aby umożliwić
53 średniej wielkości firmom tworzenie i utrzymywanie skomplikowanych
54 serwisów WWW. WebGUI jest systemem modularnym, obsługującym wtyczki i
55 niezależnym od platformy. Został zaprojektowany tak, aby pozwolić
56 ludziom tworzącym serwisy zarządzać nimi z poziomu przeglądarki,
57 zamiast zajmować czas i tak już zajętym informatykom.
58
59 %prep
60 %setup -q -n %{name}
61
62 %{__perl} -pi -e 's|/data/WebGUI|%{_datadir}/WebGUI|' sbin/preload.perl etc/WebGUI.conf*
63 ##%{__perl} -pi -e 's|configFile\s+=\s+\"WebGUI.conf\"|configFile = \"%{_sysconfdir}/WebGUI/WebGUI.conf\"|' www/index.pl
64 %{__perl} -pi -e "s|(\\\$session\{config\}\{webguiRoot\}\s*\.\s*'%{_sysconfdir}/'\s*\.)||g;" \
65         lib/WebGUI/Session.pm
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{%{_datadir}/%{name}/sql,%{_datadir}/%{name}/lib,%{_sysconfdir}/%{name},%{perl_vendorlib}}
70
71 cp -rf docs/upgrades $RPM_BUILD_ROOT%{_datadir}/%{name}/sql
72 install docs/create.sql $RPM_BUILD_ROOT%{_datadir}/%{name}/sql
73 #gzip -9nf $RPM_BUILD_ROOT%{_datadir}/%{name}/sql{,/upgrades}/*.sql
74
75 install etc/WebGUI.conf.original $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/WebGUI.conf
76 install etc/spectre.conf.original $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/spectre.conf
77 cp -Prf sbin www $RPM_BUILD_ROOT%{_datadir}/%{name}
78 cp -Prf lib/{Spectre,WebGUI} $RPM_BUILD_ROOT%{perl_vendorlib}
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc docs/{changelog,credits.txt,gotcha.txt,install.txt,legal.txt}
86 %dir %{_sysconfdir}/%{name}
87 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/WebGUI.conf
88 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/spectre.conf
89 %{_datadir}/%{name}
90 %dir %{perl_vendorlib}/WebGUI
91 %{perl_vendorlib}/WebGUI/*.pm
92 %dir %{perl_vendorlib}/WebGUI/AdSpace
93 %{perl_vendorlib}/WebGUI/AdSpace/*.pm
94 %dir %{perl_vendorlib}/WebGUI/Asset
95 %{perl_vendorlib}/WebGUI/Asset/*.pm
96 %dir %{perl_vendorlib}/WebGUI/Asset/File
97 %{perl_vendorlib}/WebGUI/Asset/File/*.pm
98 %dir %{perl_vendorlib}/WebGUI/Asset/Post
99 %{perl_vendorlib}/WebGUI/Asset/Post/*.pm
100 %dir %{perl_vendorlib}/WebGUI/Asset/Template
101 %{perl_vendorlib}/WebGUI/Asset/Template/*.pm
102 %dir %{perl_vendorlib}/WebGUI/Asset/Wobject
103 %{perl_vendorlib}/WebGUI/Asset/Wobject/*.pm
104 %dir %{perl_vendorlib}/WebGUI/Asset/Wobject/HttpProxy
105 %{perl_vendorlib}/WebGUI/Asset/Wobject/HttpProxy/*.pm
106 %dir %{perl_vendorlib}/WebGUI/Auth
107 %{perl_vendorlib}/WebGUI/Auth/*.pm
108 %dir %{perl_vendorlib}/WebGUI/Cache
109 %{perl_vendorlib}/WebGUI/Cache/*.pm
110 %dir %{perl_vendorlib}/WebGUI/Commerce
111 %{perl_vendorlib}/WebGUI/Commerce/*.pm
112 %dir %{perl_vendorlib}/WebGUI/Commerce/Item
113 %{perl_vendorlib}/WebGUI/Commerce/Item/*.pm
114 %dir %{perl_vendorlib}/WebGUI/Commerce/Payment
115 %{perl_vendorlib}/WebGUI/Commerce/Payment/*.pm
116 %dir %{perl_vendorlib}/WebGUI/Commerce/Shipping
117 %{perl_vendorlib}/WebGUI/Commerce/Shipping/*.pm
118 %dir %{perl_vendorlib}/WebGUI/Form
119 %{perl_vendorlib}/WebGUI/Form/*.pm
120 %dir %{perl_vendorlib}/WebGUI/Help
121 %{perl_vendorlib}/WebGUI/Help/*.pm
122 %dir %{perl_vendorlib}/WebGUI/i18n
123 %{perl_vendorlib}/WebGUI/i18n/*.pm
124 %dir %{perl_vendorlib}/WebGUI/i18n/English
125 %{perl_vendorlib}/WebGUI/i18n/English/*.pm
126 %dir %{perl_vendorlib}/WebGUI/Image
127 %{perl_vendorlib}/WebGUI/Image/*.pm
128 %dir %{perl_vendorlib}/WebGUI/Image/Graph
129 %{perl_vendorlib}/WebGUI/Image/Graph/*.pm
130 %dir %{perl_vendorlib}/WebGUI/Image/Graph/XYGraph
131 %{perl_vendorlib}/WebGUI/Image/Graph/XYGraph/*.pm
132 %dir %{perl_vendorlib}/WebGUI/Inbox
133 %{perl_vendorlib}/WebGUI/Inbox/*.pm
134 %dir %{perl_vendorlib}/WebGUI/Macro
135 %{perl_vendorlib}/WebGUI/Macro/*.pm
136 %dir %{perl_vendorlib}/WebGUI/Mail
137 %{perl_vendorlib}/WebGUI/Mail/*.pm
138 %dir %{perl_vendorlib}/WebGUI/Operation
139 %{perl_vendorlib}/WebGUI/Operation/*.pm
140 %dir %{perl_vendorlib}/WebGUI/Search
141 %{perl_vendorlib}/WebGUI/Search/*.pm
142 %dir %{perl_vendorlib}/WebGUI/Session
143 %{perl_vendorlib}/WebGUI/Session/*.pm
144 %dir %{perl_vendorlib}/WebGUI/SQL
145 %{perl_vendorlib}/WebGUI/SQL/*.pm
146 %dir %{perl_vendorlib}/Spectre
147 %{perl_vendorlib}/Spectre/*.pm
148 %dir %{perl_vendorlib}/WebGUI/Storage
149 %{perl_vendorlib}/WebGUI/Storage/*.pm
150 %dir %{perl_vendorlib}/WebGUI/Workflow
151 %{perl_vendorlib}/WebGUI/Workflow/*.pm
152 %dir %{perl_vendorlib}/WebGUI/Workflow/Activity
153 %{perl_vendorlib}/WebGUI/Workflow/Activity/*.pm
This page took 0.087229 seconds and 3 git commands to generate.