]> git.pld-linux.org Git - packages/VisualOS.git/blob - VisualOS.spec
- updated gettext BR
[packages/VisualOS.git] / VisualOS.spec
1 #
2 # TODO:
3 # - add png icon for VisualOS
4 #
5 # Conditional build:
6 %bcond_without  pdf_docs        # don't build pdf documentation
7 #
8 %define         _doc_ver        1.0.0
9
10 Summary:        Visual simulator of and operating system
11 Summary(pl.UTF-8):      Wizualny symulator systemu operacyjnego
12 Name:           VisualOS
13 Version:        1.0.5
14 Release:        2
15 License:        GPL
16 Group:          Applications/Emulators
17 Source0:        http://dl.sourceforge.net/visualos/%{name}-%{version}.tar.gz
18 # Source0-md5:  db0db4fe4251038fcfe0b2e7f5feefa4
19 Source1:        http://dl.sourceforge.net/visualos/%{name}-%{_doc_ver}-docs-pdf.tar.gz
20 # Source1-md5:  c1523518371ec80a9df17476a298ca5f
21 Source2:        %{name}.desktop
22 URL:            http://visualos.sourceforge.net/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  gettext-tools
26 BuildRequires:  gnome-libs-devel
27 BuildRequires:  libglade-gnome-devel
28 BuildRequires:  libtool
29 BuildRequires:  transfig
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 VisualOS is an "visual simulator of and operating system", that will
34 help study and understand the way a real sistem works.
35
36 It allows the user to insert processes in the running system,
37 assigning them properties (memory usage, processing bursts, IO
38 accesses) and VisualOS will dynamically show different graphical
39 representations of each subsystem. It is also posible to select the
40 algorithm to be used in each case.
41
42 %description -l pl.UTF-8
43 VisualOS jest "wizualnym symulatorem systemu operacyjnego", który
44 pomaga studiować i zrozumieć jak działa prawdziwy system operacyjny.
45
46 Pozwala użytkownikowi wstawiać procesy do uruchomionego systemu,
47 przypisywać im właściwości (wykorzystanie pamięci, procesora, IO) a
48 VisualOS będzie dynamicznie pokazywać reprezentacje każdego
49 podsystemu. Można także wybrać algorytm do wykorzystania w każdym
50 przypadku.
51
52 %package doc-pdf
53 Summary:        VisualOS documentation, PDF format
54 Summary(pl.UTF-8):      Dokumentacja do VisualOS w formacie PDF
55 Group:          Documentation
56 Requires:       %{name} = %{version}-%{release}
57
58 %description doc-pdf
59 VisualOS documentation in PDF format.
60
61 %description doc-pdf -l pl.UTF-8
62 Dokumentacja do VisualOS w formacie PDF.
63
64 %prep
65 %setup -q -a1
66
67 %build
68 sed -e s/AM_GNOME_GETTEXT/AM_GNU_GETTEXT/ configure.in > configure.in.tmp
69 mv -f configure.in.tmp configure.in
70 rm -f missing
71 %{__libtoolize}
72 %{__gettextize}
73 %{__aclocal} -I m4
74 %{__autoconf}
75 %{__automake}
76 %configure
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT%{_desktopdir}
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
87
88 %find_lang %{name}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files -f %{name}.lang
94 %defattr(644,root,root,755)
95 %doc README TODO NEWS ChangeLog
96 %attr(755,root,root) %{_bindir}/*
97 %{_datadir}/%{name}
98 %{_desktopdir}/%{name}.desktop
99
100 %if %{with pdf_docs}
101 %files doc-pdf
102 %defattr(644,root,root,755)
103 %doc %{name}-%{_doc_ver}/docs/*
104 %endif
This page took 0.05965 seconds and 4 git commands to generate.