]> git.pld-linux.org Git - packages/VirtualBox.git/commitdiff
up to 5.0.6 auto/th/VirtualBox-5.0.6-1
authorJan Palus <atler@pld-linux.org>
Mon, 19 Oct 2015 19:34:05 +0000 (21:34 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 19 Oct 2015 19:34:05 +0000 (21:34 +0200)
- remove Virtualbox-vnc patch (applied in this release)
- add new upstream patch for broken moc path detection

VirtualBox-moc.patch [new file with mode: 0644]
VirtualBox-vnc.patch [deleted file]
VirtualBox.spec

diff --git a/VirtualBox-moc.patch b/VirtualBox-moc.patch
new file mode 100644 (file)
index 0000000..f859b74
--- /dev/null
@@ -0,0 +1,37 @@
+--- configure.old      2015-10-02 14:46:38.000000000 +0200
++++ configure  2015-10-19 21:12:04.440451289 +0200
+@@ -1591,20 +1591,18 @@
+           cnf_append "PATH_SDK_QT4_LIB" '$'"(firstword `strip_L "$LIBQT4"`)"
+           if [ "$foundqt4" = "2" ]; then
+             cnf_append "VBOX_WITH_QT4_SUN" "1"
+-          elif [ "$foundqt4" = "3" ]; then
+-            cnf_append "VBOX_PATH_QT4" "$TOOLQT4"
+-            cnf_append "PATH_SDK_QT4" "$TOOLQT4"
+-            cnf_append "PATH_TOOL_QT4_BIN" "$TOOLQT4BIN"
+-            return
++          fi
++          if ! [ "$foundqt4" = "3" ]; then
++            TOOLQT4BIN="$TOOLQT4/bin"
+           fi
+           test_header "Qt4 devtools"
+           # try it with a suffix, some platforms use that
+-          if which_wrapper "$TOOLQT4/bin/moc-qt4" > /dev/null; then
++          if which_wrapper "$TOOLQT4BIN/moc-qt4" > /dev/null; then
+             QT4BINSUFF="-qt4"
+           else
+             QT4BINSUFF=""
+           fi
+-          moc_ver=`$TOOLQT4/bin/moc$QT4BINSUFF -v 2>&1|sed 's+^.*(Qt \(.*\))+\1+'`
++          moc_ver=`$TOOLQT4BIN/moc$QT4BINSUFF -v 2>&1|sed 's+^.*(Qt \(.*\))+\1+'`
+           if [ $? -ne 0 ]; then
+             log_failure "moc$QT4BINSUFF not working"
+             fail
+@@ -1612,7 +1610,7 @@
+             log_success "found version $moc_ver"
+             cnf_append "VBOX_PATH_QT4" "$TOOLQT4"
+             cnf_append "PATH_SDK_QT4" "$TOOLQT4"
+-            cnf_append "PATH_TOOL_QT4_BIN" "$TOOLQT4/bin"
++            cnf_append "PATH_TOOL_QT4_BIN" "$TOOLQT4BIN"
+             [ -n "$QT4BINSUFF" ] && cnf_append "TOOL_QT4_BIN_SUFF" "$QT4BINSUFF"
+           fi
+         fi
diff --git a/VirtualBox-vnc.patch b/VirtualBox-vnc.patch
deleted file mode 100644 (file)
index fbbd89c..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-------------------------------------------------------------------------
-r57658 | vboxsync | 2015-09-09 12:54:30 +0200 (śro, 09 wrz 2015) | 2 lines
-
-VNC: build fix
-
-
-Index: src/VBox/ExtPacks/VNC/VBoxVNC.cpp
-===================================================================
---- src/VBox/ExtPacks/VNC/VBoxVNC.cpp  (revision 57657)
-+++ src/VBox/ExtPacks/VNC/VBoxVNC.cpp  (revision 57658)
-@@ -103,8 +103,8 @@
-     unsigned char *mScreenBuffer;
-     unsigned char *mFrameBuffer;
-     uint32_t uClients;
--    static DECLCALLBACK(enum rfbNewClientAction) rfbNewClientEvent(rfbClientPtr cl);
--    static DECLCALLBACK(void) vncMouseEvent(int buttonMask, int x, int y, rfbClientPtr cl);
-+    static enum rfbNewClientAction rfbNewClientEvent(rfbClientPtr cl);
-+    static void vncMouseEvent(int buttonMask, int x, int y, rfbClientPtr cl);
-     static void vncKeyboardEvent(rfbBool down, rfbKeySym keySym, rfbClientPtr cl);
-     static void clientGoneHook(rfbClientPtr cl);
-
-------------------------------------------------------------------------
-------------------------------------------------------------------------
-r57690 | vboxsync | 2015-09-10 15:23:58 +0200 (czw, 10 wrz 2015) | 2 lines
-
-Additions/vbox-greeter: build fix
-
-
-Index: src/VBox/Additions/linux/lightdm-greeter/vbox-greeter.cpp
-===================================================================
---- src/VBox/Additions/linux/lightdm-greeter/vbox-greeter.cpp  (revision 57689)
-+++ src/VBox/Additions/linux/lightdm-greeter/vbox-greeter.cpp  (revision 57690)
-@@ -842,7 +842,7 @@
-  * @param   enmPhase
-  * @param   pfnLog
-  */
--static void vboxGreeterLogHeaderFooter(PRTLOGGER pLoggerRelease, RTLOGPHASE enmPhase, PFNRTLOGPHASEMSG pfnLog)
-+static DECLCALLBACK(void) vboxGreeterLogHeaderFooter(PRTLOGGER pLoggerRelease, RTLOGPHASE enmPhase, PFNRTLOGPHASEMSG pfnLog)
- {
-     /* Some introductory information. */
-     static RTTIMESPEC s_TimeSpec;
-
-------------------------------------------------------------------------
index 3eddf495f62b47602caad4b59bf09b624e7121e1..440fe82612d3b06e0af82dc5ab79ec0e0126429b 100644 (file)
@@ -42,19 +42,19 @@ exit 1
 
 %define                qtver   4.8.0
 
-%define                rel             3
+%define                rel             1
 %define                pname           VirtualBox
 Summary:       VirtualBox - x86 hardware virtualizer
 Summary(pl.UTF-8):     VirtualBox - wirtualizator sprzętu x86
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       5.0.4
+Version:       5.0.6
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://download.virtualbox.org/virtualbox/%{version}/%{pname}-%{version}.tar.bz2
-# Source0-md5: 499abc66de7bb74a9117bda75e43ec4d
+# Source0-md5: 30163e68a0d89e9f4590aeb61cd237e5
 Source1:       http://download.virtualbox.org/virtualbox/%{version}/VBoxGuestAdditions_%{version}.iso
-# Source1-md5: 6bec1f5d0bf22841cad08b7973e95588
+# Source1-md5: 51dc71be4e7988547b1a597744b0e33d
 Source2:       vboxservice.init
 Source3:       vboxservice.service
 Source5:       mount.vdi
@@ -78,7 +78,7 @@ Patch11:      18-system-xorg.patch
 Patch12:       %{pname}-all-translations.patch
 Patch13:       x32.patch
 Patch14:       %{pname}-no-scrextend.patch
-Patch15:       %{pname}-vnc.patch
+Patch15:       %{pname}-moc.patch
 URL:           http://www.virtualbox.org/
 %if %{with userspace}
 %ifarch %{x8664}
@@ -935,6 +935,7 @@ dkms remove -m vboxhost -v %{version}-%{rel} --rpm_safe_upgrade --all || :
 %dir %{_libdir}/%{pname}/tools
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTDbgSymCache
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTGzip
+%attr(755,root,root) %{_libdir}/%{pname}/tools/RTHttp
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTLdrFlt
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTManifest
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTRm
This page took 0.178621 seconds and 4 git commands to generate.