]> git.pld-linux.org Git - packages/VirtualBox.git/commitdiff
- fix building kernel modules for 5.18
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 26 May 2022 04:38:58 +0000 (06:38 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 26 May 2022 04:38:58 +0000 (06:38 +0200)
VirtualBox.spec
kernel-5.18.patch [new file with mode: 0644]

index c8ea8bab217c9d77e15003e33fb1b238139fa6b3..0708c408c5148109f10cf6e8a01f86dcde0b1c46 100644 (file)
@@ -89,6 +89,7 @@ Patch16:      %{pname}-no-vboxvideo.patch
 Patch17:       qt5-gl.patch
 Patch18:       qt-detect.patch
 Patch19:       kernel-4.9.256.patch
+Patch20:       kernel-5.18.patch
 URL:           http://www.virtualbox.org/
 %if %{with userspace}
 %ifarch %{x8664}
@@ -574,6 +575,7 @@ tar -zxf guest-modules.tar.gz -C GuestDrivers
 tar -zxf host-modules.tar.gz -C HostDrivers
 cd -
 %patch19 -p1
+%patch20 -p1
 %endif
 
 # using system kBuild package
diff --git a/kernel-5.18.patch b/kernel-5.18.patch
new file mode 100644 (file)
index 0000000..1adcf10
--- /dev/null
@@ -0,0 +1,16 @@
+--- VirtualBox-6.1.34/kernel/HostDrivers/vboxnetflt/linux/VBoxNetFlt-linux.c~  2022-05-25 17:21:29.000000000 +0200
++++ VirtualBox-6.1.34/kernel/HostDrivers/vboxnetflt/linux/VBoxNetFlt-linux.c   2022-05-26 06:36:50.085761576 +0200
+@@ -2310,8 +2310,13 @@
+             {
+                 vboxNetFltDumpPacket(pSG, true, "host", (fDst & INTNETTRUNKDIR_WIRE) ? 0 : 1);
+                 Log6(("vboxNetFltPortOsXmit: pBuf->cb dump:\n%.*Rhxd\n", sizeof(pBuf->cb), pBuf->cb));
++#if RTLNX_VER_MIN(5,18,0)
++                Log6(("vboxNetFltPortOsXmit: netif_rx(%p)\n", pBuf));
++                err = netif_rx(pBuf);
++#else
+                 Log6(("vboxNetFltPortOsXmit: netif_rx_ni(%p)\n", pBuf));
+                 err = netif_rx_ni(pBuf);
++#endif
+                 if (err)
+                     rc = RTErrConvertFromErrno(err);
+             }
This page took 0.100808 seconds and 4 git commands to generate.