- drop non-dist kernel support
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 27 Jan 2015 18:51:05 +0000 (19:51 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 27 Jan 2015 18:51:05 +0000 (19:51 +0100)
VirtualBox.spec

index c0337918c6f8d5c975312c209454d10be144f733..74ddee5eab60f4b18be7bc073219bf8dfdf6f2c7 100644 (file)
@@ -13,7 +13,6 @@
 # Conditional build:
 %bcond_without doc             # don't build the documentation
 %bcond_without debuginfo               # disable debuginfo creation (to save space when compiling)
-%bcond_without dist_kernel     # without distribution kernel
 %bcond_without kernel          # don't build kernel module
 %bcond_without userspace       # don't build userspace package
 %bcond_with    webservice      # webservice (SOAP) support
 %bcond_without dkms            # build dkms package
 %bcond_without verbose
 
-%if %{without kernel}
-%undefine      with_dist_kernel
-%else
-%define                _duplicate_files_terminate_build        0
-%endif
-
 # The goal here is to have main, userspace, package built once with
 # simple release number, and only rebuild kernel packages with kernel
 # version as part of release number, without the need to bump release
@@ -172,7 +165,7 @@ BuildRequires:      xerces-c-devel >= 2.6.0
 BuildRequires: yasm
 BuildRequires: zlib-devel >= 1.2.1
 %endif
-%{?with_dist_kernel:%{expand:%kbrs}}
+%{?with_kernel:%{expand:%kbrs}}
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
 Requires(pre): /usr/bin/getgid
@@ -424,11 +417,9 @@ Requires(post,postun):     /sbin/depmod\
 Requires(post):        systemd-units >= 38\
 Requires:      dev >= 2.9.0-7\
 Requires:      systemd-units >= 38\
-%if %{with dist_kernel}\
 %requires_releq_kernel\
 Requires:      %{releq_kernel -n drm}\
 Requires(postun):      %releq_kernel\
-%endif\
 Provides:      kernel(vboxguest) = %{version}-%{rel}\
 Provides:      kernel(vboxsf) = %{version}-%{rel}\
 Provides:      kernel(vboxvideo) = %{version}-%{rel}\
@@ -453,10 +444,8 @@ Group:             Base/Kernel\
 Requires(post,postun): /sbin/depmod\
 Requires(post):        systemd-units >= 38\
 Requires:      dev >= 2.9.0-7\
-%if %{with dist_kernel}\
 %requires_releq_kernel\
 Requires(postun):      %releq_kernel\
-%endif\
 Requires:      systemd-units >= 38\
 Provides:      kernel(vboxdrv) = %{version}-%{rel}\
 Provides:      kernel(vboxnetadp) = %{version}-%{rel}\
This page took 1.014465 seconds and 4 git commands to generate.