]> git.pld-linux.org Git - packages/VirtualBox.git/blobdiff - VirtualBox.spec
- qt5 now defines GLsizeiptr
[packages/VirtualBox.git] / VirtualBox.spec
index 7517583a8e78d679b3e1edd378be356180806962..cfdd337af9ab2e45f1160664b6ac059e2e71ec23 100644 (file)
@@ -42,19 +42,19 @@ exit 1
 
 %define                qtver   5.6.0
 
-%define                rel             2
+%define                rel             4
 %define                pname           VirtualBox
 Summary:       VirtualBox - x86 hardware virtualizer
 Summary(pl.UTF-8):     VirtualBox - wirtualizator sprzętu x86
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       5.2.8
+Version:       6.0.8
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://download.virtualbox.org/virtualbox/%{version}/%{pname}-%{version}.tar.bz2
-# Source0-md5: e731ea9c5c31096ec4c2a3bfba26665c
+# Source0-md5: 8f703ae98002f9e11dcb29eb01f87718
 Source1:       http://download.virtualbox.org/virtualbox/%{version}/VBoxGuestAdditions_%{version}.iso
-# Source1-md5: 3fb71656e8720342ab6ea4022d3dec9c
+# Source1-md5: 7fab0b92e88b57c19bcc9aa081de245f
 Source2:       vboxservice.init
 Source3:       vboxservice.service
 Source4:       vboxservice.sysconfig
@@ -64,6 +64,8 @@ Source7:      %{pname}-virtualbox-host-modules-load.conf
 Source8:       %{pname}-virtualbox-guest-modules-load.conf
 Source9:       vboxautostart.init
 Source10:      autostart.cfg
+Source11:      vboxclient-vmsvga.service
+Source12:      udev-guest.rules
 Patch0:                %{pname}-version-error.patch
 Patch1:                %{pname}-VBoxSysInfo.patch
 Patch2:                %{pname}-warning_workaround.patch
@@ -81,7 +83,7 @@ Patch13:      %{pname}-no-scrextend.patch
 Patch14:       %{pname}-multipython.patch
 Patch15:       %{pname}-lightdm-1.19.2.patch
 Patch16:       %{pname}-no-vboxvideo.patch
-Patch17:       %{pname}-kerndir.patch
+Patch17:       qt5-gl.patch
 URL:           http://www.virtualbox.org/
 %if %{with userspace}
 %ifarch %{x8664}
@@ -104,6 +106,7 @@ BuildRequires:      xorg-lib-libXrandr-devel
 BuildRequires: xorg-proto-glproto-devel
 BuildRequires: xorg-xserver-server-devel
 %endif
+BuildRequires: EGL-devel
 BuildRequires: OpenGL-GLU-devel
 BuildRequires: OpenGL-devel
 BuildRequires: Qt5Core-devel >= %{qtver}
@@ -145,7 +148,7 @@ BuildRequires:      libxslt-progs >= 1.1.17
 %{?with_lightdm:BuildRequires: lightdm-libs-qt5-devel}
 BuildRequires: makeself
 BuildRequires: mkisofs
-BuildRequires: openssl-devel >= 0.9.8
+BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: pam-devel
 BuildRequires: pixman-devel
 BuildRequires: pkgconfig
@@ -476,10 +479,11 @@ gospodarzem sprzętu PCI.\
 %if %{with kernel}\
 %files -n kernel%{_alt_kernel}-virtualbox-guest\
 %defattr(644,root,root,755)\
+%if %{_kernel_version_code} >= %{_kernel_version_magic 4 16 0}\
+%config(noreplace) %verify(not md5 mtime size) /etc/depmod.d/%{_kernel_ver}/vboxguest.conf\
+%endif\
 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/virtualbox-guest.conf\
-%if %{_kernel_version_code} < %{_kernel_version_magic 4 16 0}\
 /lib/modules/%{_kernel_ver}/misc/vboxguest.ko*\
-%endif\
 /lib/modules/%{_kernel_ver}/misc/vboxsf.ko*\
 %if %{_kernel_version_code} < %{_kernel_version_magic 4 13 0}\
 /lib/modules/%{_kernel_ver}/misc/vboxvideo.ko*\
@@ -510,28 +514,31 @@ gospodarzem sprzętu PCI.\
 export KERN_DIR=%{_kernelsrcdir}\
 cd PLD-MODULE-BUILD/HostDrivers\
 %build_kernel_modules -m vboxdrv -C vboxdrv\
-%build_kernel_modules -m vboxnetadp -C vboxnetadp\
-%build_kernel_modules -m vboxnetflt -C vboxnetflt\
-%build_kernel_modules -m vboxpci -C vboxpci\
+%build_kernel_modules -m vboxnetadp -C vboxnetadp KBUILD_EXTRA_SYMBOLS=$PWD/../vboxdrv/Module.symvers\
+%build_kernel_modules -m vboxnetflt -C vboxnetflt KBUILD_EXTRA_SYMBOLS=$PWD/../vboxdrv/Module.symvers\
+%build_kernel_modules -m vboxpci -C vboxpci KBUILD_EXTRA_SYMBOLS=$PWD/../vboxdrv/Module.symvers\
 cd ../GuestDrivers\
-%if %{_kernel_version_code} < %{_kernel_version_magic 4 16 0}\
 %build_kernel_modules -m vboxguest -C vboxguest\
 cp -a vboxguest/Module.symvers vboxsf\
-%endif\
 %build_kernel_modules -m vboxsf -C vboxsf -c\
 %if %{_kernel_version_code} < %{_kernel_version_magic 4 13 0}\
 %build_kernel_modules -m vboxvideo -C vboxvideo\
 %endif\
 cd ../..\
 %install_kernel_modules -D PLD-MODULE-BUILD/installed -m PLD-MODULE-BUILD/HostDrivers/vboxdrv/vboxdrv,PLD-MODULE-BUILD/HostDrivers/vboxnetadp/vboxnetadp,PLD-MODULE-BUILD/HostDrivers/vboxnetflt/vboxnetflt,PLD-MODULE-BUILD/HostDrivers/vboxpci/vboxpci,PLD-MODULE-BUILD/GuestDrivers/vboxsf/vboxsf -d misc\
-%if %{_kernel_version_code} < %{_kernel_version_magic 4 16 0}\
 %install_kernel_modules -D PLD-MODULE-BUILD/installed -m PLD-MODULE-BUILD/GuestDrivers/vboxguest/vboxguest -d misc\
-%endif\
 %if %{_kernel_version_code} < %{_kernel_version_magic 4 13 0}\
 %install_kernel_modules -D PLD-MODULE-BUILD/installed -m PLD-MODULE-BUILD/GuestDrivers/vboxvideo/vboxvideo -d misc\
 %endif\
 %{nil}
 
+%define install_kernel_pkg()\
+%if %{_kernel_version_code} >= %{_kernel_version_magic 4 16 0}\
+install -d PLD-MODULE-BUILD/installed/etc/depmod.d/%{_kernel_ver}\
+echo override vboxguest %{_kernel_ver} misc > PLD-MODULE-BUILD/installed/etc/depmod.d/%{_kernel_ver}/vboxguest.conf\
+%endif\
+%{nil}
+
 %{?with_kernel:%{expand:%create_kernel_packages}}
 
 %prep
@@ -572,7 +579,7 @@ cd PLD-MODULE-BUILD
 ../src/VBox/Additions/linux/export_modules.sh guest-modules.tar.gz
 tar -zxf guest-modules.tar.gz -C GuestDrivers
 
-../src/VBox/HostDrivers/linux/export_modules.sh host-modules.tar.gz --without-hardening
+../src/VBox/HostDrivers/linux/export_modules.sh --file host-modules.tar.gz --without-hardening
 tar -zxf host-modules.tar.gz -C HostDrivers
 cd -
 %endif
@@ -643,6 +650,7 @@ kmk %{?_smp_mflags}
 %endif
 
 %{?with_kernel:%{expand:%build_kernel_packages}}
+%{?with_kernel:%{expand:%install_kernel_packages}}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -696,6 +704,8 @@ install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxservice
 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/vboxservice.service
 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/vboxservice
 
+cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/vboxclient-vmsvga.service
+
 install -p %{SOURCE9} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxautostart
 %{__sed} -i -e 's#@INSTALL_DIR@#%{_libdir}/%{pname}#' $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxautostart
 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/vbox
@@ -775,6 +785,7 @@ rm -r $RPM_BUILD_ROOT%{_libdir}/%{pname}/icons
 
 %{__mv} $RPM_BUILD_ROOT{%{_libdir}/%{pname},/lib/udev}/VBoxCreateUSBNode.sh
 cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/udev/rules.d/60-vboxdrv.rules
+cp -p %{SOURCE12} $RPM_BUILD_ROOT/etc/udev/rules.d/60-vboxguest.rules
 
 %if %{with dkms}
 mv $RPM_BUILD_ROOT%{_libdir}/%{pname}/src $RPM_BUILD_ROOT%{_usrsrc}/vboxhost-%{version}-%{rel}
@@ -866,6 +877,7 @@ fi
 %update_mime_database
 
 %pre guest
+%useradd -u 336 -d /usr/share/empty -s /bin/false -c "VirtualBox guest additions" -g nobody vboxadd
 # Add a group "vboxsf" for Shared Folders access
 # All users which want to access the auto-mounted Shared Folders have to be added to this group.
 %groupadd -g 266 -r -f vboxsf
@@ -873,17 +885,18 @@ fi
 %post guest
 /sbin/chkconfig --add vboxservice
 %service vboxservice restart
-%systemd_post vboxservice.service
+%systemd_post vboxservice.service vboxclient-vmsvga.service
 
 %preun guest
 if [ "$1" = "0" ]; then
        /sbin/chkconfig --del vboxservice
        %service vboxservice -q stop
 fi
-%systemd_preun vboxservice.service
+%systemd_preun vboxservice.service vboxclient-vmsvga.service
 
 %postun guest
 if [ "$1" = "0" ]; then
+       %userremove vboxadd
        %groupremove vboxsf
 fi
 %systemd_reload
@@ -935,6 +948,7 @@ dkms remove -m vboxhost -v %{version}-%{rel} --rpm_safe_upgrade --all || :
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxDD2.so
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxDDU.so
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxDragAndDropSvc.so
+%attr(755,root,root) %{_libdir}/%{pname}/VBoxGlobal.so
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxGuestControlSvc.so
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxGuestPropSvc.so
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxHostChannel.so
@@ -945,6 +959,7 @@ dkms remove -m vboxhost -v %{version}-%{rel} --rpm_safe_upgrade --all || :
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxPython*.so
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxREM.so
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxRT.so
+%attr(755,root,root) %{_libdir}/%{pname}/VBoxSVGA3D.so
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxSharedClipboard.so
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxSharedCrOpenGL.so
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxSharedFolders.so
@@ -973,6 +988,8 @@ dkms remove -m vboxhost -v %{version}-%{rel} --rpm_safe_upgrade --all || :
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxVMMPreload
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxVolInfo
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxXPCOMIPCD
+%attr(755,root,root) %{_libdir}/%{pname}/VirtualBoxVM
+%attr(755,root,root) %{_libdir}/%{pname}/bldRTLdrCheckImports
 %attr(755,root,root) %{_libdir}/%{pname}/iPxeBaseBin
 %if %{with doc}
 %attr(755,root,root) %{_libdir}/%{pname}/VBoxManageHelp
@@ -980,11 +997,14 @@ dkms remove -m vboxhost -v %{version}-%{rel} --rpm_safe_upgrade --all || :
 %dir %{_libdir}/%{pname}/tools
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTCat
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTChMod
+%attr(755,root,root) %{_libdir}/%{pname}/tools/RTCp
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTDbgSymCache
+%attr(755,root,root) %{_libdir}/%{pname}/tools/RTFuzzMaster
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTGzip
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTHttp
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTIsoMaker
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTKrnlModInfo
+%attr(755,root,root) %{_libdir}/%{pname}/tools/RTLdrCheckImports
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTLdrFlt
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTLs
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTManifest
@@ -994,6 +1014,7 @@ dkms remove -m vboxhost -v %{version}-%{rel} --rpm_safe_upgrade --all || :
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTShutdown
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTSignTool
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTTar
+%attr(755,root,root) %{_libdir}/%{pname}/tools/RTTraceLogTool
 %attr(755,root,root) %{_libdir}/%{pname}/tools/RTUnzip
 %attr(755,root,root) %{_libdir}/%{pname}/tools/scm
 
@@ -1009,11 +1030,8 @@ dkms remove -m vboxhost -v %{version}-%{rel} --rpm_safe_upgrade --all || :
 %{_libdir}/%{pname}/ExtensionPacks/Oracle_VBoxDTrace_Extension_Pack/linux*/VBoxDTraceR0.debug
 %{_libdir}/%{pname}/ExtensionPacks/Oracle_VBoxDTrace_Extension_Pack/linux*/VBoxDTraceR0.r0
 
+%{_libdir}/%{pname}/VBoxBugReport
 %{_libdir}/%{pname}/VBoxCpuReport
-%{_libdir}/%{pname}/VBoxDD2R0.debug
-%{_libdir}/%{pname}/VBoxDD2R0.r0
-%{_libdir}/%{pname}/VBoxDD2RC.debug
-%{_libdir}/%{pname}/VBoxDD2RC.rc
 %{_libdir}/%{pname}/VBoxDDRC.debug
 %{_libdir}/%{pname}/VBoxDDRC.rc
 %{_libdir}/%{pname}/VBoxDDR0.debug
@@ -1037,7 +1055,7 @@ dkms remove -m vboxhost -v %{version}-%{rel} --rpm_safe_upgrade --all || :
 
 %dir %{_datadir}/%{pname}
 
-%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/*.rules
+%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/60-vboxdrv.rules
 %attr(755,root,root) /lib/udev/VBoxCreateUSBNode.sh
 
 %if %{with gui}
@@ -1103,8 +1121,10 @@ dkms remove -m vboxhost -v %{version}-%{rel} --rpm_safe_upgrade --all || :
 %attr(754,root,root) /etc/rc.d/init.d/vboxservice
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/vboxservice
 %{systemdunitdir}/vboxservice.service
+%{systemdunitdir}/vboxclient-vmsvga.service
 %attr(755,root,root) %{_bindir}/VBoxControl
 %attr(755,root,root) %{_bindir}/VBoxService
+%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/60-vboxguest.rules
 
 %files guest-x11
 %defattr(644,root,root,755)
This page took 0.044554 seconds and 4 git commands to generate.