]> git.pld-linux.org Git - packages/VirtualBox.git/blobdiff - VirtualBox.spec
- blah, correct paths for Qt4 stuff
[packages/VirtualBox.git] / VirtualBox.spec
index 795eeb3671b9eb142aa9182b23441a33804e34e6..4306bca8d442ce3c6a1a5e9a06a764b29a9627f9 100644 (file)
@@ -10,8 +10,9 @@
 %bcond_without dist_kernel     # without distribution kernel
 %bcond_without kernel          # don't build kernel module
 %bcond_without userspace       # don't build userspace package
+%bcond_with    verbose
 
-%define                rel             3
+%define                rel             0.1
 
 %if %{without kernel}
 %undefine      with_dist_kernel
 %undefine      with_userspace
 %endif
 
+%if "%{pld_release}" != "ti"
+%define                __ucc   gcc-3.4
+%else
+%define                __ucc   %{__cc}
+%endif
+
 %define                pname   VirtualBox
 
 Summary:       VirtualBox OSE - x86 hardware virtualizer
 Summary(pl.UTF-8):     VirtualBox OSE - wirtualizator sprzętu x86
 Name:          %{pname}%{_alt_kernel}
-Version:       1.6.2
+Version:       2.0.0
 Release:       %{rel}
 License:       GPL v2
 Group:         Applications/Emulators
-Source0:       http://www.virtualbox.org/download/%{version}/%{pname}-%{version}-OSE.tar.bz2
-# Source0-md5: 0372a3a31326078f7849a0467d547a70
-Source1:       http://www.virtualbox.org/download/%{version}/UserManual.pdf
-# Source1-md5: 32505857b575f0fb6f71ba1738c1e102
-Source2:       http://www.virtualbox.org/download/%{version}/VBoxGuestAdditions_%{version}.iso
-# Source2-md5: 3cac7e911e545038102ff641cba66365
+Source0:       http://download.virtualbox.org/virtualbox/%{version}/%{pname}-%{version}-OSE.tar.bz2
+# Source0-md5: 1f53ebed0f55df129f6cf72dba646c3a
+Source1:       http://download.virtualbox.org/virtualbox/%{version}/UserManual.pdf
+# Source1-md5: cf65a8164a18f7200520c1ec3399a918
+Source2:       http://download.virtualbox.org/virtualbox/%{version}/VBoxGuestAdditions_%{version}.iso
+# Source2-md5: ae0512b8db853fdea9fc262fc04bd242
 Source3:       %{pname}-vboxdrv.init
 Source4:       %{pname}-vboxadd.init
 Source5:       %{pname}.desktop
@@ -45,6 +52,7 @@ Patch1:               %{pname}-qt-paths.patch
 Patch2:                %{pname}-shared-libstdc++.patch
 Patch3:                %{pname}-disable-xclient-build.patch
 Patch4:                %{pname}-configure-spaces.patch
+Patch5:                %{pname}-gcc.patch
 URL:           http://www.virtualbox.org/
 %if %{with userspace}
 BuildRequires: SDL-devel >= 1.2.7
@@ -53,13 +61,15 @@ BuildRequires:      bash
 BuildRequires: bcc
 BuildRequires: bin86
 BuildRequires: gcc >= 5:3.2.3
+%if "%{pld_release}" != "ti"
+BuildRequires: compat-gcc-34
+%endif
 BuildRequires: iasl
 %endif
 %if %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.20
 %endif
 %if %{with userspace}
-BuildRequires: Qt3Support-devel
 BuildRequires: libIDL-devel
 BuildRequires: libpng >= 1.2.5
 BuildRequires: libstdc++-devel >= 5:3.2.3
@@ -71,7 +81,6 @@ BuildRequires:        pkgconfig
 BuildRequires: pulseaudio-devel >= 0.9.0
 BuildRequires: qt-devel >= 6:3.3.6
 BuildRequires: qt-linguist
-BuildRequires: qt4-build >= 4.2.0
 %endif
 BuildRequires: rpmbuild(macros) >= 1.379
 %if %{with userspace}
@@ -150,7 +159,7 @@ Summary:    udev rules for VirtualBox OSE kernel modules
 Summary(pl.UTF-8):     Reguły udev dla modułów jądra Linuksa dla VirtualBoksa
 Release:       %{rel}
 Group:         Base/Kernel
-Requires:      udev
+Requires:      udev-core
 
 %description udev
 udev rules for VirtualBox OSE kernel modules.
@@ -252,6 +261,7 @@ Sterownik grafiki dla systemu gościa w VirtualBoksie.
 %endif
 
 %patch4 -p1
+%patch5 -p0
 
 cat <<'EOF' > udev.conf
 KERNEL=="vboxdrv", NAME="%k", GROUP="vbox", MODE="0660"
@@ -276,9 +286,11 @@ sed -i -e '/#.*define.*RTMEMALLOC_EXEC_HEAP/d' vboxadd/r0drv/linux/alloc-r0drv-l
 ./configure \
        --with-gcc="%{__cc}" \
        --with-g++="%{__cxx}" \
+       --disable-qt4 \
        --disable-kmods
 
-. ./env.sh && kmk -j1
+. ./env.sh && \
+kmk -j1 VBOX_RECOMPILER_OP_GCC_PLD_COMPAT="%{__ucc}"
 %endif
 
 %if %{with kernel}
This page took 0.137349 seconds and 4 git commands to generate.