]> git.pld-linux.org Git - packages/VirtualBox.git/blobdiff - VirtualBox.spec
deps for guest initscripts
[packages/VirtualBox.git] / VirtualBox.spec
index 3b790e609ad1199f3269ed4922e43b674c180df8..3c13c26bb2a6f2e04db8355858ffe60e996c67b3 100644 (file)
 %define                _enable_debug_packages  0
 %endif
 
-%define                rel             10
+%define                rel             7
 %define                pname           VirtualBox
 Summary:       VirtualBox - x86 hardware virtualizer
 Summary(pl.UTF-8):     VirtualBox - wirtualizator sprzętu x86
 Name:          %{pname}%{_alt_kernel}
-Version:       4.2.10
+Version:       4.2.12
 Release:       %{rel}
 License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://download.virtualbox.org/virtualbox/%{version}/%{pname}-%{version}.tar.bz2
-# Source0-md5: 99349df34caacdecbb7cf3908631c3f3
+# Source0-md5: 654e45054ae6589452508d37403dc800
 Source1:       http://download.virtualbox.org/virtualbox/%{version}/VBoxGuestAdditions_%{version}.iso
-# Source1-md5: e49046cd56398f9f9b8410154f1a0393
+# Source1-md5: 403098e688f9e7f4273de680f6734983
+Source2:       vboxservice.init
 Source3:       %{pname}-vboxdrv.init
 Source4:       %{pname}-vboxguest.init
 Source5:       %{pname}-vboxnetflt.init
@@ -66,6 +67,7 @@ Patch2:               %{pname}-warning_workaround.patch
 Patch3:                %{pname}-dri.patch
 Patch4:                %{pname}-disable_build_NetBiosBin.patch
 Patch5:                xserver-1.12.patch
+Patch6:                gcc48.patch
 # ubuntu patches
 Patch10:       16-no-update.patch
 Patch11:       18-system-xorg.patch
@@ -150,6 +152,8 @@ Requires(pre):      /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires:      QtCore >= 4.7.0
 Requires:      desktop-file-utils
+Requires:      fontconfig
+Requires:      fonts-Type1-urw
 Requires:      libvncserver >= 0.9.9
 Requires:      udev-core
 Suggests:      gxmessage
@@ -251,19 +255,34 @@ This package contains ISO9660 image with drivers for Guest OS.
 You should install this package in your Host OS.
 
 %package guest
+Summary:       VirtualBox Guest tools
+Group:         Base
+Requires(post,preun):  /sbin/chkconfig
+Requires:      rc-scripts
+Suggests:      kernel(vboxguest)
+Suggests:      kernel(vboxsf)
+
+%description guest
+Tools that utilize kernel modules for supporting integration with the
+Host, including file sharing.
+
+You should install this package in your Guest OS for base VirtualBox
+communication
+
+%package guest-x11
 Summary:       VirtualBox Guest Additions
 Group:         Base
+Requires:      %{name}-guest = %{version}-%{release}
 Requires:      xorg-driver-video-vboxvideo = %{version}-%{release}
-Suggests:      kernel%{_alt_kernel}-misc-vboxsf = %{version}-%{rel}@%{_kernel_ver_str}
-Suggests:      kernel%{_alt_kernel}-misc-vboxvideo = %{version}-%{rel}@%{_kernel_ver_str}
+Suggests:      kernel(vboxvideo)
 Obsoletes:     xorg-driver-input-vboxmouse < %{version}-%{release}
 
-%description guest
-Tools that utilize kernel modules for supporting integration with the
-Host, including file sharing and tracking of mouse pointer movement
-and X.org X11 video and mouse driver.
+%description guest-x11
+Tools for X11 session that utilize kernel modules for supporting
+integration with the Host, like tracking of mouse pointer movement and
+X.org X11 video and mouse drivers
 
-You should install this package in your Guest OS.
+You should install this package in your Guest OS for X11 session.
 
 %package -n pam-pam_vbox
 Summary:       PAM module to perform automated guest logons
@@ -495,6 +514,7 @@ Moduł jądra Linuksa dla VirtualBoksa - sterownik obsługi DRM.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 
 %{__sed} -i -e 's,@VBOX_DOC_PATH@,%{_docdir}/%{name}-%{version},' \
        -e 's/Categories=.*/Categories=Utility;Emulator;/' src/VBox/Installer/common/virtualbox.desktop.in
@@ -661,6 +681,7 @@ cp -p src/VBox/Additions/x11/Installer/vboxclient.desktop \
 
 %if %{with kernel}
 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,modules-load.d},%{_sbindir},%{systemdunitdir}}
+install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxservice
 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxdrv
 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxguest
 install -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxnetflt
@@ -733,6 +754,16 @@ if [ "$1" = "0" ]; then
        %groupremove vbox
 fi
 
+%post guest
+/sbin/chkconfig --add vboxservice
+%service vboxservice restart
+
+%postun guest
+if [ "$1" = "0" ]; then
+       /sbin/chkconfig --del vboxservice
+       %service vboxservice -q stop
+fi
+
 %post  -n kernel%{_alt_kernel}-misc-vboxdrv
 %depmod %{_kernel_ver}
 %vbox_kernel_post -d vboxdrv VirtualBox Support Driver
@@ -973,12 +1004,16 @@ fi
 
 %files guest
 %defattr(644,root,root,755)
+%attr(754,root,root) /etc/rc.d/init.d/vboxservice
+%attr(755,root,root) %{_bindir}/VBoxControl
+%attr(755,root,root) %{_bindir}/VBoxService
+
+%files guest-x11
+%defattr(644,root,root,755)
 # NOTE: unfinished, should contain .desktop files for starting up mouse
 # integration and other desktop services
 # NOTE: the filelist is incomplete too
 %attr(755,root,root) %{_bindir}/VBoxClient
-%attr(755,root,root) %{_bindir}/VBoxControl
-%attr(755,root,root) %{_bindir}/VBoxService
 /etc/X11/xinit/xinitrc.d/98vboxadd-xclient.sh
 /etc/xdg/autostart/vboxclient.desktop
 
This page took 0.038516 seconds and 4 git commands to generate.