]> git.pld-linux.org Git - packages/VirtualBox.git/blobdiff - VirtualBox-export_modules.patch
- identify our build as _PLD, see http://www.virtualbox.org/wiki/Editions
[packages/VirtualBox.git] / VirtualBox-export_modules.patch
index d46050cbc6f081099dcad3df8a7370d92384afd3..3f7122601fa639b597eb2c20a9d0ab87b33addfb 100644 (file)
@@ -1,96 +1,18 @@
---- /dev/null  2009-01-22 12:52:06.498125436 +0100
-+++ VirtualBox-2.1.0/src/VBox/HostDrivers/Support/linux/export_modules 2008-09-01 14:23:30.000000000 +0200
-@@ -0,0 +1,93 @@
-+#!/bin/sh
-+
-+#
-+# Create a tar archive containing the sources of the vboxdrv kernel module
-+#
-+# Copyright (C) 2007 Sun Microsystems, Inc.
-+#
-+# This file is part of VirtualBox Open Source Edition (OSE), as
-+# available from http://www.virtualbox.org. This file is free software;
-+# you can redistribute it and/or modify it under the terms of the GNU
-+# General Public License (GPL) as published by the Free Software
-+# Foundation, in version 2 as it comes in the "COPYING" file of the
-+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
-+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
-+#
-+# The contents of this file may alternatively be used under the terms
-+# of the Common Development and Distribution License Version 1.0
-+# (CDDL) only, as it comes in the "COPYING.CDDL" file of the
-+# VirtualBox OSE distribution, in which case the provisions of the
-+# CDDL are applicable instead of those of the GPL.
-+#
-+# You may elect to license modified versions of this file under the
-+# terms and conditions of either the GPL or the CDDL or both.
-+#
-+# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa
-+# Clara, CA 95054 USA or visit http://www.sun.com if you need
-+# additional information or have any questions.
-+#
-+
-+if [ -z "$1" ]; then
-+    echo "Usage: $0 <filename.tar.gz> [--without-hardening]"
-+    echo "  Export VirtualBox kernel modules to <filename.tar.gz>"
-+    exit 1
-+fi
-+
-+VBOX_WITH_HARDENING=1
-+if [ "$2" = "--without-hardening" ]; then
-+    VBOX_WITH_HARDENING=
-+fi
-+
-+PATH_TMP="`cd \`dirname $1\`; pwd`/.vbox_modules"
-+PATH_OUT=$PATH_TMP
-+FILE_OUT="`cd \`dirname $1\`; pwd`/`basename $1`"
-+PATH_ROOT="`cd \`dirname $0\`/../../../../..; pwd`"
-+PATH_VBOXDRV="$PATH_ROOT/src/VBox/HostDrivers/Support"
-+
-+VBOX_VERSION_MAJOR=`sed -e "s/^ *VBOX_VERSION_MAJOR *= \+\([0-9]\+\)/\1/;t;d" $PATH_ROOT/Config.kmk`
-+VBOX_VERSION_MINOR=`sed -e "s/^ *VBOX_VERSION_MINOR *= \+\([0-9]\+\)/\1/;t;d" $PATH_ROOT/Config.kmk`
-+VBOX_VERSION_BUILD=`sed -e "s/^ *VBOX_VERSION_BUILD *= \+\([0-9]\+\)/\1/;t;d" $PATH_ROOT/Config.kmk`
-+VBOX_VERSION_STRING=$VBOX_VERSION_MAJOR.$VBOX_VERSION_MINOR.$VBOX_VERSION_BUILD
-+
-+. $PATH_VBOXDRV/linux/files_vboxdrv
-+
-+# Temporary path for creating the modules, will be removed later
-+mkdir $PATH_TMP || exit 1
-+
-+# Create auto-generated version file, needed by all modules
-+echo "#ifndef __version_generated_h__" > $PATH_TMP/version-generated.h
-+echo "#define __version_generated_h__" >> $PATH_TMP/version-generated.h
-+echo "" >> $PATH_TMP/version-generated.h
-+echo "#define VBOX_VERSION_MAJOR $VBOX_VERSION_MAJOR" >> $PATH_TMP/version-generated.h
-+echo "#define VBOX_VERSION_MINOR $VBOX_VERSION_MINOR" >> $PATH_TMP/version-generated.h
-+echo "#define VBOX_VERSION_BUILD $VBOX_VERSION_BUILD" >> $PATH_TMP/version-generated.h
-+echo "#define VBOX_VERSION_STRING \"$VBOX_VERSION_STRING\"" >> $PATH_TMP/version-generated.h
-+echo "" >> $PATH_TMP/version-generated.h
-+echo "#endif" >> $PATH_TMP/version-generated.h
-+
-+# vboxdrv (VirtualBox host kernel module)
-+mkdir $PATH_TMP/vboxdrv || exit 1
-+for f in $FILES_VBOXDRV_NOBIN; do
-+    install -D -m 0644 `echo $f|cut -d'=' -f1` "$PATH_TMP/vboxdrv/`echo $f|cut -d'>' -f2`"
+--- VirtualBox-3.1.8_OSE/src/VBox/Additions/linux/export_modules.orig  2010-05-10 08:45:29.000000000 +0200
++++ VirtualBox-3.1.8_OSE/src/VBox/Additions/linux/export_modules       2010-05-16 14:15:16.321158339 +0200
+@@ -71,6 +73,15 @@
+     install -D -m 0755 `echo $f|cut -d'=' -f1` "$PATH_TMP/vboxsf/`echo $f|cut -d'>' -f2`"
+ done
++# vboxvideo_drm (VirtualBox guest kernel module for DRI)
++mkdir $PATH_TMP/vboxvideo_drm || exit 1
++for f in $FILES_VBOXVIDEO_DRM_NOBIN; do
++    install -D -m 0644 `echo $f|cut -d'=' -f1` "$PATH_TMP/vboxvideo_drm/`echo $f|cut -d'>' -f2`"
 +done
-+for f in $FILES_VBOXDRV_BIN; do
-+    install -D -m 0755 `echo $f|cut -d'=' -f1` "$PATH_TMP/vboxdrv/`echo $f|cut -d'>' -f2`"
++for f in $FILES_VBOXVIDEO_DRM_BIN; do
++    install -D -m 0755 `echo $f|cut -d'=' -f1` "$PATH_TMP/vboxvideo_drm/`echo $f|cut -d'>' -f2`"
 +done
-+sed -e "s;_VERSION_;$VBOX_VERSION_STRING;g" < $PATH_VBOXDRV/linux/build_in_tmp > $PATH_TMP/vboxdrv/build_in_tmp
-+chmod 0755 $PATH_TMP/vboxdrv/build_in_tmp
-+sed -e "s;_VERSION_;$VBOX_VERSION_STRING;g" < $PATH_VBOXDRV/linux/dkms.conf > $PATH_TMP/vboxdrv/dkms.conf
-+if [ -n "$VBOX_WITH_HARDENING" ]; then
-+    cat                                   $PATH_VBOXDRV/linux/Makefile > $PATH_TMP/vboxdrv/Makefile
-+else
-+    sed -e "s;-DVBOX_WITH_HARDENING;;g" < $PATH_VBOXDRV/linux/Makefile > $PATH_TMP/vboxdrv/Makefile
-+fi
-+
-+# Only temporary, omit from archive
-+rm $PATH_TMP/version-generated.h
-+
-+# Create the archive
-+tar -czf $FILE_OUT -C $PATH_TMP . || exit 1
-+
-+# Remove the temporary directory
-+rm -r $PATH_TMP
 +
+ # Only temporary, omit from archive
+ rm $PATH_TMP/version-generated.h
This page took 0.055987 seconds and 4 git commands to generate.