]> git.pld-linux.org Git - packages/VirtualBox.git/blame_incremental - VirtualBox.spec
- VirtualBox is now licensed under GPLv2 so here is spec for it
[packages/VirtualBox.git] / VirtualBox.spec
... / ...
CommitLineData
1#
2# TODO:
3# - Doesn't compile without /usr/src/linux/include/linux/autoconf.h so one must
4# symlink it before building package. This is because during compilation kernel
5# module is being build. Since we are building kernel modules later
6# sources/makefiles probably needs some hacking to drop this requirement.
7# - Home page says that some addons should be compiled, I don't see any except.
8# vboxaddon kernel module and {vboxmouse,vboxvideo)_drv.so. Are they required?
9# - BR list was a quickie so it may be incomplete or too big.
10# - R list probably required.
11# - .desktop file, some wrapper to launch VirtualBox (LD_LIBRARY_PATH must include
12# %{_libdir}/VirtualBox), maybe some init script to launch VBoxSVC.
13# - Devel stuff is not packaged yet.
14# - Now its EA ix86 amd64, but looking into autogenerated env.sh suggests that
15# code may be compiled exclusively for i686. Probably x86_64 must be put in EA for Th.
16#
17# Conditional build:
18%bcond_without dist_kernel # without distribution kernel
19%bcond_without smp # without SMP kernel modules
20#
21%define _snap 20070116
22Summary: VirtualBox
23Summary(pl): VirtualBox
24Name: VirtualBox
25Version: 1.3.3
26Release: 0.1
27License: GPL v2
28Group: Applications/Emulators
29Source0: %{name}-%{version}_%{_snap}.tar.bz2
30# Source0-md5: 8554cf552c3ad07b2ae5229c3f8825dc
31Patch0: %{name}-configure.patch
32Patch1: %{name}-qt-paths.patch
33URL: http://www.virtualbox.org/
34BuildRequires: SDL-devel
35BuildRequires: bcc
36BuildRequires: bin86
37BuildRequires: gcc >= 3.2.3
38BuildRequires: iasl
39%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7}
40BuildRequires: libIDL-devel
41BuildRequires: libuuid-devel
42BuildRequires: libxslt-devel
43BuildRequires: qt-devel
44BuildRequires: rpmbuild(macros) >= 1.329
45BuildRequires: xalan-c-devel
46BuildRequires: xcursor-devel
47BuildRequires: xerces-c-devel
48BuildRequires: zlib-devel
49ExclusiveArch: %{ix86} amd64
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52%description
53InnoTek VirtualBox is a general-purpose full virtualizer for x86
54hardware. Targeted at server, desktop and embedded use, it is now the
55only professional-quality virtualization solution that is also Open
56Source Software.
57
58Some of the features of VirtualBox are:
59
60Modularity: VirtualBox has an extremely modular design with
61well-defined internal programming interfaces and a client/server
62design. This makes it easy to control it from several interfaces at
63once: for example, you can start a virtual machine in a typical
64virtual machine GUI and then control that machine from the command
65line. VirtualBox also comes with a full Software Development Kit: even
66though it is Open Source Software, you don't have to hack the source
67to write a new interface for VirtualBox.
68
69Virtual machine descriptions in XML: the configuration settings of
70virtual machines are stored entirely in XML and are independent of the
71local machines. Virtual machine definitions can therefore easily be
72ported to other computers.
73
74%description -l pl
75